sftp used to work, now it doesn't

Discussion in 'Jailbreaks and iOS Hacks' started by joseftu, Feb 8, 2008.

  1. joseftu macrumors member

    Joined:
    Jul 6, 2007
    #1
    Or rather, sometimes it works, but only very slowly.

    Anyone run across this?

    I've got OpenSSH and BSD subsystem installed, I've got the Mac and the iPhone on the same wifi network, I'm using the correct username and password and IP address. I've tried Transmit and Cyberduck both. I've even reinstalled all OpenSSH and BSD, with plenty of restarting.

    In fact, I know all that is correct, because sometimes it's working fine--but always slower than it used to be. On some tries, it eventually connects (and I'm not talking about the host keys problem), but then changing directories takes so long that it eventually times out. Other times, it won't even connect at all.

    Transmit gives a "could not connect to server" "permission denied" error. But I'm not sure that's meaningful at all. Cyberduck just tells me it's timed out.

    Anyone experience this? Nothing has changed on the iPhone or the Mac, but all of a sudden it just barely wants to make an sftp connection. Any ideas?
     
  2. brando88 macrumors 6502

    Joined:
    Nov 13, 2007
    #2
    What firmware are you running, and what version of BSD do you have?
     
  3. joseftu thread starter macrumors member

    Joined:
    Jul 6, 2007
    #3
    I've got firmware 1.1.2 and BSD 2.0
     
  4. joseftu thread starter macrumors member

    Joined:
    Jul 6, 2007
    #4
    no suggestions, huh? How will I get my new ebooks installed?! :(
     
  5. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #5
    What iPhone firmware you have?
     
  6. joseftu thread starter macrumors member

    Joined:
    Jul 6, 2007
    #6
    See above. It's 1.1.2 .

    (and it's always worked fine in 1.1.2)
     
  7. enero@serpico50 macrumors newbie

    Joined:
    Jun 26, 2005
    #7
    I'm having the same problem!

    I'm running 1.1.4 with BSD 2.0 and openSSH 4.6p1-2

    Everything worked fine a week ago. Never had any issues connecting through fetch. Now, I keep getting the same "permission denied" error. I have tried this on multiple machines and with different FTP apps. Nothing seems to help. I have tried reinstalling BSD and openSSH.

    Anything come about with this? This is really frustrating!
     
  8. PACMAC macrumors regular

    PACMAC

    Joined:
    Feb 24, 2008
    #8
    make sure you on SFTP..and check your iphones IP adress same as the one that you have on your cyber duck...you do have boss prefs installed correct..? thats easy to use and tells your ip adress ..

    hope that works
     
  9. enero@serpico50 macrumors newbie

    Joined:
    Jun 26, 2005
    #9
    Yep, yep, all that, of course :)

    I actually figured it out. It was BSD 2.0 Just seemed to stop working, and installer didnt notify me that there was a 2.1. So I reinstalled, and all was well again!
     
  10. penter macrumors 6502a

    penter

    Joined:
    Jun 15, 2006
    #10
    I'm having the same problem.....

    I Pwned my 2.0.1 iPod, and installed OpenSSH
    Transmit won't allow me to SSH into my iPod because the of the "Permission denied" error :confused:
    I'm sure i have all the imformaton correct, though:

    Server: xxx.xxx.xxx.xxx

    User Name: root

    Password: alpine

    Initial Path: /

    Port: 22

    Protocol SFTP

    What am I missing??

    EDIT: So I typed into terminal: ssh root@xxx.xxx.xxx.xxx
    this is what i got :eek::eek::eek:

    What is this??!! PLEASE, someone help me...
     

Share This Page