Sierra wifi

Discussion in 'macOS Sierra (10.12)' started by donaldcroberto, Sep 24, 2016.

  1. donaldcroberto macrumors newbie

    Joined:
    May 19, 2016
    #1
    Unable to automatically connect to wifi from sleep mode.
     
  2. idome macrumors newbie

    Joined:
    Sep 24, 2016
    #2
    Same problem with mid 2011 imac, after wakeup from sleep mode wifi not connect automatically, like it should do.
     
  3. pmwybo macrumors newbie

    Joined:
    Jul 15, 2011
    #3
    hope someone has the answer as i have the exact same issue. iMac 11,2 which was connecting to wifi fine until i upgraded to Sierra and now i have to reconnect each time
     
  4. vrDrew macrumors 65816

    Joined:
    Jan 31, 2010
    Location:
    Midlife, Midwest
    #4
    This has been a real bugbear for me too. I'm seriously regretting installing Sierra as a result. Every time I want to use my iMac after waking from sleep mode, it takes almost a minute to reconnect to wifi.

    Any word on possible solutions to this?
     
  5. SoxFan894, Sep 27, 2016
    Last edited: Sep 27, 2016

    SoxFan894 macrumors newbie

    Joined:
    Jun 15, 2011
    #5
  6. vrDrew macrumors 65816

    Joined:
    Jan 31, 2010
    Location:
    Midlife, Midwest
    #6
    I tried the same steps, and ended up with an absolute disaster, requiring a complete reinstall from my TimeMachine backup. Don't do this.

    My situation is a little unusual (but hardly unique) in that I'm accessing an ATT U-Verse router and live in an area where my Mac is seeing at least a dozen or so different potential WiFi networks.

    It's a relatively minor inconvenience, but still frustrating.
     
  7. SoxFan894 macrumors newbie

    Joined:
    Jun 15, 2011
    #7
    Good to know, I was about to perform the other reset steps. But won't now, guess we will need to wait on a release from apple.

    i'm following the thread so if you find a way to fix please post and like wise for me.
     
  8. nylon macrumors 6502a

    nylon

    Joined:
    Oct 26, 2004
    #8
  9. OceanRider macrumors newbie

    Joined:
    Nov 14, 2013
    #9
    I have the same WiFi does not reconnect after sleep issue with a mid 2011 imac 21.5". Also tried solutions to no avail.
     
  10. SoxFan894 macrumors newbie

    Joined:
    Jun 15, 2011
    #10
    I attempted to just do the robot in safe mode. Seemed to work for a few hours and then when back to its same issue. Heres hoping they fix this on a 10.12.1
     
  11. vrDrew macrumors 65816

    Joined:
    Jan 31, 2010
    Location:
    Midlife, Midwest
    #11
    I've found that since 10.12.1 was installed the issue of losing wifi connectivity during sleep mode seems to have greatly diminished. If you are still having problems losing a connection, and haven't installed 10.12.1 - do it now, and chances are you'll find this fixes the problem.
     
  12. donaldcroberto thread starter macrumors newbie

    Joined:
    May 19, 2016
    #12
    Same here, although it does take 3 to 5 seconds to sync with my router. Thanks.
     
  13. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #13
    I'm getting similar issues, though it only happens to me when I'm VPN'ed. If the laptop goes to sleep, and I reconnect via VPN, it will lose its ability to connect.
     
  14. SoxFan894 macrumors newbie

    Joined:
    Jun 15, 2011
    #14
    Hey, i know this is a old forum post, please bump if its been resolved. but has this been addressed and fixed with any other updates with Sierra? I downgraded to 10.11
     
  15. donaldcroberto thread starter macrumors newbie

    Joined:
    May 19, 2016
    #15
    --- Post Merged, Dec 8, 2016 ---
    I upgraded to sierra 10.12.1 which took care of the problem except that connection to the net takes up to 10 seconds.
    Thanks.
     
  16. SoxFan894 macrumors newbie

    Joined:
    Jun 15, 2011
    #16
    I updated to 10.12 but still have wifi issues. It goes dark and won't stay connected, so there for Plex does not show the server (comp). Any insights?
     

Share This Page