Siri not reading my texts

Discussion in 'iPhone' started by sadcaper, Oct 14, 2011.

  1. sadcaper macrumors member

    Joined:
    Jun 28, 2007
    #1
    When I've gotten a new text I ask Siri to read it and it appears she understands my request because she goes silent for a bit and then asks if I want to read it again or reply. It's weird. Everything else is working great with Siri.

    Anything else I need to do so she'll read my texts?
     
  2. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #2
    I'm wondering this too. I was under the impression Siri would do both speech-to-text and text-to-speech. Am I wrong?
     
  3. chris459 macrumors member

    Joined:
    Jun 8, 2009
    Location:
    Miami, Florida
    #3
    Go to settings notifications and make sure under messages you have show preview on
     
  4. DerekTS macrumors regular

    Joined:
    Oct 7, 2011
    #4
    It works fine for me. Siri has had no problem reading me texts to far.
     
  5. macingman macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    You have to wait 5-8 seconds for it to read it you I've noticed.
     
  6. DerekTS macrumors regular

    Joined:
    Oct 7, 2011
    #6
    Siri reads mine almost instantly...
     
  7. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
  8. Danarc macrumors member

    Joined:
    Oct 29, 2008
  9. lw9090 macrumors regular

    Joined:
    Jul 31, 2008
    #9
    Notifications setting

    I think this is the solution. I did some testing with it on and off.
     
  10. sadcaper thread starter macrumors member

    Joined:
    Jun 28, 2007
    #10
    Ahhh this would make sense as I do have preview off. Thanks!
     
  11. johna1234 macrumors member

    Joined:
    Oct 14, 2011
    #11
    hmm cant get this to work, message preview on, but not working.
     
  12. neile45 macrumors regular

    Joined:
    Jul 27, 2011
    #12
    yeah, my preview is on, and it's not working either. I tried the accessibility, and that changes the finger gestures. If I have to do that, I will leave it off
     
  13. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #13
    As with others here, I've got show preview on, but it's not reading the messages to me. Anyone have any idea how to get Siri to actually read a text message to you? Maybe I'm just not activating it the correct way? When I get a text, do I need to hold down the home button to activate Siri and then she'll read it to me?

    ----------

    Nevermind. I figured it out. You just have to hold down the home button to activate Siri and then tell her to read you the text message and she does. Very nice!
     
  14. Hankster macrumors 68020

    Hankster

    Joined:
    Jan 30, 2008
    Location:
    Washington DC
    #14
    If you already read the message it won't read it. Siri only reads new unread messages.
     
  15. Stangs55 macrumors 6502a

    Stangs55

    Joined:
    Jul 3, 2007
    Location:
    The Lone Star State
    #15
    This.

    I also wish she could read messages/emails to me. For example, if I open up an email (while driving...shhh, don't tell) and see that it's longer than I though, I'd like Siri to read it to me while I keep my eyes on the road.
     
  16. nfl46 macrumors 603

    Joined:
    Oct 5, 2008
    #16
    Siri can you read you text messages without you saying, "Read my text messages."

    You have to enabled it though.

    General
    Accessibility
    VoiceOver
    Speak Notifications

    http://www.youtube.com/watch?v=KLR_-9tvq6A

    Go to 1 minute mark.
     
  17. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #17
    See how at the end right when she got a new message from Sandy Chang it read to it to her without her saying anything?

    How does mine do that? Mine won't
     
  18. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #18
    The problem with doing it this way is by turning on VoiceOver, you enable Siri to read every button you touch and you have to double-tap to open anything. If you just hold down the home button and tell Siri to read, she'll read the text without all those other problems.

    ----------

    As far as I can tell, Siri will only do that if you enable VoiceOver in Accessibility as mentioned above. But then you've got the problems I listed above. The easiest way, as far as I can find, is to just activate Siri and ask her to read.
     
  19. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #19
    Got it. That video is false ad! Just kidding but still, it should read it right away like the video.
     
  20. fdot macrumors regular

    Joined:
    Feb 2, 2008
    #20
    i enabled the notifications and now it reads it but that is stupid, i don't want my text to pop up on my screen but i do want it to read it to me
     
  21. unobtainium macrumors 68000

    Joined:
    Mar 27, 2011
    #21
    Yes, this is indeed stupid. I want Siri to read texts while I'm driving, but that doesn't mean that I want previews to pop up for anyone to read while my phone is sitting on my desk. I get that Apple is trying to preserve privacy here, but the logic seems a bit flawed.
     
  22. TM WAZZA macrumors 68000

    Joined:
    Sep 18, 2010
    Location:
    Hamilton, New Zealand
    #22
    So how does siri read out messages with wrong spellings, and shortcut texts?
     
  23. Trissa macrumors newbie

    Joined:
    Nov 11, 2011
    #23
    Siri wasn't reading my messages. I turned on "Show Preview" in Notifications>Messages and it worked. I turned it off again and it still works. I guess turning it on and off fixed the problem.
     
  24. Jayl1475 macrumors newbie

    Joined:
    Nov 13, 2011
    #24
    Sort of solution

    The way I done it was to click on triple click home screen button through accessibility. You can then choose toggle voice over. This means I don't need to keep going into settings to turn it on and off. Plus means I don't need to suffer the double clicking everything.

    Hope it sort of helps.
     
  25. thatoneguy82 macrumors 68000

    thatoneguy82

    Joined:
    Jul 23, 2008
    Location:
    Beach Cities, CA
    #25
    Like many have said the way to fix this is turning preview on for text messages. I had this same problem and kept trying it on/off. However, I do find it inconvenient that I have to turn on the preview to have Siri read it. I really don't want one for the other, I'd rather have both. I don't want to leave my phone unattended with a text message that's visible. Sounds like a bug or something they should work on.
     

Share This Page