Siri Remote no longer working properly

Discussion in 'Apple TV and Home Theater' started by CriticalCatalyst, May 20, 2018.

  1. CriticalCatalyst macrumors newbie

    Joined:
    May 20, 2018
    #1
    I did find a similar thread on here, but none of the solutions worked and I didn't want to raise it from the dead.

    My Siri remote no longer works. I'm not certain what version of Apple TV I have, but it's at least 2 years old now. The buttons still work just fine, but using even a simple swiping gesture no longer works very well. I can get it to work maybe every 5-6 swipes, and to get anything done has been a test of patient. I have restarted the Apple TV a few times now, charged the remote overnight, and reset and repaired the remote. Nada. However, I did download a remote app (the only one that works over bluetooth) and that works perfectly. Is buying a new Siri remote the only thing I can do?
     
  2. levander macrumors newbie

    Joined:
    Jul 21, 2011
    #2
    Maybe someone will post that knows more about it than I.

    But one thing you didn’t mention that I would try is calling Apple technical support. They’ve helped me out for free before when I wasn’t under warranty. But the only thing they’ll know about is common fixes. If there is no common fix, they won’t know and probably wont help. I would be shocked if they sent you a new remote just to be nice guys like some companies would.
     
  3. CriticalCatalyst thread starter macrumors newbie

    Joined:
    May 20, 2018
    #3
    Alright, I called Apple tech support and they did help me out. Though, they said with all the Apple devices I own, they were going to make an exemption and replace my Siri remote for free. They even called the local Apple store to see if they would honor it (they will) so I don't have to have a hold placed on my bank account while waiting for the new remote to get here and the old one to arrive.
     
  4. -Gonzo- macrumors 6502

    -Gonzo-

    Joined:
    Nov 14, 2015
    #4
    When my Siri remote went all laggy the only thing that worked for me was to change the Chroma setting from 4:4:4 to 4:2:0.
    Why I wouldn’t know as I’ve even paired my TV4 remote and that had the same issue so I’d say it’s not actually the remote but the TV itself.
     

Share This Page