Sleep Wake Failure

Discussion in 'macOS Sierra (10.12)' started by ImperialForces, Oct 31, 2016.

  1. ImperialForces macrumors member

    #1
    Every night when I'm asleep my computer will restart by itself and give me a sleep wake crash report. I followed the apple forums, resetting the pram, starting is safe mode, and even did a first aid via disk repair. The only USB connectors are from my keyboard and the lighting and 30 pin connector to my iPhone and iPod, respectively.

    My mac is a 2012 27 inch rocking 32gb of ram with a nvidia 680mx. Why? Is this happening to you guys that have installed sierra?
     
  2. Whiskey27 macrumors newbie

    Joined:
    Aug 7, 2016
    #2
    Crazy! I know.....Started when I installed Sierra. I've done everything that has been suggested, to no avail! BUT! I have stumbled onto something and I have not had the SLEEP/WAKE FAILURE since! I created a new admim account for myself and deleted my old admin account. In doing so, I did not save anything concerning my deleted account,
    NOTHING! .....You will be given options on what to do with the old account. Give it a try! Good luck!
     
  3. ImperialForces thread starter macrumors member

    #3
    Okay thank you!
     
  4. codelode84 macrumors regular

    codelode84

    Joined:
    Oct 10, 2011
    Location:
    Cincinnati, OH
    #4
    I'm having this issue since I installed the beta. Then once the main release came out it kept doing it. An apple advisor showed me how to fix it deleting files, but it was a temporary fixed. Then I started the computer completely over and it has slowly crept back. I believe it is truly an os bug.
     
  5. Keleko macrumors 68000

    Joined:
    Mar 26, 2008
    #5
    I'm having this issue, too, with my new 2016 15" MBP.
     
  6. ImperialForces thread starter macrumors member

    #6
    I manually backed up my files (not time machine) and nuked my computer from orbit. It worked - no more sleep wake failures.
     
  7. alazhaarp, Dec 23, 2016
    Last edited: Dec 23, 2016

    alazhaarp macrumors member

    Joined:
    Sep 17, 2014
    Location:
    Halle, Germany
    #7
    I don't know if I have a similar case (or issue).
    So after I updated to 10.12.2, I only turned off my mid-2012 13 inch MacBook Pro twice (I rarely turn my MacBook pro off). I turned it off because I had to make a bus trip. But after the trip I'm always stuck in boot loading screen after I entered my password. It usually stops at around 75%.

    I tried resetting the pram, starting is safe mode, and did a first aid via disk repair too, but nothing works so far. I don't think it's a hardware issue because my windows 10 bootcamp partition boots just fine.

    Do you guys think I should nuke my computer too? Or is there any other way?
    Thank you

    P.s. I know my computer is old, and it has been used extensively. But before this problem occurred, I've never had any performance issue whatsoever.. (Including with 10.12.2)
     
  8. Keleko macrumors 68000

    Joined:
    Mar 26, 2008
    #8
    I determined that if I unplug both the USB 3 and TB 2 drives, it sleeps and wakes without failing. So it is something to do with the external drives plugged in.
     
  9. SRTM macrumors regular

    Joined:
    Dec 11, 2011
    #9
    having this issue. only have an external monitor + power plugged in.
     
  10. KJL3000 macrumors 6502

    KJL3000

    Joined:
    Oct 13, 2010
    #10
    Same here, MacBook Pro 15" mid 2010 with DIY FusionDrive. I found out that a fresh install on an external USB stick seems to work without any sleep wake issues. I think the FusionDrive could be the problem, but seeing some of you having that issue on new 2016 machines let me doubt it...
     
  11. tommiy macrumors newbie

    Joined:
    Dec 11, 2015
    #11
  12. TD912 macrumors newbie

    Joined:
    Nov 22, 2008
    #12

    Having the same issue here with a 2010 15" MBP and "homebrew" Fusion Drive. It keeps happening in Sierra. It started working fine again for a while in the 10.12.3 betas, but I upgraded to the final release and it's starting to happen again. Not sure if there's any way around this, or if it's just because something they changed in Sierra doesn't like DIY Fusion Drives...
     
  13. KJL3000, Jan 25, 2017
    Last edited: Jan 25, 2017

    KJL3000 macrumors 6502

    KJL3000

    Joined:
    Oct 13, 2010
    #13
  14. sguser macrumors regular

    Joined:
    Aug 12, 2010
    #14
    Same here on 2016 13''. It's as a replacement unit, the same was happening on the original one as well. In my case the failure happens only in the following sequence:
    Mac is attached to an LG 21'' display. If I unplug the Mac from the monitor and open the lid, that would case macOS to crash. It doesn't happen in other scenarios.
     
  15. TD912 macrumors newbie

    Joined:
    Nov 22, 2008
    #15
    Actually, a quick update: It seems like it's working fine again? It did the restart thing once or twice after the upgrade to 10.12.3, but it seems to be sleeping properly now. I still can't completely tell if it was the DIY Fusion Drive or something else that was causing it as I didn't go through the whole process of removing a drive and reinstalling everything. Strange...
     
  16. KJL3000 macrumors 6502

    KJL3000

    Joined:
    Oct 13, 2010
    #16
    UPDATE:
    the 10.12.3 Update didn't fix it for me, so I reinstalled macOS: I created an external usb sierra installer and booted from there to use terminal and delete the DIY Fusion drive. Then I reinstalled sierra on the HDD to get a recovery partition, then i recreated a fresh FusionDrive with the SSD and the newly built Mac Partition on the HDD. Then I reinstalled Sierra on that Fusiondrive again and restored from timemachine Backup.

    No more crashes on sleep so far!

    So in conclusion, i guess reinstalling macOS is the key, I don't think rebuilding the Fusion Drive is even neccessary, but i like the idea of a fresh drive to install on. :) Most important thing: the issue does not get restored by timemachine! ;)
     
  17. sguser macrumors regular

    Joined:
    Aug 12, 2010
    #17
    There is a theory that FileVault has its hand in the crashes. So does your HDD has FV enabled?
     
  18. TD912 macrumors newbie

    Joined:
    Nov 22, 2008
    #18
    I'll have to try this when I have enough time. I thought the issue somehow fixed itself, but it looks like it's back again.
     
  19. KJL3000 macrumors 6502

    KJL3000

    Joined:
    Oct 13, 2010
    #19
    No FileVault at any time...
     

Share This Page