Slight lag on iPhone 7

Discussion in 'iPhone' started by gbi, Sep 17, 2016.

  1. gbi macrumors newbie

    Joined:
    Jan 2, 2013
    #1
    Hi all,

    Got my iP7 Silver 128GB yesterday afternoon and really liking it so far.

    I set up the new phone by restoring a backup of my 6S.

    Overall performance is good but I cannot help but notice a slight lag in some screens, for example when scrolling inside Mail app or closing an app to return to the Home screen.

    Has anyone else noticed this issue ad what suggestions would you have?

    Thanks!
     
  2. SumYoungGai macrumors 6502a

    Joined:
    Jun 11, 2013
    Location:
    SF Bay Area, CA
    #2
    Give it a couple days to settle down.
     
  3. Jal217 macrumors regular

    Jal217

    Joined:
    Oct 28, 2015
    #3
    Definitely give it a few days, your phone is doing a lot of behind the scenes stuff for a couple days after you get it. Also I've been using ios10 since beta 1 and I think it's the best operating system yet. The only thing negative I have to say is that the animations aren't perfect yet even after release.
     
  4. piecookie macrumors member

    Joined:
    Oct 22, 2012
    #4
    I use a 5 year old backup and it runs everything perfectly smooth.
     
  5. gkingha macrumors member

    gkingha

    Joined:
    May 2, 2016
    Location:
    Canada
    #5

    No lag for me, just tried it out with mail app. Best of luck.
     
  6. KingArthurVI macrumors regular

    KingArthurVI

    Joined:
    Dec 17, 2011
    Location:
    Minneapolis, MN
    #6
    Not sure if people noticed but this is only on 7, not 7+. The lag is pretty noticeable on the app exit animation, the frame drops are terrible
     
  7. MattXDA macrumors 6502

    MattXDA

    Joined:
    Aug 18, 2014
    Location:
    UK
    #7
    It's the 7+ too - it doesn't happen EVERY time but most times to skips frames or something when returning to home screen. It's not obvious that it's lag, looks like a tweaked animation but it's not
     
  8. boxrick macrumors newbie

    Joined:
    Sep 16, 2016
    Location:
    Manchester
    #8
    There is a definite lag on the 7 compared to the 6s. It doesn't even show pages as fast.

    This is what I get on mine.

     
  9. MattXDA macrumors 6502

    MattXDA

    Joined:
    Aug 18, 2014
    Location:
    UK
    #9
    Here's what I get on mine. On the video, the first 2 times it lags then the last 3 times it's smooth.

     
  10. pcrispy macrumors newbie

    pcrispy

    Joined:
    Sep 17, 2016
    Location:
    Marion, IN
    #10
    I have a 7 Plus and have the same slight animation glitch every time I go from an app back to the home screen. Never had that on the 6s Plus with iOS 10, but this is something a simple OS update will likely resolve. Same with screen colors being more yellow, since it appears to be completely normal for everyone, an OS update typically is release shortly after new devices and fixes all those things.
     
  11. Lakailb87 macrumors regular

    Joined:
    Jul 11, 2008
    Location:
    San Francisco
    #11
    Yup I notice the stutter when going back to the home screen. It also seems like the home button works slower than my 6.. there is a delay from when I press it and something happens, even more so when double tapping
     
  12. MattXDA macrumors 6502

    MattXDA

    Joined:
    Aug 18, 2014
    Location:
    UK
    #12
    For me there's less of a delay - when I double press the home button the screen has already started closing so it has to spring back up into multitasking. It's like it doesn't wait a few milliseconds to see if I'm going to double peess
     
  13. boxrick macrumors newbie

    Joined:
    Sep 16, 2016
    Location:
    Manchester
    #13
    My worry here is this is the BIG.Little nonsense. My old galaxy s6 had all sorts of issues which were never resolved due to shoddy hardware.

    The battery life benefits were pretty much negligible, but performance always horribly suffered.

    There is no excuse, especially when the 6S is more or less spot on.
     
  14. alisalem macrumors member

    Joined:
    Apr 12, 2013
    Location:
    Dubai, UAE
  15. KingArthurVI macrumors regular

    KingArthurVI

    Joined:
    Dec 17, 2011
    Location:
    Minneapolis, MN
    #15
    Hmm you guys are right about the lag not being as obvious on 3rd try and beyond. Seems like it's the low powered cores not being able to handle the animation, which is a shame
     
  16. Bathplug macrumors 6502a

    Joined:
    Jul 12, 2010

Share This Page