SLOW internet on NEW MacBook Pro

Discussion in 'MacBook Pro' started by martymartin, Nov 20, 2008.

  1. martymartin macrumors newbie

    Jul 15, 2008
    I am experiencing an INCREDIBLY slow internet connection via wi-fi on my new MacBook Pro. Not only that, but I am lucky if my laptop will even stay connected to my router or if I can get it to reconnect. I just upgraded to the new model from the previous 17" model and i never had this issue. In fact, I just opened my old MacBook Pro and NO problems at all.

    Anyone else experiencing this?
  2. FinalCutJay macrumors member

    Nov 4, 2008
    yeap me too. my wireless router is on the floor in my closet in my room. i get full signal strength and yet it takes forever for a page to load up if it does at all. my ibook is lightening fast, and when i plug in my MBP via ethernet it's perfect.

    i cannot figure out what is causing the issue. maybe the router itself?
  3. puma1552 macrumors 601

    Nov 20, 2008
    maybe the fact it's in your closet and the computer is aluminum?
  4. martymartin thread starter macrumors newbie

    Jul 15, 2008
    I am using my new MacBook Pro just as I used my old one. And it shows a very strong signal but often takes MINUTES to download one page. My friend just bought the new MacBook and brought it to my place, and it does the same thing too. I think this is a problem with this new line of MacBooks.
  5. lucasgladding macrumors 6502

    Feb 16, 2007
    Waterloo, Ontario
    Make sure your service order has been set up. That simple problem has caused unresponsive connections in the past for me. If anyone is unfamiliar with this, the settings can be found under System Preferences - Network. Click the gear icon in the lower left and select Set Service Order. I usually set AirPort, Ethernet, Bluetooth, etc in that order.
  6. eddyhttp macrumors regular

    Oct 15, 2008
    i had the same issue with you. my computer was working fine then i took it to my brother's place and connected to his router. when i got back to college it was extremely slow even with excellent connection. after working hard to find the reason, i found a post on google on the forums.
    the fix..
    go to networks, advance, dns, and remove the new dns server that wasn't there before. i guess my computer made a new dns for his router.

    bam the internet is fast as ever!

    i was about to do a full system restore : ( lol
  7. tsa1 macrumors regular

    Nov 8, 2008
    quick question, what kind of routers are best for macs other than airports. I used to have a belkin N router which would never connect to my ps3 and my my friends SR Mbp although it worked ok with my iPod touch.

    Now I'm using a d-link wbr-2310 which is a G router but works way better with my ps3 and iPod touch. It just seems ever router brand just plain sucks! Perhaps it's just my house I'm about 30 ft from my router which is downstairs, would I have a better signal moving it to a room closer beneath me, since I can't bring it upstairs using all my cable outlets haha.
  8. chrono1081 macrumors 604


    Jan 26, 2008
    Isla Nublar
    I used to work for Circuit Citys firedog and bestbuys geeksquad setting up wireless networks all the time and I remember the belkin routers being absolutely terrible. Not once, not twice, but about 6 different times of being forced to call their tech support the first suggestion a rep told me was to "try another brand router". WHAT!?

    I always found linksys, netgear, and dlink to work best with macs (and in general). This was years ago however so things may have changed since then.
  9. macrem macrumors 65816


    Mar 11, 2008
    Btw I'd suggest making sure you guys update to the latest firmware on your routers.
  10. rolex54 macrumors 6502

    Aug 20, 2007
    Houston, TX
    are you dropping any packets?
    open network utility and ping like 20 times
    see if you have any packet loss
  11. gauwow macrumors newbie

    Jul 4, 2008
    Ok.. I've seen a solution to this a while back so give it a shot....

    for your DNS entry type your router address as the first entry and below that type the following 2 entries and

    try that and see if it works... if that doesn't work just type and
  12. MBPDiva macrumors regular

    Nov 1, 2008
    on Orion's Belt
    I had one horrible experience with a Belkin N router. After consulting with their tech support for hours, they denied any known issues with Belkin routers and MacBooks. I returned the Belkin and bought a Linksys N from Circuit City. Setup was a breeze!! Now I am always connected and the speeds are amazing! :) My advice: do not install the LELA wizard! You can set up without it and it needlessly installs crap on your computer and messes around with your registry settings!
  13. jmbentle macrumors newbie

    Jun 19, 2009

    I don't know you, but I LOVE you. This worked beautifully on my new MBP, and it's now officially my dream machine! :apple:

    (By the way, folks, Apple Support told me to go out and buy a new router--mine is a Belkin G--to fix this problem, but try changing your DNS settings before spending more money!)
  14. mtbiac macrumors newbie

    Jun 13, 2009
    I've been having the same problems. When plugged into hard line ethernet cable, no problems at all, but when using airport (N) I get dropped every 15min WTF! (this is at a school, but at home, ethernet is literally 20x faster than airport, but airport never drops). I'm not talking like gigabit connections vs N, I'm talking 100kb/sec on N vs 1+mb/s via ethernet....

    ANYWAY, do I type these numbers into my router or under Network>Airport>Advanced>DNS?


    (I tried the Airport settings and I havent seen any change in speed :(, any other suggestions????)
  15. SonicRage macrumors newbie

    May 29, 2007
    Better yet, find out what the DNS servers are for your local ISP in your area and add them to the list.
  16. imthekuni macrumors member

    Jun 6, 2009
  17. -tWv- macrumors 68000


    May 11, 2009
    Network>Airport>Advanced>DNS. This immediately changed the speed of my internet. Try it
  18. spaceboots06 macrumors 6502a


    Jun 13, 2009
    The Rotten Apple
    Ping has started ...

    PING (**.***.**.***): 56 data bytes

    --- ping statistics ---
    10 packets transmitted, 0 packets received, 100% packet loss
  19. imthekuni macrumors member

    Jun 6, 2009
    I remember reading somewhere that it has to do with the way IPv4 and IPv6 DNS addresses work. I experienced this problem when switching to Safari 4 Beta, but have since repaired it by switching to the openDNS addresses
  20. mtbiac macrumors newbie

    Jun 13, 2009
    I can't even get the openDNS stuff to work because in DNS, I have 3 DNS addresses greyed out unable to delete, which means these bypass the openDNS servers after I add them. I tried deleting the airport setup and creating a new one, but as soon as it connects to the router, all of the DNS stuff gets added automatically (damn Comcast!!)

    any ideas on how to use openDNS? grrrr
    I need to use it on my actual computer and not router because I have these problems elsewhere as well...I'm not always at home

  21. SFStateStudent macrumors 604


    Aug 28, 2007
    San Francisco California, USA
    Same problem on this end Belkin N router and drops the signal every 10-15 minutes. I've had a friend stop by from BB and work it out with updates, but the thing is totally updated. I'll try changing those numbers; if that doesn't work I'm buying a new router and shipping this one back to BB or else just throw it on their door step.....:(:(:(
  22. tempusfugit macrumors 65816

    May 21, 2009
    the problem you're having might be ISP related. outgoing requests from new macs request ipv6 records even though a lot of times its not completely necessary. I had problems on a comcast connection with a new imac a year ago.

    what I did was I changed the DNS settings in my router control panel and manually set alternate dns servers other than the default comcast ones. These handle the more complicated ipv6 requests just fine with no loss of roundtrip packet speed. I used the servers available for free at and it completely fixed my problem.

    set your dns servers to:

    hopefully this helps some of you!
  23. sdsvtdriver macrumors 65816

    Jul 31, 2008
    Southern California
    make sure you are scan for channels and set to ones not used.

    if using N, make it N only, 40mhz, wide, 5ghz.

    if it is still slow, set router to G, channel 1,6,11. if it works fine, probably is interference. 5ghz does not penetrate walls as well as 2.4. set N to 2.4, but use channel 1,6, or 11, depending on what is free in your area.
  24. mtbiac macrumors newbie

    Jun 13, 2009
    stupid comcast has "Greyed" out my default comcast DNS server addresses such that I cannot delete them, so even when I add the openDNS dns servers in airport settings, they are below the comcast ones, and the comcast ones get used first and openDNS never works. How can I remove these!!?? I've tried everything, driving me insane! Damn Comcast :mad:
  25. tsa1 macrumors regular

    Nov 8, 2008
    I added to my dns on my MBP, should i at it to my FIOS router at home too in the router menu? also do those other DNS (208.XXX etc...) work anywhere? or do i have to go to to get specific ones for my location?

    Also, at work we have a Dlink wireless N router, nothing special, but it had good range. Could i just add the DNS servers to my macbook pro, or would i still have to make a openDNS account?

Share This Page