bobright

macrumors 601
Original poster
Jun 29, 2010
4,776
25
Is it just me or is there lag in Safari page loading? I am even having some pages macrumors for instance just give me a blank white page at times. I was on another forum and the page only loaded halfway. It's been a disaster for me, never had any of these problems prior to updating. Smh
 

hovscorpion12

macrumors 68000
Sep 12, 2011
1,627
593
USA
Yes, Same here on iPhone 5S and iPad 4. Waiting until work tomorrow to test their Wi-Fi to see if its the same. If it is then iOS 8 bug.
 
Comment

sanke1

macrumors 65816
Nov 9, 2010
1,067
435
I am wondering if the lag has deliberately been introduced to prevent frequent Safari crashing or tabs reloading.

But apart from stuttering keyboard coming up while tapping address bar, Safari feels slightly improved overall. We need to give more time to Apple to iron out few niggles.
 
Comment

OHCasper

macrumors newbie
Jul 6, 2010
21
0
All apps seem much slower over wifi on both iPhone 5s and iPad Mini. Same apps over LTE are fine. I thought my wifi was acting up, but both computers in the house are fine. My wife's iPhone which hasn't been upgraded to iOS 8 is also fine. Also noticed when in Safari on wifi the spinning activity icon next to the wifi icon rarely if ever goes away. Normally it's only there during page loads.
 
Comment

Yun0

macrumors 68000
Jun 12, 2013
1,540
821
Winnipeg, Canada
wifi fine on the 5, & has been on every beta & every os since i owned the phone on launch day..getting near 60mbps on 2.4ghz & 95mbps on 5ghz, no drops ever. idk how people have all these random problems..

router is a tplink tl-wdr4900 v1.3 with dd-wrt
 
Comment

Wowzera

macrumors 6502a
Oct 14, 2008
853
28
Brazil
All apps seem much slower over wifi on both iPhone 5s and iPad Mini. Same apps over LTE are fine. I thought my wifi was acting up, but both computers in the house are fine. My wife's iPhone which hasn't been upgraded to iOS 8 is also fine. Also noticed when in Safari on wifi the spinning activity icon next to the wifi icon rarely if ever goes away. Normally it's only there during page loads.

Exactly the issue I am currently having.
Any help? Tell me, please, if you find a solution!
 
Comment

jonathan1683

macrumors member
Dec 18, 2011
37
8
I noticed this too I thought my router www bugged. my router puts out wireless n and g so I switched over to g and its working again.. ipad air
 
Comment

dsh3

macrumors 6502a
Apr 30, 2012
542
246
Denmark
All apps seem much slower over wifi on both iPhone 5s and iPad Mini. Same apps over LTE are fine. I thought my wifi was acting up, but both computers in the house are fine. My wife's iPhone which hasn't been upgraded to iOS 8 is also fine. Also noticed when in Safari on wifi the spinning activity icon next to the wifi icon rarely if ever goes away. Normally it's only there during page loads.

Exactly the same thing I am experiencing too. Tried resetting network settings without helping, neither did reset all or even a full reset without restoring from backup. Argh!

EDIT: Tried three difference WiFi networks now, same issue on all three.
 
Comment

TheBuffather

macrumors 6502
Jul 19, 2009
490
235
Orlando, FL
I've been banging my head trying to figure out what the issue is. As a dev, I've had the beta for a while. The GM was terrible on WiFi; so bad, I had to use LTE if I wanted any connection at all. When I installed the public release today (and set up as a new iPhone), I had the same problem.

I used OS X's WiFi diagnostics to select a better channel for my wireless network, and that fixed it. So, until I read this thread, I thought that one of my neighbors (I live in an apartment) got a new wireless router that was screwing with my channels.

I'll continue to test it out and see if the slow downs come back.
 
Comment

Zxxv

macrumors 68040
Nov 13, 2011
3,558
1,104
UK
I was going to post Safari is....slower but I think macrumours is being hammered at the moment. Tried some other sites and theyre fine
 
Comment

j0han

macrumors 6502
Jul 24, 2010
447
21
Sweden
its the wifi general not only safari. and 5ghz is unstable, been waiting for a 8.0.1 for a week ;)
 
Comment

bobright

macrumors 601
Original poster
Jun 29, 2010
4,776
25
I see I'm not the only one and yeah it isn't specific to macrumors for me.

Edit: this is a bad safari problem I just lost the ability to even connect online nothing but a blank page and a stuck loading bar, yet Tweetbot and other apps worked completely fine. I had to reboot my device in order for it to work.
 
Last edited:
Comment

scottw75

macrumors newbie
Sep 18, 2014
20
2
I'm having problems with a retina iPad mini on a 5ghz wifi network. When I switch to 2.4ghz it works.

When on the 5ghz it works for a short period then gives up and lags. A reset fixes it again for a few minutes but it always comes back.
 
Comment

ram161

macrumors newbie
Sep 24, 2013
15
2
Same here I have slow wifi now after I updated to iOS 8 (I'm using iPhone 5s)
 
Comment

Zxxv

macrumors 68040
Nov 13, 2011
3,558
1,104
UK
yes much slower. maybe some forced obsolescence from Apple

if that were true then why are no news/rumour sites picking up on this? as there really is no need for safari to slow down.

And if its a bug why wasn't it picked up in beta testing? what do they do in beta testing :rolleyes:
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.