SMC reset problems/ battery is not recognized

Discussion in 'MacBook Pro' started by Do_oM, Aug 25, 2015.

  1. Do_oM macrumors newbie

    Joined:
    Aug 25, 2015
    Location:
    Berlin
    #1
    Good afternoon, hivemind! Here's something to chew in case any of you have some thoughts on possible solutions.

    In short: my Macbook Pro does not recognise the battery (symbol has a cross through it), can not run without external power supply from magsafe cable, will not charge and will not SMC reset either manually (ctrl+option+shift+power method) or with the downloaded SMC firmware file through terminal.

    The whole story: About a month ago there was a liquid spill in my backpack (soy sauce if you must know. the tastiest damage of all). Although my laptop and power supply were not saturated, I was wiping off the sauce off both. No immediate problems but within a week or so I noticed the magsafe power cable would sometimes not work immediately (after reconnecting or connecting first to another Macbook Pro and then back to mine, it would function with the green light again) and the taskbar shows no battery available.

    I took it to the Apple store. They tested in the shop front and the test software showed everything running normally except the power of course.

    So the techs took one look inside, discovered immediately there was possible liquid damage and instead of just possibly replacing the magsafe board/ akku, they charged me with the whole price of swapping out the entire logic board, magsafe board, battery even the casing (has a few dings in it from a hard life) costing almost the price of a brand new laptop @_@

    After a while (2 weeks or so) I decided rather than simply forking out money and not having the time to track down a computer repair shop willing to have a crack at it I would have a look in on it myself and see what the damage was.

    Sure there was some evidence of the spill on the battery case and some streaks on the underside of the battery (really minimal) but absolutely no signs of corrosion or ANYTHING on the logic board, magsafe board or any of the cable connections aside from some dust.

    I dismantled the laptop carefully, cleaned the stains with a light brush and some isopropyl, checked all the connections, re-inserted the boards and closed everything up again.

    Everything functions fine except the power!

    I know from previous attempts on trying an SMC reset that apparently the SMC firmware version is false for the operating system/ macbook pro that I have (will clarify model and OS soon) but I don't know what the workaround is.

    I have here a Macbook Pro 13inch (early 2011) Model A1278 to be more precise running OS X Yosemite 10.10.5 with the SMC version being 1.68f99

    I have tried:

    - Using different magsafe power supplies (no problem)
    - Manual SMC reset (through keyboard, no response)
    - From memory I tried re-installing the latest SMC version but encountered some kind of problem (would not install for one reason or another). I remember digging through a shitcreek of posts at the time on SMC bugs or incorrect versions but would appreciate more thorough advice if it's around here.
    - Cleaned and checked all connections from the boards inside the macbook

    I have yet to try the following:

    - try to use my current battery in another Macbook
    - try swapping my current battery with a new battery
    - open up and see if there is liquid damage in the power supply of the cable (not the easiest to access -_-)
    - formatting and re-installing the whole operating system
    - take it into another computer repair shop and see if the can offer any other solution aside from swapping out the whole logic board (in which case I may as well consider upgrading my computer entirely).

    Fan runs normally. Computer is not as peppy with speed as it was since 2011 (obviously could be for a number of reasons). Really EVERYTHING seems to functioning normal except for the battery.

    I'm not a particularly cluey guy with computers so there may very well be a lot of obvious solutions/ reasons the more experienced of you with IT backgrounds/ repairs experience can provide. But I am a curious creature and do want to learn if there is a cost effective way to make repairs to this situation without just throwing money at it and still not knowing what happened.

    To me, Average Joe no computer knowledge, the most obvious thing to try would be simply change the battery and see if that solves it but I also want to know exactly what the deal is with not being able to do an SMC reset.

    Thanks a whole lot for your time. Cheers!
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    It won't be a software issue - reinstalling the system would be a waste of your time.

    Because there is evidence of a liquid spill, then a "flat-rate repair" option through the Apple store (much less expensive) is not available to you. That option will repair anything that would ordinarily be covered under warranty, but won't repair accidental damage, which unfortunately includes visible liquid damage, regardless of how minor that may appear to you.

    SMC reset is here - for the task listed in that article, your Macbook has a non-removable battery.

    Do the battery test lights on the side of your MacBook respond at all? The battery may be completely dead, so NO lights may not mean anything for your issue.
    Next step is to try your battery in another MacBook, or even easier, try a different battery.

    If that other battery is also not recognized, then there's not much left. The magsafe adapter won't help, but replacing the magsafe board (sometimes called the DC-in board) can be worth a try.
    When THAT doesn't help, then you are left with only one choice - the logic board.
    If you get to that point, then it's decision time.

    What can you do that won't cost most of a new Mac?
    You could try a third party shop.
    You could replace the logic board yourself.
     
  3. Do_oM thread starter macrumors newbie

    Joined:
    Aug 25, 2015
    Location:
    Berlin
    #3
    Okay. So I finally got round to ordering a brand new battery from a seemingly reputable seller. Switched the batteries. Same deal. It doesn't get recognised by the computer. The battery test lights don't work on my mac.

    I still haven't been able to successfully do a SMC reset though and it's bugging me because maybe that makes all the difference. I have followed the instructions to the T for my mac model and many youtube videos watched but my mac just won't respond to it all.

    Any ideas for a workaround to get the SMC up and running on a Mac?
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    What is a "seemingly reputable seller"?
    Replacement batteries, particularly for an older MBPro, can be a crapshoot.
    The "reputable seller" is best when it is Apple.
    Going on the cheap with replacement batteries is almost never a bargain.

    However, your situation is probably still connected to your liquid damage.
    Cleaning the inside thoroughly, as you did, is a good idea, but won't repair actual corrosion damage.

    If you DON'T get the test lights on the side to work, REMOVE the main battery, then try the test lights again. You should see the indicator show one LED "chasing" back and forth (no battery recognized).
    If you still don't get the test lights, then the logic board will need replacing - that's pretty much it.

    The SMC reset does NOT give you any physical response that will tell you that it has been successful. You just push the buttons as directed, and hope for the best. The only indication that you will get is when the battery needs to charge, so would show an orange LED on the Magsafe connector. When you press the SMC reset sequence, the magsafe LED will briefly return to green, then back to amber, indicating that that battery is charging.
    If your battery is not recognized, then the Magsafe LED will simply remain green. There's no way to tell if the reset completed. The keys to press are simple.
    If you have tried a different battery, and you still don't get good results from charging, and the battery remains unresponsive, then you COULD try replacing the magsafe board, which is fairly simple to replace, and significantly less expensive than the logic board. If THAT doesn't help, then you have the last choice, replacing the logic board....
     
  5. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #5
    ...and its "not as peppy" because the MBP throttles with no battery as full cpu power requires more power than the charger can provide alone.
     

Share This Page