Snow Leopard Internet Sharing Glitch/Bug/Change?

Discussion in 'macOS' started by duykur, Aug 31, 2009.

  1. duykur macrumors regular

    Joined:
    Jan 20, 2008
    #1
    Well i don't have a wireless network at my house, so i use my macbook pro to create an adhoc network. This worked great for a year, until I upgraded to snow leopard. My ipod can connect to the WiFi network, but i suspect snow leopard is forcing the airport chip to broadcast an N network, which the iPod can't connect to.

    Is there anyway to fix this, or is there any other reasons this may have stopped working?

    After checking the apple forums, it appears that some other users have this problem, some suspect a problem with DHCP, but there is no confirmed source of the problem.
     
  2. duykur thread starter macrumors regular

    Joined:
    Jan 20, 2008
  3. taio84 macrumors newbie

    Joined:
    Apr 12, 2007
    #3
    Same problem for me!
    I HAVE to share a internet connection from my mac trough ethernet and airport. No problems until snow leopard, now (after having installed snow leopard) when I share internet connection trough airport, my MacBook Pro and ipod touch / Iphone, CAN connect to the adHoc network, but CAN'T access the internet.
    This is VERY VERY annoying....
    Please if known share suggestions.
     
  4. cowpaintings macrumors member

    Joined:
    Jun 25, 2007
    #4
    Same problem here. I have an imac and have used internet sharing for years to provide a network for my laptop and apple tv. Never had a problem until I just installed snow leopard. Now, anytime I turn on the network the internet goes dead on my imac.
     
  5. Steils macrumors newbie

    Joined:
    Sep 3, 2009
    #5
    I have a first gen iPhone and just got mine working today by following these steps.

    The following procedure is confirmed to work as written.

    Start Internet Sharing if it's not already running.

    In Terminal, type cp /etc/bootpd.plist /tmp/bootpd.plist

    Stop Internet Sharing.

    Open "open -e /tmp/bootpd.plist" for editing using TextEdit or whatever.

    Locate this section of the file, near the end:

    <key>reply_threshold_seconds</key>
    <integer>4</integer>

    Change the value 4 to 0.

    In Terminal, type sudo cp /tmp/bootpd.plist /etc

    Start Internet Sharing.

    If you want to, check that your change to /etc/bootpd.plist hasn't been reverted.


    then i just restarted my phone and everything seems to working for the past few hours.


    Source - Following 10.5 Steps
    http://www.macosxhints.com/article.php?story=20071223001432304&query=xbox+360
     
  6. Steils macrumors newbie

    Joined:
    Sep 3, 2009
    #6
    I tried to connect again this morning after a day of using the fix, and it would not connect until i turned Internet sharing off then back on again, and it connected almost instantly, so not a permeant fix. I don't have anything to try keeping the connection active all the time(like Apple TV) as I only have my iPhone to test.
     
  7. cowpaintings macrumors member

    Joined:
    Jun 25, 2007
    #7
    Think I figured it out.

    Turn off internet sharing.

    Go into system preferences -network

    Click on Airport in the left hand side, then click 'advanced' on the right hand side'

    Click TCP/IP and turn 'Configure IPv4 to Off

    Click OK, then click 'Apply' in the network window.

    Turn internet sharing back on.

    After that I am now back to normal and my network is up and running again without problems.
     
  8. Axxl macrumors newbie

    Joined:
    Jun 19, 2009
    #8
    This fixed it for me (I've only tried it once so far). I went into the airport tab in the top bar, hit "create network" to make a computer-to-computer network. Then I clicked on the airport symbol again, disconnected from that network, tried turning on internet sharing again, and it worked. I don't know if it's just random luck or what though.
    Alex
     
  9. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #9
    No success here. I've always used a Mini as my network hub, but it's not working under SL. I've tried the two suggested fixes, and neither one allows my network to stay up.

    I've got a new Intel Mini running SL, sharing ethernet over Airport. Two clients: Mac Pro running SL and MB Air running Leopard. Occasionally we'll add a Skype WiFi phone and an iPod touch to the network, but I don't think they're the source of the problem (also fails with those devices off...).
     
  10. Cave Man macrumors 604

    Cave Man

    #10
    Any further progress on this? I'm screwed too.
     
  11. 8740ridgeroad macrumors newbie

    Joined:
    Sep 14, 2009
    #11
    It's Alive!!

    So I have been desperately trying to find a way to fix the internet sharing issue I have since Snow Leopard was installed. I use an AT&T USBConnect 881 and once I downloaded the new 3G Watcher and got that working again the internet sharing didn't work.

    I read a post on an Apple forum where they talked about DeSelecting Ethernet or Firewire and as I only need to personally share my Airport I deselected both and voila! I can now share my internet.

    I have zero idea why it works nor do I care. I now am showing that I only share my airport and it is doing just that.

    Hope this helps someone!

    C
     
  12. jesuguru macrumors newbie

    Joined:
    Sep 14, 2009
    #12
    Thanks 8740ridgeroad

    Had tried all other suggestions on this thread (and others) to restore internet sharing between macbook and iphone (had worked b4 SL upgrade, not after).

    Your solution (disabling ethernet/firewire, leaving only airport checked) is also what finally worked for me.

    THANKS!
     
  13. jiminfrance macrumors newbie

    Joined:
    Jul 22, 2004
    #13
    Snow Leopard Internet Sharing Glitch/Bug/Change?

    cowpaintings did it for me. Using imac with snow leopard 10.6.1and g4 laptop with 10.4.10 Did the biz with the iMac and then set the G4 to DCHC. On the iMac under Network, the lefthand side shows Airport as Not Connected but the right hand side shows Airport as On. It says that Airport does not have an IP address and cannot connect to the internet. Before, it was assigning itself an Ip number. Thanks to cowpaintings for a simple straightforward explanation.http://images.macrumors.com/vb/images/smilies/smile.gif
     
  14. Megasus macrumors newbie

    Joined:
    Sep 15, 2009
    #14
    Thank You, thank you cowpaintings!

    I have a mac pro with snow leopard 10.6.1 and a mini with 10.4.11 and after this I'm back up and surfing the net. THanks!!!

    Turn off internet sharing.
    Go into system preferences -network
    Click on Airport in the left hand side, then click 'advanced' on the right hand side'
    Click TCP/IP and turn 'Configure IPv4 to Off
    Click OK, then click 'Apply' in the network window.
    Turn internet sharing back on.
     
  15. pjmacl macrumors newbie

    Joined:
    Jan 6, 2003
    #15
    Still flaky!

    Running sharing on a iMac and sharing to a MBP both on 10.6.1. Tried the solutions on this forum – e.g. Cowpaintings's "fix"– which initially seemed to work. Interesting thing is that I can always connect to my iMac's wireless net, but usually it is not actually sharing the Internet, so I have no through connection. Get the null wireless symbol with the exclamation mark through it. However SOMETIMES it works fine with no obvious reason. Really flaky. Clearly an OS level fix is still needed.
     
  16. MoleTwins macrumors newbie

    Joined:
    Sep 19, 2009
    #16
    Leopard Sharing Fix that works - Fix that doesn't

    I read a post on another site that if you go into Network Preferences and change your Aircom settings under the TCPIP such that Detect IPV4 is set to "off", that it starts working again. The first time I tried, I accidentally switched off detect IPV6. It worked anyway. But I was frustrated that Snow leopard had screwed things up and concerned that switching off this function might have other adverse effects. This appears to turn the wifi default into a "fixed IP address" and I'm not sure if you can get on other wifi hotspots that way or not.

    So I undid the change called Applecare and they had me go into Library, then the preferences folder and drag my "systemConfig" folder to the desktop. and restart the computer. Well everything started working again, so I deleted the old systempreferences file. But the next time I rebooted it wasn't working again. So now I'm back to solution number one. Anyone know what this IPV4 thing actually does?
     
  17. bencapozzi macrumors newbie

    Joined:
    Sep 24, 2009
    #17
    Up and working after Megasus Procedure

    Thanks, Megasus! Mine's restored after your solution. I have an iMac I use as a a base station to broadcast wireless for iPhone and Air, but Airport was simply not broadcasting. Now it is once more.

    ~ben
     
  18. bencapozzi macrumors newbie

    Joined:
    Sep 24, 2009
    #18
    Nope; not fixed

    And it's effed up again! Picks up wireless network signal but no actual connection to internet. Waiting for mother ship to send out a fix... >le sigh<

    ~ben
     
  19. meanlittlemonke macrumors newbie

    Joined:
    Sep 23, 2009
    #19
    The Carolyn Fix! This One Actually worked for me!

    HI,

    If you didn't repair disk permissions after the SL installation, try that.

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and restart your Mac.

    And try deleting this file. com.apple.internetconfig.plist

    /Users/YourName/Library/Preferences. Drag that file to the Trash, empty the Trash and restart your Mac.

    Carolyn
     
  20. meanlittlemonke macrumors newbie

    Joined:
    Sep 23, 2009
    #20
    Um nevermind

    Yeah, this one poops out after a few hours too.
     
  21. Appleist macrumors newbie

    Joined:
    Sep 28, 2009
    #21
    Same ****... :(

    I try to share internet via Wi-Fi from my iMac5.1 to MacBook & iPhones... iMac connect to internet via PPPoE. On 10.4 & 10.5 it's have perfect sharing, and I dont know any problems... But now in 10.6 (& 10.6.1 too) its not work!!!
    iMac have internet, but not share it. After connect to Wi-Fi MacBook show [​IMG] icon. iPhone after connect show «Connecting...» in Safari. Whats going on???? Need downgrade to 10.5? :mad:

    I try to reset, DiskUtility, change WEP/WPA - same problem.
    Sometime before (immideatly after I check checkbox in «Internet sharing»), it share internet to 1-2 minutes, then shutdown. But now it's gone too... I\m very very mad. Anybody help us??
     
  22. ironybubble macrumors newbie

    ironybubble

    Joined:
    Oct 3, 2009
    #22
    I'm gonna have to jump on the bandwagon here.

    I'm sharing Ethernet via WiFi using an iMac running 10.6.1, and this computer doesn't seem to be the problem.

    The Macbook c2d 2.1, however, was happily functioning using the WiFi shared internet connection while it was running 10.5.8. I installed Snow Leopard on this laptop before I went to sleep, and in the morning I woke up and the laptop wouldn't connect to the same network that it had been running on the night before.

    Odd.
     
  23. dr34mc4st3r macrumors regular

    dr34mc4st3r

    Joined:
    Aug 18, 2009
    Location:
    Singapore
    #23
    for me my internet sharing is working, however when i put my mac to sleep and then wakes it up, the internet sharing goes dead. i have the wifi connection to my iphone, but no data from internet. truly frustrating. anyone have the same kind of issues?
     
  24. ep2002 macrumors newbie

    ep2002

    Joined:
    Jul 16, 2008
    #24
    I just want to add my name to this problem.

    I got with Apple Care a couple of weeks ago, and of course no solution yet. I'm just hoping for a fix by the time 10.6.2 comes out.

    Wishful thinking????

    The only short term fix is to toggle the internet sharing check mark box off and on. Some times that doesn't work, so I'll have to restart the iMac.

    I'm frustrated too, because this was working PERFECTLY with 10.5 and ALL the point updates.
     
  25. gikku macrumors regular

    gikku

    Joined:
    Dec 29, 2006
    Location:
    -33.82,151.26
    #25
    mee too.
    internet sharing issues on iMac 2.66 10.6.1, ethernet -> airport , drops out with no access, while iPhone, MacBook or Win7 netbook still report a wireless connection but no internet access.
     

Share This Page