Snow Leopard, stop replacing my CAPITALS please? [solved]

Discussion in 'macOS' started by C64, Oct 25, 2009.

  1. C64 macrumors 65816


    Sep 3, 2008
    Hey all,

    I think it's the new text replacement stuff in Snow Leopard that's causing this 'problem'. Every time I type more than one capital using the Shift key, the other capitals are replaced by lower case letters. Now this is useful when you mistakenly started a sentence with two capitals, but I find it extremely annoying when I actually do need multiple capitals. And using caps lock all the time is annoying as well.

    Is there a way to turn this off? I like the rest of the hole text replacement thing, and would like to keep that turned on. But I can't really find anything that has to do with 'accidental double capitals' or something like that.

    TIA! (yeah, that took backspaces and retyping :mad:)
  2. gr8tfly macrumors 603


    Oct 29, 2006
    ~119W 34N
    Which app are you using when you're seeing this behavior?
  3. C64 thread starter macrumors 65816


    Sep 3, 2008
    Hmm.. I was stupid :eek:

    I now notice it has to do with Synergy; I use it to work with my desktop keyboard/mouse on my MacBook over the network, but somehow it doesn't register all the shift-strokes. I'm typing this on my MacBook itself, and no problems.. Oh well, another problem solved :)
  4. PhilaRobert macrumors newbie

    Oct 27, 2009
    Shift key only capitalizes first letter

    I'm having the same problem in ALL my typing: when I hold down the shift key for multiple letters, only the first is capitalized; the rest come out lower case. This is not a replacement behavior: I don't see the Uppercase letter get replaced by the lowercase one; only the first is uppercase.

    Is there some new text replacement routine? Can this be customized? I can't stand having to release the shift key between letters or to have to shift-lock, shift unlock.

    Thanks for any help.

Share This Page