So if you use exchange for gmail push you can't delete emails?

Discussion in 'iPhone' started by Siciliano611, Mar 27, 2011.

  1. Siciliano611 macrumors regular

    Joined:
    Jul 8, 2008
    #1
    I've searched and read up on this a lot, it seems regardless if i hit delete on an email or move to folder "trash" the only place it goes is the ALL MAIL folder, which is some kind of archive folder? That's kind of annoying, anyone know of a way around this using exchange for push gmail?
     
  2. BurntReality macrumors 6502

    BurntReality

    Joined:
    Jun 21, 2010
    Location:
    Tyler, TX
    #2
    Are you sure you are hitting delete and not "Archive".
    Goto Settings/Mail, Contacts, Calendars/
    Then select which account and make sure Archive Messages is set to "off"
     
  3. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #3
    There is no option in exchange for any kind of Archive in the mail settings...this only applies to the "GMAIL" mail app
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #4
    I know for a fact that Archive is an option in the mail app for IMAP..I'm not sure about Exchange... Maybe that is what the previous poster was referring to.
     
  5. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #5
    Yeah James, IMAP, but for push gmail you can only use Exchange right now for the mail app...and there is no archive turn off/option for that
     
  6. xyz1534 macrumors regular

    Joined:
    Jul 2, 2010
    #6
    If you are using Exchange for gmail then you can go to settings/mail/gmail/ and turn off archive over there, it will then give you the option to delete emails in exchange...

    Just like what the other poster said...
     
  7. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #7
    That's what I thought.:D
     
  8. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #8
    xyz, i dont see that setting in the mail/contacts/calendar settings for my exchange/gmail account...only if it is setup as a new account when you ap the GMAIL icon instead of the Exchange one, early in the setup....
     
  9. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #9
    also when i go into my inbox and highlight a message it says DELETE not ARCHIVE, but when i delete the message it wont go into trash, only into all mail...this is crazy
     
  10. xyz1534 macrumors regular

    Joined:
    Jul 2, 2010
    #10
    That is strange, mine goes to Trash
     
  11. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #11
    Mine goes to trash and all mail, and when I empty trash, it gets deleted from all mail.
     
  12. xyz1534 macrumors regular

    Joined:
    Jul 2, 2010
    #12
    Ok, go to settings/mail/gmail/account/advanced - over there u will see "Mailbox Behaviors" go to the deleted mailbox and make sure it says Trash over there...let me know if this works
     
  13. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #13
    There is no advanced in the account settings IF YOU SET GMAIL UP THROUGH EXCHANGE....I can't be going crazy here....all there is under that is email/server/domain/username/password/description/use SSL, that is it.....if i set up gmail through the GMAIL button after add account, then what you are speaking of is there...not through setting it up under exchange.....
     
  14. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #14
    If my memory serves, when using Gmail/ActiveSync/Exchange, I think you have to go to your Gmail account with a web browser and in the settings turn on IMAP Advanced features or something like that. I believe this issue you have with emails not actually being moved to the trash is a setting within Gmail (web) and not a configuration on the iPhone.
     
  15. xyz1534 macrumors regular

    Joined:
    Jul 2, 2010
    #15
    Missed a step accounts/gmail and then the rest
     
  16. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #16
    There is no "advanced" if you have Gmail on your iPhone configured as an Exchange account. It IS there if you configure it using the "Gmail" account preset or as a generic IMAP account.
     
  17. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #17
    xray, and I didn't configure it that way, i configured it through exchange not the gmail preset....so how can i resolve this with no Advanced option
     
  18. xyz1534 macrumors regular

    Joined:
    Jul 2, 2010
    #18
    Oh ok, Thanks for clearing that up...
     
  19. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #19
    No - not on the phone - on the gmail website, go to the gmail settings and I think somewhere in there is an option for Advanced IMAP control or something of that nature.
     
  20. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #20
    There is a lab you have to add for advanced IMAP controls and i did that and there is now a couple extra options...

    When I mark a message in IMAP as deleted:
    Auto-Expunge on - Immediately update the server. (default)
    Auto-Expunge off - Wait for the client to update the server.

    When a message is marked as deleted and expunged from the last visible IMAP folder:
    Archive the message (default)
    Move the message to the Trash
    Immediately delete the message forever

    I have auto expunge on and i tried to turn it off and then turn the below option to move the message to trash, but even THAT didn't work...this is really a pain in the ass
     
  21. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #21
    Set auto-expunge to off and move message to trash on. I think this will do it for you. I think it will take a few minutes for the email to hit the trash when deleted from the iPhone. HOWEVER, do realize that Gmail isn't real IMAP mail. It's made to look like it to email clients, but it's its own animal.
     
  22. Siciliano611 thread starter macrumors regular

    Joined:
    Jul 8, 2008
    #22
    tried that, sadly even that didn't work......ridiculous
     
  23. scotty588 macrumors 6502

    Joined:
    Jan 2, 2007
    Location:
    Carlsbad, CA
    #23
    Yeah I know exactly what you mean and I have the same problem. Only options are these:

    1. Add the gmail account as imap. You will loose push support, but when you delete emails it will go to the trash.

    2. Keep it added as an exchange account, but when you want to delete an email go to mail.app, select the account, go to All Mail (not inbox) and delete it from there. It should go to the trash then.

    I just go through my All Mail section every month and trash anything that hasn't been properly deleted.

    If you look on the Google help forums you'll see this issue has been brought up many times. Why Google does not fix this I have no idea. It's very annoying.

    http://www.google.com/support/forum/p/gmail/thread?tid=7faa3def18265804&hl=en

    http://www.google.com/support/forum/p/gmail/thread?tid=0680120508f07632&hl=en

    http://www.google.com/support/forum/p/gmail/thread?tid=765d1a799963be63&hl=en
     
  24. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #24
    OP, if you did search, you would have seen there are a few posts explicitly around this exact topic, I know as I've replied to them as well. I share your frustration.

    As of now, if you want your gmail deletes to be real deletes (not into all mail), your ONLY option is to setup via the gmail icon (IMAP) and then turn off archive. Any other avenue results in your deletes really being archived into all mail.
     
  25. willpower101 macrumors regular

    Joined:
    Jul 12, 2009
    #25
    This thread had me thinking I was insane for a minute two until I realized that half the people here don't even know wtf exchange is.

    The best solution I've found is to use a web interface style gmail app and just turn on exchange push for the notification.
     

Share This Page