So long perfect iPhone

Discussion in 'iPhone' started by stlredbird, Sep 29, 2010.

  1. stlredbird macrumors 6502

    stlredbird

    Joined:
    Feb 24, 2009
    #1
    So I got my iPhone 4 at launch from Best Buy, and though I didn't get a protection plan for my 3G and never had a problem for it's entire 2 year life span, I decided with both sides being glass I wasn't going to take the chance.

    Cut to last night. I'm at a restaurant and the waitress spills my water all over the table, me and my iPhone. I dry it off as best as possible and everything seems to work except when I make a phone call I don't hear anything. I quickly realize the the iPhone thinks that headphones are plugged in. The manager offers to pay for a replacement and I take his card but I already know that my Best Buy warranty will replace it at no charge.

    I rush to Best Buy after dinner and they just give me a new 32GB iPhone 4, nice and simple (normally they give you a loaner phone and send it to Apple but they were out of loaner phones). My world is good once again.

    Until today. I'm taking pictures around the office, trying out Pano which I just downloaded, when I realize a green blob in the middle of the pictures and screen when in camera mode. It seems to be the florescent lights and white/light background is when it really shows up, in other lighting it's barely noticeable or non-existent.

    So I went back to Best Buy and explained the situation and they promptly gave me a new phone out of the box. I immediately test the camera before I leave and it has the same problem. Obviously the whole batch they have will more than likely have the same problem so they suggested I wait until they get a new batch and try again.

    So I'll give it a couple months I suppose and try again.

    I miss you already launch iPhone!
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
  3. WilliamG macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #3
    Every iPhone 4 I've used has that same "issue" under fluorescent light. It's pretty normal if you ask me, though far from ideal.
     
  4. Hellishness macrumors 65816

    Hellishness

    Joined:
    Jan 27, 2010
    Location:
    Bay Area, CA
    #4
    Many phones have this problem. I'm pretty sure you can get it replaced for it (by Apple). Some are worse than others....
     
  5. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #5
    My post was deleted :( Oh well, someone else stated it for me.
     
  6. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #6
    Just like the above poster said, the green blob is a known iP4 issue. Afaik, it affects all iP4's when taking photos under cfl lighting. I'm guessing you probably just never noticed/encountered it on your original iP4.
     
  7. stlredbird thread starter macrumors 6502

    stlredbird

    Joined:
    Feb 24, 2009
    #7
    Well I have photos of the exact same office with the exact same lighting from a month ago and no discoloration from my old iPhone, so I don't think it's all iP4s.
     
  8. jasonforisrael macrumors regular

    Joined:
    Jan 8, 2008
    #8
    this has been discussed in length.


    the majority of users will experience this when under fluorescents or certain indoor lighting conditions.
     
  9. iBaloney macrumors 6502

    iBaloney

    Joined:
    Jan 6, 2010
    #9
    how much was the protection plan for the ip4 from best buy?
     
  10. Lioncrazz macrumors member

    Joined:
    Dec 3, 2009
    #10
    The protection plan through Best Buy is $15 per month.

    Honestly, I have not experienced the "green blob" issue. I take pictures under CFL almost every day.
     
  11. iBaloney macrumors 6502

    iBaloney

    Joined:
    Jan 6, 2010
    #11
    do you pay month to month for that?
     
  12. The General macrumors 601

    Joined:
    Jul 7, 2006
    #12
    Complain to the restaurant. They're the ones who spilled it on your phone. It's their fault.

    Oh, nevermind. This thread is pointless.
     
  13. iBaloney macrumors 6502

    iBaloney

    Joined:
    Jan 6, 2010
    #13
    lolz kinda agree, but give the guy a break.:D
     
  14. yayitsezekiel macrumors 6502a

    yayitsezekiel

    Joined:
    Aug 1, 2008
    Location:
    Irvine, CA
    #14
    do you have any picture examples? I'm sort of interested as to what this looks like
     
  15. mpossoff macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #15
    It is $15/ month after month. But I never gears of best buy giving you a replacement right on the spot.

    Marc
     
  16. itsmemuffins macrumors 68030

    itsmemuffins

    Joined:
    Jun 23, 2010
    #16
    I don't see any difference in the pictures you pos...oh wait.
     
  17. stlredbird thread starter macrumors 6502

    stlredbird

    Joined:
    Feb 24, 2009
    #17
    Much like your post in it...
     
  18. stlredbird thread starter macrumors 6502

    stlredbird

    Joined:
    Feb 24, 2009
    #18
    They normally don't apparently but they were out of loaner phones so the manager just took one out of the box and switched it out.
     
  19. someguy macrumors 68020

    someguy

    Joined:
    Dec 4, 2005
    Location:
    Still here.
    #19
    Can you post an example? I'd like to see this green blob, please. :)
     
  20. stlredbird thread starter macrumors 6502

    stlredbird

    Joined:
    Feb 24, 2009
    #20
    Here
    Original phone:
    [​IMG]
    New:
    [​IMG]
    [​IMG]
     
  21. mad-dog-one macrumors 6502

    Joined:
    Aug 14, 2009
  22. stlredbird thread starter macrumors 6502

    stlredbird

    Joined:
    Feb 24, 2009
    #22
    Now that I post them here I do notice a slight discoloration on the cabinet in the original but no where near as bad as the new ones. The "blob" btw is much much more noticeable and pronounced on the screen when using the camera, and when the pics are thumbnails in the photo album.
     
  23. someguy macrumors 68020

    someguy

    Joined:
    Dec 4, 2005
    Location:
    Still here.
    #23
    It is worse in the new phone, but still exists in all images posted. Once I wake up, I'm going to try this in my office with my EVO, just for kicks.

    OP, hope you get a new phone from a fresh batch that doesn't have this issue! :)
     
  24. Irish Rose macrumors 65816

    Joined:
    May 29, 2010
    #24
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    That really sucks, sorry that the new one isn't working out for you.
     
  25. iBaloney macrumors 6502

    iBaloney

    Joined:
    Jan 6, 2010
    #25
    the green doesnt seem that bad, does this happen in all the pix you take?
     

Share This Page