Software Update Problem

Discussion in 'macOS' started by brguitarist, Nov 18, 2007.

  1. brguitarist macrumors member

    Joined:
    May 24, 2007
    Location:
    New Jersey
    #1
    Hey guys,
    So after upgrading to Leopard I'm having a problem with the most unexpected thing... Software Update.
    Right after the install I updated to 10.5.1, updated QuickTime, RDC and iTunes.
    Now, however, every time I run Software update I quickly get the window that says "New software is available for your computer", but no updates are listed and the Install button is "greyed out".
    Going to Software Update properties I see: Last attempt: Failed. Error occurred while checking. Monday, November 19, 2007 2:07 AM.

    I have re-installed 10.5.1 and still got nothing.
    Any idea of how I can go about fixing this?
    This is really annoying...

    Thanks a lot
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Sometimes, Software Update's caches and other support files can become corrupted, causing various problems when attempting to update. This is easily fixed - find the offending files (they're in ~/Library/Caches/com.apple.SoftwareUpdate/ where ~ is your home folder) and delete them.
     
  3. McMadMan macrumors newbie

    Joined:
    Nov 20, 2007
    #3
    Hi wrldwzrd89, Thanks for your solution. Searched the whole net including Apple's support but could not find your solution. It worked like a charm.
     
  4. jauhari macrumors regular

    jauhari

    Joined:
    Mar 20, 2007
    #4
    Wow this perfect and supper, I was looking around on Apple Discussion and get nothing, when I visit this GREAT FORUM I got what I looking for ;)
     
  5. pjrobertson macrumors 6502a

    Joined:
    Nov 14, 2007
    #5
    Thanks wrldwzrd89,

    This solved the problem for me after about 5 days of searching.
    Now I know that macrumors should be the first place to look.

    :)
     
  6. brguitarist thread starter macrumors member

    Joined:
    May 24, 2007
    Location:
    New Jersey
    #6
    Hmm, could swear I responded to this.
    Thanks wrldwzrd89!
     
  7. ateng macrumors newbie

    Joined:
    May 16, 2007
    #7
    It works perfectly.. Thanx alot.
     
  8. iseedeadpple macrumors newbie

    Joined:
    May 25, 2008
    #8
    have exactly the same problem, but the solution doesn't work. any other possible reasons for this? thanks!
     
  9. dryvlee macrumors newbie

    Joined:
    Jan 26, 2004
    Location:
    Singapore
    #9
    I have the same problem despite zapping PRAM, reset PMU, fsck ... install leopard to a new external HD and same problem after updating with new Comboupdater 10.5.2 not via software update, but downloaded that from Apple website. Now even my iMac also face the same thing. I suspect perhaps Apple is doing all these ...
     
  10. dryvlee macrumors newbie

    Joined:
    Jan 26, 2004
    Location:
    Singapore
    #10
    Ha, I solved it, the old method still work, but must repair permissions, drag the cache file to trash and empty it and reboot and then tada, Apple Software Update works!
     
  11. iseedeadpple macrumors newbie

    Joined:
    May 25, 2008
  12. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #12
    Go into Disk Utility, select your disk, click Repair Permissions.
     
  13. iseedeadpple macrumors newbie

    Joined:
    May 25, 2008
    #13
    thanks. have tried it. still won't work. maybe i will just have to live without software update.
     
  14. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #14
    Hmm... there's one other file you can try deleting - Software Update's preferences. It's found in ~/Library/Preferences/com.apple.softwareupdate.plist.

    Also, open up Console and look at the Software Update crash log. This may reveal more about what exactly went wrong. I can help interpret log files, if you think that's worth a try.
     
  15. iseedeadpple macrumors newbie

    Joined:
    May 25, 2008
    #15
    it's working now! great! thanks much for all the help!
     
  16. neggen macrumors newbie

    Joined:
    Nov 11, 2008
    #16
    I'm getting an agruments=(null) error message in my Software Update log.

    Here is an example:

    11/10/08 4:16:38 PM Software Update[246] arguments=(null)

    Any ideas?

    I cleared my preferences and cache files. Neither did the job.

    I also verified that the Software Update Preferences area displays the friendly error.

    Weird stuff..
     
  17. petemwah macrumors regular

    Joined:
    Feb 10, 2009
    #17
    thanks so much wrldwzrd89 your tip worked a TREAT for me just now! x x x
     
  18. JohnTB macrumors newbie

    Joined:
    Mar 3, 2009
    #18
    Software Update

    I have read all of the posts for resolving Software Update Problems but none have resolved the problem that I have.
    When I open Software Update the blue bar indicator for 'Checking for new software . . .' just stops at about 6 mm.
    When this same problem happened before Apple Support suggested:
    01. Going into UTILITIES and running DISK UTILITY > VERIFY DISK. This shows that everything was OK.
    02. When this didn't resolve the problem, they said that I would have to re-install MAC OSX.
    This resolved the problem but it's a very long winded and tiresome process.
    Does anyone have a solution for this?
     
  19. sheva22 macrumors newbie

    Joined:
    Mar 28, 2009
    #19
    I have exactly the same problem!!! At the apple store they told me to try archive and install.. but I don't want to reinstall the system.. did u resolve the problem in another way?!
     
  20. benevale macrumors newbie

    Joined:
    Apr 1, 2009
    #20
    software update problem

    Yesterday I tried to update my software and received this message:

    "Mac OSX update combined can't be installed. Source media is damaged. Try installing from a different copy of source or contact manufacturer for a replacement."

    I then received the prompt to "restart" and after doing so I reached a grey screen with some code on it and a message that says "You need to restart your computer. Hold down the power button for several seconds or press the Restart button". So I can not use my computer because everytime I turn it off and on, it goes back to this grey screen telling me to restart.

    Does this problem sound familiar to anyone? If so, any ideas as to how I can resolve this issue or what is going on?
     
  21. *Andrew macrumors newbie

    Joined:
    Oct 12, 2009
    #21
    Do you delete everything in there?

    Don't we need those files for something; or are they replaced somehow?
    Thx for help.
     
  22. jaren0401 macrumors newbie

    Joined:
    Dec 2, 2009
    #22
    Just use terminal!

    People have trouble doing it, why don't you just use terminal for updating:

    1. Open terminal in the applications/utilities folder.
    2. type in sudo softwareupdate -i -a
    3. It will request for your password (you have to be in the ROOT user)
    4. Sit back and wait
    5. If it says no updates available then there's no updates. If there is one, then it'll be downloaded immediately and install it for you!
     
  23. phatowner macrumors newbie

    Joined:
    Aug 4, 2009
    #23
    same Software Update probelm

    My problem is with the HP Printers Driver, it keeps asking to update them. so far I have:

    updated via Softwareupdate
    updated the entire package via downloading from Apples site
    cleared my cache
    deleted my preferences
    ran sudo softwareupdate -i -a
    booted off snowleapord disk and repaired disk and permissions

    nothing has worked, any other ideas?
     
  24. phatowner macrumors newbie

    Joined:
    Aug 4, 2009
    #24
    problem solved

    my bad, I forgot to reboot after removing the cache, that with a repair of perms after reboot did the trick

    thanks gurus!
     
  25. Kimba macrumors member

    Kimba

    Joined:
    Sep 22, 2009
    Location:
    Ventura County, California
    #25
    Software Update Doesn't Check Automatically (10.5.8 and 10.6.2)

    Hi,
    I have a minor problem with the Software Update feature. While it works fine manually it won't check for updates automatically. For example, changing between Daily, Weekly, and Monthly does nothing. The Last checked time and date always show the last time I did a manual update.

    I looked around for a solution and I found several sites (including this one) that recommended deleting the com.apple.SoftwareUpdate.plist file and rebooting. However, I tried that and it didn't make any difference. I also tried repairing permissions but that didn't make any difference either.

    The other odd things is that it used to work. For example, it worked from 10.5.0 through 10.5.7 but stopped working in 10.5.8. It then worked again with 10.6.0 but stopped with 10.6.2. Any suggestions? (Maybe I'll just wait for 10.6.3. :()

    Thanks
     

Share This Page