Solution needed for -43 error that keeps coming back

Discussion in 'OS X El Capitan (10.11)' started by Ewen Cameron, Nov 8, 2016.

  1. Ewen Cameron, Nov 8, 2016
    Last edited: Nov 8, 2016

    Ewen Cameron macrumors newbie

    Joined:
    Feb 15, 2004
    #1
    Computer = Mac pro 4.1 updated via firmware to 5.1 (1 year ago)
    Upgraded CPU = 3.46 Ghz 6 core Xeon (1 year ago)
    Has been running Yosemite perfectly well since the upgrades above.
    OS System is running on a Crucial SSD 500gb (1 year old with no problems before El Capitan)

    Since upgrading to El Capitan (2 days ago) I get the following error when moving ANY files from the desktop to the trash...

    The operation can’t be completed because one or more required items can’t be found.
    (Error code -43)


    I have tried many different solutions found here and on the web, but they only temporarily fix the problem which comes back on second or third restart.

    So far I have tried....
    • Starting in Safe Mode and running disk first aid (3 times) + resetting PRAM
    • Unmounting other hard drives
    • Force quit Finder (this works - but then error comes back on next restart)
    • Setting up a new admin account and deleting old account, then selecting previous user folder as new account - as seen in this link (really thought this was going to work).
      http://forums.macrumors.com/threads/corrupted-user-account-el-capitan.1932063/
    • Using Onyx to rebuild cache files, launch services, DS_store files and fix permissions (about 3 times)
    • Uninstall Trim Enabler and activate OSX Trim using Terminal (last thing I tried, and worked after restart, then went back to errors on 2nd restart).
    I can't believe this is a hardware disk error, too much of a coincidence and only 1 year old (onyx says disk is ok for what its worth).

    I have installed new software along with the update, new Adobe CC suite and FontExplorer X Pro 6 - could it be anything to do with this?

    Any decent ideas would be much appreciated, please don't suggest looking at basic Apple links like (how to delete a locked file or files won't delete etc).

    Anyone know why force quitting the finder will then allow desktop files to be deleted ok? The answer must be to do with this, but obviously I don't want to do this every time I restart the computer and really would like to solve this without having to try a clean install.

    Thanks
     
  2. Ewen Cameron thread starter macrumors newbie

    Joined:
    Feb 15, 2004
    #2
    Hate to leave a question unanswered, so after spending some time going through the console and using Etecheck, I found that Avira virus protection was causing some issues.

    However I think the main culprit was actually an internal drive which I had left a clone of Yosemite on (set up using Carbon Copy Cloner). I reformatted this disk and now everything seems to be ok (touch laminated wood).

    Now on 4th restart and no problems yet.
     

Share This Page