SOLUTION: No 4G/LTE Connectivity After Restore from iTunes/iCloud

Discussion in 'iPhone' started by caliwolv, Sep 22, 2012.

  1. caliwolv macrumors member

    Jul 11, 2008
    This problem only impacts people who have data working fine when they set the phone up as a new device, but lose data connectivity after a restore from a previous device backup.

    This is caused by APN settings from a previous jailbreak and comcenter patch or other modification to APN settings which can't be removed - essentially there is a phantom APN installed with the wrong settings for your LTE data plan (but worked fine on 3G). Other symptoms of this issue include:
    • The SETUP PERSONAL HOTSPOT option missing in Settings --> General --> Cellular
    • If you try to install a new APN, you're told that one already exists even though it doesn't
    • Trying to access data gives you the error "Could not activate cellular data network - You are not subscribed to a cellular data service"

    Before beginning - you will want to have a backup of your iPhone backup in case you make a mistake! Yes, a backup of the backup.

    1) Download and install iBackupBot for Mac or Windows (free version works fine, but this app crashes LOTS on OS 10.8 - just relaunch it and keep trying)
    2) Open your backup and find the entry "mobile/"
    3) Double click on the file to edit it (you can cancel the prompt for registration)
    4) There is likely a more delicate change, but I preferred to wipe this file clean and let the iPhone 5 restore the correct settings. Replace the contents of this file with the following:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
    <plist version="1.0">
    5) Save your change and close the application
    7) Once complete, restore your iPhone from the backup you just edited

    Voila - enjoy LTE.
  2. rancid macrumors newbie

    Sep 22, 2012
    I can confirm this works 100%. I have been working on this problem since 9am EST and it is 10:52pm here now. I had narrowed it down to the same file as well and an APN problem but no utilities I found could edit and put back the file (I tested over 10 different ones.)

    Big thank you to the OP for suggesting this solution.
  3. caliwolv thread starter macrumors member

    Jul 11, 2008
    ;) I tried every which way to get edited backups back on the phone as well without iTunes erroring out - glad it helped!
  4. ranjanx macrumors newbie

    Sep 19, 2012

    Thanks for this. Will try this later today
  5. eagandale4114 macrumors 65816


    May 20, 2011
    Great work OP.
  6. reza96 macrumors newbie

    Aug 10, 2010
  7. caliwolv thread starter macrumors member

    Jul 11, 2008
    1) Launch iTunes, connect your phone and click on it at the left side
    2) Uncheck the option to encrypt your backup
    3) Enter your password when prompted and let the process complete
    4) Voila - you now have an unencrypted backup

    Yes, you'll lose your saved passwords but other data remains intact including accounts and saved games, etc.
  8. reza96 macrumors newbie

    Aug 10, 2010

    But I can't decrypt the saved backup on my PC to fix the issue being discussed above... I no longer have my iphone 4 and now experiencing the lost data service when restore my data to iphone 5. The only way I get it to work is to use it as a new device on itunes and sync my apps but can't restore my data :(
  9. decon1 macrumors member

    Mar 29, 2012
    Thanks OP! I had the problem for the past few hours and your fixed worked!

    LTE baby!
  10. grimmjaw macrumors newbie

    Jul 7, 2010
    I try both my Iphone 4s and Iphone 4, I didn't see the file anywhere.
    /private/var/Managed Preferences/mobile/
    the folder mobile seem empty no cellular driving me crazy.
    I even check the backup on my phone there is none
  11. decon1 macrumors member

    Mar 29, 2012
    Go further down on the list should be
    mobile/ only.
  12. Romanesq macrumors 6502a


    Jun 16, 2003

    How do you restore the backup? If you just do a restore from backup, how do you know which one is getting picked or select it?

    I tried and it didn't work and guess that's why. :eek:
  13. spaten macrumors newbie

    Oct 4, 2012
    I'm having trouble getting iBackupBot to open my backup (no it's not encrypted). When I launch it I get a popup error window stating "Invalid domain size at 27049: C:\........\Backup\<backup id>/manifest.mbdb"

    then "Error: can't load device info"

    and of course, no backups show in the ibackupbot window.

    i tried using an alternative program "iphone backup browser" to point me to the right file for the 'managedcarrier' plist. then used iplist editor to edit it as described. however when I do this, itunes throws an error about the backup not being compatible or corrupt. it doesn't do this until the restore bar has seemingly completed.

    any ideas? I tried just removing that specific plist file as well.. and got the same error from itunes.
  14. caliwolv thread starter macrumors member

    Jul 11, 2008
    Well, if you have many backups - you may want to start by moving them ALL outside of that folder (to a temporary location) and creating a new backup from your iPhone 5 by syncing it - and then you'll only have one! Then you can copy everything back, and delete any other iPhone backups from the iTunes Preferences...


    Same suggestion as above (but for a different reason).

    Move your backups out of that folder and create a new one by syncing your iPhone 5. Then edit the new backup and restore it to your phone.
  15. spaten macrumors newbie

    Oct 4, 2012
    First, thanks for the reply! However I was pretty certain I had performed this sequence through my many trials and errors... but just to be sure, tried it again. I still get the same error. I even copied the backup (15,000 files takes a long time to copy!) to another windows machine, and a mac. both gave me the same error.

    it seems that without a wholistic backup editor like ibackupbot making adjustments to the main info.plist, manifest, etc files. I can't make manual changes to the carrier plist, without deeming the whole thing 'corrupt'. >_<
  16. spaten macrumors newbie

    Oct 4, 2012
    I continued trying every possible combination. I restored my iphone 5 backup onto my old iphone 4, then deleted all backups and did a fresh backup from the 4. ibackupbot still had the same error.

    Decided that I wasn't going to get around whatever issue it was having with my backup. So, with the restore on the iphone 4, i decided to jailbreak it, and edit the plist file from the phone using iFile. This worked with no problem. Then i did a fresh backup of the iphone 4 with the now modified carrier plist file. i verified that the file on my pc in the backup indeed was modified. difference being that now it was matched with the manifest.mbdb etc.

    I then restored this backup into my iphone 5, since all the jailbroken components are left out of an itunes backup, it was 'normal'. This put the modified carrier plist into my iphone 5....

    and now.... as everyone else in this thread can attest... the fix worked for me too! :)

    figured I'd note this workaround in case anyone else was having a similar issue.
  17. AriX macrumors 6502


    Jan 8, 2007
    Worked great for me - though I did have to do one extra thing. After restoring the modified backup, I had to go to Settings -> General -> Reset -> Reset Network Settings. After this, everything worked great.
  18. dunkin1 macrumors newbie

    Sep 25, 2012
    Pittsburgh, PA
    I have had this problem almost every time I upgrade to a new phone. I used to be a blue account on AT&T and had to manually change the settings to get the iPhone to work. I don't understand why they won't put the network settings option back. I know it is because of tethering and what not but does it really matter now? This worked flawless for me. Thanks OP for the assistance. This was so much easier than previously. The last time I tried to fix it I messed with file permissions and almost bricked my phone, not fun.
  19. sdyoyo macrumors regular

    Dec 15, 2006
    I've had a problem where every so often I'd do a speed test and the download works fine, but the upload is zero, and then the speed test fails to complete because of no connectivity? Do you think this fix would help? I restored from jailbroken Verizon 4S.
  20. Iphone5stressed macrumors newbie

    Nov 1, 2012

    I can NOT find "mobile/" i have looked over the list over and over.. im not savy with these things anyways... I had a iPhone 4.. I backed it up.. then set up my 5 last night.. with the last 4 backup.. and now im having the data problem.. is this happening to EVERYONE that is backing up from a different iPhone device... I have downloaded the ibackupbot.. located last back up.. and can NOT find that "mobile/" anywhere.. I have alphabetized and I'm not pulling up anything even starting with "mobil:confused" please helpppp!!!! :confused:
  21. VeroRE macrumors newbie

    Jan 1, 2013
    Hi, I'm having the same issue, I cannot find the path beginning with " mobile"
    Did you find it?
  22. happy2run, Mar 25, 2013
    Last edited: Mar 25, 2013

    happy2run macrumors newbie

    Mar 25, 2013

    extra info it concerns a iPhone 4s

    mobile/ is the only mobile file listed

    my wife came back from a business trip to China and since then no cellular data.

    tried everything restoring etc as soon as iCloud backup is restored cellular data 3G and LTE is not working anymore.

    in the list there is no file named mobile/
    only the springboard

    I'm out of options hoping to get some input to solve this issue
  23. darricksailo macrumors 601


    Dec 18, 2012
    I think if you go to settings -> general -> reset -> reset network settings, it'll change the apn back to default

    I'm not entirely sure though but that's what it says in this article:
  24. happy2run macrumors newbie

    Mar 25, 2013
    Thanks Darrick, sadly it was the first thing I have tried and it is not working. Only works by erase settings and delete al data from your iPhone. The moment you put back your back-up it stops working.

    I have also backed up to iTunes instead of iCloud and restored sadly with the same result:

    No 3G LTE edge data so no email, iMessage, Safari on WIFI is works just fine. And phone and text works also.

    It has to do with swapping sims in this case China Unicom. I never experienced problems with China mobile only Edge data slow but reliable.
  25. happy2run macrumors newbie

    Mar 25, 2013
    Solved for me by reset all settings

    OK Still waiting for a reply from apple I got a bright moment and I have done a reset all settings

    path: Settings/ General/ reset/ reset all setting

    this will not delete you text messages or photo's and most some apps will keep their data.
    This solved my problem still I do think you should be able to only reset the network settings.

Share This Page

48 September 22, 2012