Some apps still won't launch even with watchOS 2.2 GM

Discussion in 'Apple Watch' started by 212rikanmofo, Mar 22, 2016.

  1. 212rikanmofo macrumors 65816

    Joined:
    Jan 31, 2003
    #1
    Sigh, I've had this problem for the longest time, I'm not sure why certain apps won't launch at all. Such as facebook messenger, united, cnn, skype, runtastic, and more...

    I've tried various methods that users recommended such as, unpair and repair, and even erase and restore. Still no go. I have been using watchOS beta all the way until 2.2 GM was just released. I am using the latest iOS 9.3 on my iPhone 6 Plus as well.

    This is an on-going problem that really annoys me with the watch. I've never had this much problem in an Apple product before. I thought it was suppose to "just work". Big sigh.

    I'm running out of ideas on what to do. Another strange thing I've noticed was on my iPhone that I see multiple entries of my watch. About 5 or more. Not sure if this has anything to do with why certain apps on my watch won't launch. Anyways, I hope someone can tell me once and for all exactly what I need to do to fix this problem once and for good. I want to be able to use my watch again. :(

    Thanks
     
  2. fabio.lordelo macrumors member

    Joined:
    Oct 2, 2014
    #2
    Erase all songs synced to the iPhone and try opening some of these apps again. If that it still doesn't work, turn the watch off and on again. That worked with both watches I've bought.
     
  3. Mjoshea148 macrumors member

    Joined:
    Sep 9, 2012
    #3
    Please check out this thread...it covers what you're experiencing, including a (temporary) workaround to get those apps working...the issue does not appear to be fixed in 2.2

    http://forums.macrumors.com/threads/native-apps-do-not-load.1919307/page-27#post-22698540
     
  4. xtcv2k macrumors newbie

    Joined:
    Jul 14, 2015
    Location:
    South Florida
    #4
    I had similar a similar issue with apps which eventually was a drain to my watch battery. The genius bar suggested to erase and unpair watch, back up iphone on itunes, erase iphone and restore from itunes back up, wait for iphone apps to load, pair watch as new (not from restore). It solved the issue. My apps load faster, my battery is back to normal, and my iphone gained 4GB of extra space.
     

Share This Page