Sound disabled in OS X...and I can't re-enable. Help?

Discussion in 'macOS' started by GNice, Jul 29, 2008.

  1. GNice macrumors 6502

    Joined:
    Aug 7, 2007
    #1
    For some reason the sound is disabled on my Mac. I'm running 10.5.4. I don't know what happend. I was using it earlier and sound was working. Went away for a while, came back and got ready listen to something and I noticed no sound. :( I clicked on the volume control on the menu bar and it's disabled. I have volume control on my keyboard so I pressed it and the volume "image" appears on the screen with a "NO sign". i.e. - the circle with the diagonal line through it.:(

    First tried logging off...didn't help. I restarted...didn't help. I looked in System Preferences don't see any global enable/disable item.

    In System Preferences -> Sound I click Output...the is one line under choose a device for sound output. I select it, but under the "Settings for selected device:" it says "The selected device has no output controls". Not sure what that is telling me.

    Also the Output volume slider (on that same page) is disabled...

    Any help pointers would be greatly appreciated.
     
  2. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #2
    could you post a screenshot of the icon you're receiving when you press the volume control on your keyboard?
     
  3. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #3
    I tried...and bear with me here...it's not actually on the screen. I know that may be confusing, but it's like a "ghosted" image of a speaker with square blocks under it.

    I wish I could explain better but just can't find I way to describe it. :(

    Thx!
     
  4. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #4
    Not sure how this person captured it, but it's just like post #5 in this link.

    http://forums.macrumors.com/showthread.php?t=378954

    Unfortunately I tried restarting per this thread and it didn't help.
     
  5. Jolly Jimmy macrumors 65816

    Jolly Jimmy

    Joined:
    Dec 13, 2007
    #5
    I know what you are describing. You get the same thing when you have an optical cable plugged in (There is no onboard volume control when using the optical audio output). Anyway I once had a similar problem, a Macbook that thought it needed to use the optical output, even though nothing was plugged in. I could see the red optical signal coming out of the headphone socket. Can you check if that's happening?
     
  6. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #6
    Tried removing "com.apple.soundpref.plist" in the Your Name > Library > Preferences folder.
     
  7. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #7
    except it is actually on the screen and you can capture it.
     

    Attached Files:

  8. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #8
    Sorry...I didn't know how to do it...my bad...excuse me.
     
  9. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #9
    lo siento. Anyway did removing that plist help?


    maybe... and I hate to be the one who always says this... repair permissions?
     
  10. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #10
    Thx for the help...

    Removing the plist didn't help, but thx for the idea. Already did repair permission with no luck either.
    This is bad...really bad. Never expected this from OS X...
     
  11. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #11
    it seems like it thinks something is plugged into your audio out port. (Is there?)

    maybe take it to an apple store.
     
  12. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #12

    Well...you fixed it for me. :D

    Seriously...I never thought to look at the audio port because I hadn't touched it or the speakers at all. So I thought this had to be on the software side. Plus it looked like the sound was disabled on the OS.

    Well, I unplugged the speakers and plugged them back in and the sound is back.

    Odd...really odd since nothing or no one could have possibly touched my Mac...no one else is here and I didn't.

    But I'm happy to be back in business.
     
  13. MyMaria macrumors newbie

    MyMaria

    Joined:
    Mar 22, 2009
    #13
    gee.. thanks to this thread.. i figured out how to fix the very same thing... my speakers seem to be grounded (or the cables are?).. i was :confused: because the sounds suddenly got disabled...

    something like this from the other thread:
    [​IMG]

    then after reading this thread.. i simply disconnected then plugged back the speakers and i got my sounds back!!! :D
     
  14. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #14
    Most likely because the optical out is on - check if there is a red dot coming out of the audio output on your Mac. Try plugging and unplugging an audio cable to try and switch it.

    There is been people who have carefully used a paperclip to try and trigger the switch. The optical toslink connector is longer than a normal 3.5mm jack, and will enable optical out. Though sometimes it'll remain on optical etc.
     
  15. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #15
    My audio out can be a bit shaky at times too--if I hit the plug, sound will sometimes go out--but for the most part it works fine as long as I leave it alone. So I guess the audio out jack should be an obvious first thing to check for audio problems especially if you have external speakers.
     
  16. HoldenC macrumors newbie

    Joined:
    Jan 17, 2010
    #16
    Solution!

    I suffered this problem for over two years on my PowerBook G4. Only multiple re-starts would help.

    The problem is with the digital audio output switch described in the last posts here. Easiest solution I found was to plug in your headphones and plug them out. That seems to reset the port to internal speakers and everything works fine.

    You might need to plug in/out a few times if it doesn't reset first time.
     
  17. mikesanz macrumors newbie

    Joined:
    Jan 7, 2011
    #17
    This worked for me! Thanks!!

    Just had to plug in a pair of headphones into the headphone jack and then unplug and sound was working again.
     
  18. CreativeNiceguy macrumors newbie

    Joined:
    Feb 21, 2012
    #18
    Plugging Speaker/Headphones worked for me too

    Sound just went out with the ghosted icon problem as well. Had computer for over 3 years never even plugged anything in the speaker nor line in port.
    Plugging Speaker/Headphones worked for me too.
     
  19. jayar256 macrumors newbie

    Joined:
    Apr 17, 2012
    #19
    Another reason for sound not to work

    I've had my MacBook Pro for about half a year. Shortly after I bought it my headphone jack (actually just the tiny tip) broke off in the headphone port. Since then the Mac thinks there's a jack in there and the speakers are muted (except during start-up, so I know they do work). It seems the only repair option is to replace the mother board at a cost of over 1100 Euros (!). I bought an iMic (USB sound adapter) from Griffin, so now I can get sound (as long as I have the iMic cable with me).
    So, is there a way to unmute the speakers?
     
  20. Dragonchilde macrumors newbie

    Joined:
    Nov 10, 2010
    #20
    This drives me crazy

    The first time this happened, I had been listening to my mac through headphones. After getting neck cramps flipping that tiny little switch, I never plugged anything into it again. The on board speakers are enough for what I do, anyway.

    Problem is, last time I turned off my mac (which I do when I go out of town in case of brownouts, cats, etc) I turned it back on, and lo and behold, that ^*%#%@ switch was glowing red again! This is aggravating, because I KNOW that I didn't plug anything in there. Why would it trip? Is it like a breaker or something?

    Anyway, with some more painful neck and eye contortions, I got the switch flipped, but is there ANY way to get this to stop?
     
  21. dportabella macrumors newbie

    Joined:
    Oct 12, 2014
    #21
    SOLVED, in my case by deleting file ~/Library/Preferences/com.apple.systemsound.plist

    Thanks, this worked for me!
    the filename was a bit different though: ~/Library/Preferences/com.apple.systemsound.plist

    some more info: the problem was that OSX was trying to use "Digital Out" instead of the "Internal Speakers".
    So, I went to System Preferences -> Audio -> Output. When plugged in a headphones, the output list shows a "Headphones" entry. when unplugging the headphones, then the output list showed a "Digital Out" entry.
    After deleting that plist file (no need for rebooting), and plugging and unplugging the headphones, then the output list showed a "Internal Speakers".
    and the audio is working again.
     
  22. YanniDepp macrumors 6502

    YanniDepp

    Joined:
    Dec 10, 2008
    #22
    I'm sure a lot of file names have changed in OS X between 2008 and 2014. :rolleyes:
     
  23. dondavanzo macrumors newbie

    Joined:
    Oct 19, 2014
    #23
    SOLVED as if it was a Hackintosh - Voodoo HDA bypasses Optical Audio "Switch"

    If the above resolution doesn't work cause the optical audio switch internally is stuck.... Don't throw the MacBook away or replace the logic board or pay to replace the jack....

    Don't poke it with a stick.... instead bypass the optical audio(if you don't need it) and here is how I did it:

    http://forums.macrumors.com/showthread.php?p=20146330#post20146330

    ----------------

    I have tried for years to fix this dam Optical audio issue and recently got to thinking after I built myself a killer Hackintosh for work why couldn't this audio issue be solved using some Hackintosh Kext like the ones I used building my

    Well guess what IT CAN!

    Here is what I did:

    Tested theory & audio first with an Ubuntu Live CD - - - AUDIO WORKS!

    Downloaded the current Voodoo HDA Kexts from Sourceforge - http://sourceforge.net/projects/voodoohda/ which are for Intel HDA to begin with :) v286 and ran the installer.

    The I downloaded the Kext Utility (Google Search to find it) It will be in the download section of: tonymacx86.com

    Just run the kext utility to repair permissions, clear caches etc.

    Then restart.

    After restart audio possibly could be / will be a little low, or won't mute or won't lower, so you will need to enable the Voodoo HDA Audio fixes as needed here:

    1. Open the Terminal and go to /System/Library/Extensions/VoodooHDA.kext/Contents directory.
    2. Type the command: sudo nano -w Info.plist.
    3. Press CONTROL-W (^W for search) and search for the string "VoodooHDAEnableHalfVolumeFix" (without the quotes). Change the value from false to true. Save the file. enable other fixes as needed.
    4. Fix your permissions by running Kext Utility and clear your caches.
    5. Reboot the system. Volume now at the right levels...

    THATS IT!!

    PUT THIS Circa 2006 / 8+ YEAR HEADACHE TO REST!!!

    Apple couldn't do it or didn't want to and so many people on the Apple forums say you can't bypass the optical audio switch.... BS!

    Not to mention when I posted this resolution on Apple Support forum they were quick to take it down.....

    SOLVED AND FIXED WITH HACKINTOSH METHODOLOGY!

    Send your love....

    Friend me on www.facebook.com/donald.davanzo
     
  24. kittencounter macrumors member

    Joined:
    Mar 22, 2013
    #24
    Unplug headphone and plug in again or just plug in a headphone if you don't have any plugged in
     

Share This Page