spontaneous reboot when turn on USB DAC

Discussion in 'Mac mini' started by RustyShackleford, May 22, 2018.

Tags:
  1. RustyShackleford macrumors newbie

    Joined:
    Oct 19, 2015
    #1
    I am using a mid-2010 Mac Mini running OSX 10.11.6 as a "headless" music server. It is connected to a DAC, via USB, and thence my stereo system. I use iTunes, playing mostly rips of CDs. If I power the DAC off and then back on, the Mini reboots. The DAC has multiple input channels (TOSlink etc) and the problem occurs even if it's switched to one of the non-USB inputs. I am at a loss.

    I have tried resetting the SMC and NVRAM. I have tried different USB ports, as well as a USB isolator (between the port and the cable to the DAC).

    I don't believe it's a kernel panic, because I don't get the "your Mac restarted because of a problem" message.

    I don't believe it's the DAC drawing too much power (I need to try a USB hub to test this) because the DAC mfg'er says the USB input draws very little power and because I don't get the usual error message (when you plug in a USB device that draws too much power for the port).

    Thanks for any ideas !
     
  2. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #2
    I would try the same thing (DAC off-on) without connecting the DAC to the Mini - perhaps it might be a power (as in AC) issue.
     
  3. RustyShackleford, May 22, 2018
    Last edited: May 23, 2018

    RustyShackleford thread starter macrumors newbie

    Joined:
    Oct 19, 2015
    #3
    Unplugged the USB cable and can cycle the DAC power with no problems. In fact, plugging and unplugging the USB cable, with the DAC powered-up, also causes no problem.
     
  4. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #4
    Do you have a DAC that draws power from the computer (like the DragonFly)? Do you have problems with other USB devices connected to the Mini (AC powered or not)? (Although the DragonFly doesn't have multiple inputs - duh.)

    Do you know if the DAC required manufacturer-supplied software to be installed? If so, it could be that software. If you're at all unsure, you can try running the Mini in safe mode, make sure you don't have any audio-related software running and try the DAC off-on.
    https://support.apple.com/en-us/HT201262
     
  5. RustyShackleford thread starter macrumors newbie

    Joined:
    Oct 19, 2015
    #5
    It's an Emotiva XDA-2 (a large component with multiple inputs, volume control, de-jitter circuit, etc); yes, the USB receiver section takes power from the computer, but the mfg'r (who is very engaged with trying to figure this out and very savvy) says that it uses very little USB power and should not be a problem for any USB port to supply. And since the computer does not give that message that one sees when plugging in a USB device that draws too much power, I doubt seriously this is the problem. I could try a powered USB hub and see what happens, but I don't ave one right now.

    You mean did Emotiva supply software with the DAC that you're supposed to install on a computer connected to its USB input ? No.

    The only such software I've installed would be BitPerfect (hijacks iTunes to provide un-molested digital stream to the Mini's outputs).

    Do you think I should try safe mode anyhow ?
     
  6. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #6
    Safe mode is worth a try - it's easy to do and you have a diagnostic (DAC off-on) that is also easy and consistent.

    You might want to try single-user mode since it's also easy to do. If it has the same problem, that would point more towards a hardware issue.
    https://support.apple.com/en-us/HT201573
     
  7. Partron22 macrumors 68020

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #7
    Anything else connected via usb that might put the bus near its limit?
    USB 2 doesn't usually give you more than 500mA to work with, and other power hungry devices can drag that down. See this page: https://support.apple.com/en-us/HT204377

    I'd unplug everything USB that I could, including maybe Music HD, and then try the DAC. When I've had troubles like this, a powered hub was usually the answer.
     
  8. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    The XDA-2 plugs in to AC somewhere - - As far as I can find out, it is self-powered, not bus powered (it has its own power cord)
    Are you plugged in to the same power strip where your Mac mini gets power?
    Have you tried moving either the XDA-2 power cord, or the mini power cord to another connection so neither is on the same circuit - at least, not on the same surge suppressor?
     
  9. RustyShackleford thread starter macrumors newbie

    Joined:
    Oct 19, 2015
    #9
    Nothing else on the USB, not even a keyboard or mouse (since it's "headless", so controlled using Finder-sidebar screen-sharing from my laptop, or iTunes remote on iPad).
    I need to try that, for diagnostic purposes if nothing else (I need to buy or borrow one). However, audio people think that can introduce artefacts like jitter. That's why people thing it's preferable to connect the DAC via USB instead of TOSink. Of course, going optical would solve this problem for me (the Mini has both USB and optical outputs and the Emotiva has both USB and optical inputs). But the Emotiva has an ASRC de-jittering circuit - resamples to 96Khz and syncs to a good clock; but then of course that resampling can cause artefact too. And so on and so on and scooby dooby do ...
    --- Post Merged, May 23, 2018 ---
    Correcto-mundo. However, apparently the receiver circuit (on the DAC's USB input) does take its power from the USB input (i.e. from the Mini). But their tech guys say it's "very little" and I'm sure they're familiar with the issue of the USB bus providing limited power. Also (see above) unplugging/plugging the USB cable does not cause the reboot, and I've never seen the message that I've often seen when a Mac complains a USB device wants too much juice.
    Yes, same TrippLite surge suppresor. I've tried moving off the surge suppressor, but not to a different AC circuit. I could try that, but the fact the problem doesn't occur if the USB cable is disconnected suggests it's not interference over the AC mains. And it occurs if I use a USB isolator. But I should try this; actually I could power Mini or DAC off an inverter connected to a 12v battery (which I have) - THAT's the ticket to eliminate this possible cause for good.

    Sorry if it seems like I'm blowing off all you guys' suggestions. There's definitely still some stuff I should try: USB hub, safe mode.
     

Share This Page