Spotlight not working in 8.1.1

Discussion in 'iOS 8' started by supersalo, Nov 17, 2014.

  1. supersalo macrumors 6502

    supersalo

    Joined:
    May 14, 2010
    #1
    Looks like Spotlight isn't returning any results for 'Apps'.

    I'm seeing this on two different devices. Restarted one and still no results.

    Anyone else seeing this?
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    working for me. is Applications checked in your setting > general > spotlight?
     
  3. supersalo thread starter macrumors 6502

    supersalo

    Joined:
    May 14, 2010
    #3
    Yes, I even toggled Applications off, then on. Must be just me. Joy!

    Edit: Ok, now it is working. I guess me posting here threatened it.
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    lmao ok.
     
  5. AnimAlu macrumors member

    AnimAlu

    Joined:
    Sep 19, 2012
    Location:
    Long Beach, CA
    #5
    Since 8.0, I've had spotlight randomly not returning apps...Haven't tried to find a pattern though.
     
  6. antiprotest macrumors 65816

    antiprotest

    Joined:
    Apr 19, 2010
    #6

    Agree. Sometimes things don't want to work until you show them you mean business.
     
  7. richard371 macrumors 68000

    Joined:
    Feb 1, 2008
    #7
    I have the same problem. Rebooted and it didn't fix it. Finally it just started working. Maybe it was indexing or something?
     
  8. AdonisSMU macrumors 603

    Joined:
    Oct 23, 2010
  9. Zeos macrumors 6502

    Joined:
    Jan 24, 2008
    #9
    Same thing here. Started working just as I started to post. I have had this problem since 8.1. Spotlight sometimes does not return Apps in the search. Works after several tries.
     
  10. iapplelove macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #10
    I have had this happen s bunch of times since 8.0
     
  11. fortheus macrumors regular

    Joined:
    Jul 11, 2012
  12. Lancetx macrumors 68000

    Lancetx

    Joined:
    Aug 11, 2003
    Location:
    Texas
    #12
    Same thing happened to me after first installing 8.1.1 on my iPhone 6, but a reboot immediately fixed it though.
     
  13. mcdj macrumors G3

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #13
    In settings/spotlight, drag apps to the top of search results. Then open spotlight and type a period. Every app on your device will be listed, and this seems to index them.
     
  14. 33man macrumors regular

    Joined:
    Sep 27, 2011
    #14
    Same issue here on iPhone 6. I'm not the best organized with my springboard so I use spotlight to start apps... Today after iOS 8.1.1 I got only music results no applications listed... Strange... I only linked the phone to synch over wifi to my MacBook, I doubt this is the issue, where it didn't finish to synch apps so it get stuck...

    Anyway will try the hard reboot...

    Hmm Apple every release new bugs... :(
     
  15. AdonisSMU macrumors 603

    Joined:
    Oct 23, 2010
    #15
    Accept when its not a bug. There will never be a bugless release. There has never been a bugless release.
     
  16. macduke Suspended

    macduke

    Joined:
    Jun 27, 2007
    Location:
    Central U.S.
    #16
    Something is borked with the Spotlight on my iPad. I first noticed the no apps in Spotlight the day before 8.1.1 came out, and then after installing the update they were still missing. Today it's working, but then I tried another test. I typed "guardi" on my iPhone and it auto fills with Guardians of the Galaxy (film) on Wikipedia, then the album on iTunes, and then the Bing search results. On my iPad everything is blank, even when I fill in the full name for the film. Events, notes, reminders, etc are all showing up fine, along with apps suddenly working too. And yes, I've tried rebooting (even installed that update) and toggling the switches in settings.
     
  17. Chaztrip macrumors member

    Joined:
    Sep 17, 2014
    Location:
    West Des Moines
    #17
    Not working on my 6+ after a reboot as well. Did not realize how much I relied on it until its borked up.
     
  18. yozh macrumors 6502

    Joined:
    Aug 17, 2008
    #18
    Mine is not working eather, tried to reboot, uncheck apps in settings of spotlight, recheck, move around etc... nothing Apps are not showing up.. On iPhone 6
     
  19. hendrics macrumors newbie

    Joined:
    Nov 18, 2014
    #19
    same here - no spotlight search for apps

    rebooting now. iPhone 5s. Spotlight stopped indexing any apps, only contacts. Enabling/disabling it didn't help.
     
  20. reece1605 macrumors newbie

    Joined:
    Nov 18, 2014
    #20
    Found a work around

    It doesnt get rid of the bug entirely, but I have found that on this occasion (for me), deleteing the app that wont be found, and then reinstalling, somehow then allows spotlight to find it again when searching.
    The app that couldnt be found by spotlight for me was the 'Remote' app for controlling Apple TV.

    Once deleted and reinstalled, it now can be found by spotlight.

    I have reported to Apple feedback
     
  21. fljoemon macrumors newbie

    Joined:
    May 9, 2011
    #21
    Spotlight not searchign Apps

    I cannot get Spotlight to return Apps that I am searching. I removed everything from Settings -> General -> Spotlight Search and ONLY left Applications on (tick mark against it) and it stil doesnt work. Seems like a BUG in iOs 8.1.1. Just updated to this version today .. hpefully they will have a fix soon.
     
  22. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #22
    In addition to no apps showing in my results the search box and results are half the normal width and in the center of the screen. 6 Plus. The first time it happened I did a reboot which stuck at the Apple logo and stayed there. I had to restore via iTunes (DFU) to get the phone working again. The second time a reboot fixed it and so far has been working fine. I never used to use this tool but I have been training myself to use it because it really is a nice feature. I believe Apple will get it worked out one day.
     
  23. BanditoB macrumors newbie

    Joined:
    Feb 24, 2009
    Location:
    Chicago, IL
    #23
    Me, Too!

    I had this same problem with my iPhone 6 Plus when I went to do a search this afternoon. I tried it several times and it wouldn't return results for any of my apps.

    I then went into settings and unchecked and rechecked the apps search results and tried again but no dice. I did a bit of reading on the device and tried a search again afterwards, but it again didn't work.

    I returned to my office and iPad and tried it and apps were there in its Spotlight results, so I went back to the iPhone for one last check and suddenly it worked! Phew! That was a relief.

    Thought I'd check and see if anyone else was having this issue and ended up here. Thanks for confirming that I wasn't just seeing things!
     
  24. popcorn-in-sac macrumors member

    Joined:
    Jan 30, 2008
    Location:
    Seattle, WA area
    #24
    I was seeing this as well. I decided to try a "reset all settings", and when it came back from the reboot, this issue was gone, and it's working fine now. I had to re-do a few various settings, but nothing too difficult.

    Mark
     
  25. Cvx5832 macrumors regular

    Joined:
    Nov 2, 2014
    #25
    We have a half dozen iThings in our household. What worked for us consistently is unchecking Applications, exiting the menu, pull the shade down as if to search (on the home menu), then clicking Applications on again. It should index and search fine after that. At least it did for us.
     

Share This Page