Spotlight search bug - will restore from backup help?

Discussion in 'iOS 9' started by Paco II, Dec 25, 2015.

  1. Paco II macrumors 65816

    Joined:
    Sep 13, 2009
    #1
    My iPhone 6 running 9.2 is afflicted with the Spotlight search bug, where I get no results at all. I've tried the various tricks to get it to start working again, and they work, for about 10 minutes, when it stops working again.

    Does anyone have experience with this issue? I'm wondering if restoring the phone then restoring from an iCloud backup will help at all? No idea the source of this issue and can't find anything online about it. Is it bad settings related? A rouge app?

    Would love to find a more permanent solution.
     
  2. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #2
    What various tricks? Perhaps a settings>reset>reset all settings will resolve it. That fixes strange issues typically. Of course you have to add back wallpaper and wifi networks as well as go through your settings to set as you prefer. Pretty painless though.
     
  3. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #3
    Sadly reset settings did not work. Tried everything I could think of. Ended up restoring and starting fresh.

     
  4. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #4
    Sadly, the issue has returned. Spotlight search will work briefly after a reboot, but then eventually stop working again. Is it a memory management issue?
     
  5. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #5
    No. Have you turned off suggestions and such in the spotlight search options in settings? If not, try toggling them and then wait 5 seconds or so before you hit the page again.
     
  6. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
  7. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #7
    Your suggestion didn't help. But your 'No' seems pretty confident. What do you believe is the cause of this bug? And how is disabling features a fix? :)

     
  8. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #8
    Guess I'll continue with the email yourself hack fix. Pretty annoying bug.
     
  9. bripab007 macrumors 6502

    Joined:
    Oct 12, 2009
    #9
    I, too, have been experiencing this on 9.2. It does indeed get resolved after a reboot, but then turns sour again after a couple days.

    What's the email yourself hack fix?
     
  10. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #10
    The email hack trick, for me, only makes it work again for like an hour. Than stops working again :( Really annoying bug this is. The hack fix is simple: send an email to an account set up in your native iOS mail app. When your phone receives it, Spotlight search will start working again for some temporary amount of time.
     
  11. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #11
    a few more things to try according to our sites.

    1. go into the spotlight search settings and toggle everything off. Restart the phone, toggle everything on and wait a few minutes.

    2. go to the contacts app, groups, hide all contacts, show all contacts.
     
  12. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #12
    Like the email 'fix', all these approaches provide short term relief, but the issue always returns. I've read and tried all these approaches. Unfortunately there does not appear to be a known cause of the issue, and as a result, no lasting fix. Maybe 9.2.1. Fingers crossed :)

     
  13. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #13
    good luck man wish I hand a permanent answer.
     
  14. Woodcrest64 macrumors 6502a

    Woodcrest64

    Joined:
    Aug 14, 2006
    #14
    My issue with spotlight is that when I search for text/sms/imessages I get some results but not everything. I use this all the time for messages sent from clients. Having this broken is a pain. I tried searching with in the messages app but its worse with even less results.
     
  15. Paco II thread starter macrumors 65816

    Joined:
    Sep 13, 2009
    #15
    Yeah it's definitely a weird one. Tried many things to isolate cause (removing apps, changing settings) but no success. Here's hoping for 9.2.1

     
  16. bripab007 macrumors 6502

    Joined:
    Oct 12, 2009
    #16

Share This Page