Startup boots to gray screen. What to do next?

Discussion in 'OS X El Capitan (10.11)' started by pbl24, Dec 13, 2016.

  1. pbl24, Dec 13, 2016
    Last edited: Dec 13, 2016

    pbl24 macrumors newbie

    Joined:
    Dec 12, 2016
    #1
    I've trolled this forum and many others for potential solutions, all unsuccessful. My machine is a 15" 2011 MBP (Core i7, 16 GB RAM) running El Capitan. I was in the middle of a session when my computer spontaneously went to a gray screen. I initially suspected hardware problem. After rebooting, the startup phase makes it to the initial screen with the Apple logo and progress bar and proceeds to the end before simply stalling again at the gray screen. I've tried the following steps in order with the observed outcome:
    • Reboot - returns to gray screen
    • Safe boot (Shift key) - does not enter safe boot, returns to gray screen
    • Clear NVRAM (Cmd + Option + P + R) - successfully clears NVRAM, returns to gray screen
    • Reset SCM - (Shift + Ctrl + Option + Power) - successfully clears SCM, returns to gray screen
    • Single user mode (Cmd + S) - successfully enters single user mode. Tried running the file system check (multiple consecutive times), and hardware reports okay:
      Code:
      /sbin/fsck -fy 
    • Single user mode + forcing safe boot (in single user mode: sudo nvram boot-args="-x") - does not enter safe boot, returns to gray screen
    • Apple Hardware Test (D key) - does not start Apple Hardware Test
    • Internet Apple Hardware Test (Option + D) - reports hardware as OK. Ran extended hardware test which also reports as OK
    • Recovery (Cmd + R) - does not start recovery
    • Internet Recovery (Cmd + Option + R) - runs to completion, but shows forbidden/prohibited icon after progress completes
    • Verify and repair permissions:
      Code:
      sudo /usr/libexec/repair_packages --repair --standard-pkgs --volume / 
    • I'm able to put my computer into target disk mode and access files on the HDD
    • I created a bootable USB drive using both El Capitan and Sierra installers with booting to the device resulting in return to gray screen. I tried on 2 separate devices (USB thumb drive and an external hard drive) and 2 separate methods to create installer (using createinstallmedia command in installer and DiskMaker X). In all cases, the device is recognized as being bootable (available as a startup disk), but when selected, the Apple logo and progress bar appear and eventually transition to the gray screen (was expecting the Disk Utilities application)
    The odd thing was that I was in the middle of a session when my screen went gray and my computer rebooted, so it's not like an update caused the unstable state.

    One major open question is if it's related to the apparent video issues some models experience: http://www.apple.com/support/macbookpro-videoissues/. The machine has Intel HD Graphics 3000 and an AMD Radeon HD 6750M.

    Any steps that I'm obviously missing? Help and/or suggestions is appreciated.
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    It looks like you have a done a very good job of trying to solve the problem.

    The dGPU could have failed. Get it to Apple for testing ASAP. The video repair program ends this month! Even if it is not the dGPU Apple could diagnose the problem during their testing.

    BTW, I had the same problem with my 2011 MBP December 2015 that Apple repaired with a replacement logic board.
     
  3. pbl24 thread starter macrumors newbie

    Joined:
    Dec 12, 2016
    #3
    Awesome, thanks for the suggestion and heads up CoastalOR. Appreciate it.
     

Share This Page