Strange problem with Time Machine - Help!

Discussion in 'macOS' started by baryon, Jun 12, 2011.

  1. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #1
    I have a MacBook Pro running Snow Leopard (latest version) on a 320 GB drive. I have been using Time Machine to back up to a 500 GB external USB drive (Western Digital MyBook).

    I never had serious need of Time Machine, only occasion accidental deletions and over-writings, and I never had problems before.

    However, today, I was playing Minecraft and I wanted to go back to yesterday's saved game because I died. You have to know that Minecraft only makes a single save to keep the gameplay realistic, so it keeps overwriting the save files. That way, the only easy way to revert to an older game is to make a copy of the save, or just rely on Time Machine. When I entered Time Machine and scrolled back to "Yesterday", I noticed that the saves were from something like 1 month ago. There was nothing in there from yesterday.

    This shocked me, not because I'm such a Minecraft maniac, but because I thought "then what else isn't getting saved?". I quickly went to my Photos folder and sure enough, it didn't have a backup of the latest album (which was created 1 week ago).

    It's as if it simply stopped backing up.

    Time Machine is ON, there are no exceptions set up, there is enough free space on it to keep more than my entire system backed up at least once, and I didn't change any of the settings lately. It's also backing up hourly as it should, I can hear the hard drive spin up and the Time Machine icon is animating. It even says "Last Backup: Today, 22:20" right now, meaning that it made a backup an hour ago. However, the files that were there an hour ago are nowhere to be found in Time Machine.

    Can anyone help with this? What could be going on? I've always had trouble understanding Time Machine, but this is clearly a problem and not just me not understanding it.

    What I never get is this for example: "Time Machine Keeps Daily Backups for the Past Month": what does this mean? After a month, which daily backup does it keep? Does it consolidate 30 backups into one? How does it decide which files to keep and which ones not to after a month? How do I know what isn't getting backed up?

    I really feel like I should not be using Time Machine anymore as it can't seem to be trusted, what should I do?

    Thank you for your help!
     
  2. Jagardn macrumors 6502a

    Joined:
    Apr 18, 2011
    #2
    Where does the saved data for your game reside?
    Did you browse Finder to the window of your target then click the Time Machine Icon?
    I would think it should be there, it should do daily archives for 30 days.
    Have you tried mounting the sparsebundle and browsing the folder for yesterday? Any files that changed should be in there.:confused:
     
  3. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #3
    I tried from the Time Machine interface, wasn't there, and then I tried going to Finder and checking out the various folders on the Time Machine disk, wasn't there either. The weird thing is most things are there, but this isn't.

    The files are in User/Library/Application Support/Minecraft/Saves

    And my Photos folder is User/Pictures/Photos/<one folder for each album>

    I noticed that nothing really got saved for the past few weeks or so, even though Time Machine does at least pretend to back things up hourly.

    What do you mean by "mounting the sparsebundle"? What is that and how do I do it?

    Should I wipe my backup drive and re-start a fresh Time Machine?
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
    A sparsebundle only exists if the Time Machine backup is on a Time Capsule. As you said your backup disk was connected to your system via USB, this doesn't apply to you.

    As for what you should do... do you normally sleep your system? When was the last time you did an actual restart of the system? I think Time Machine has an issue when you sleep the system too many times since the last restart.
     
  5. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #5
    Open /Applications/Utilities/Disk Utility and in Disk Utility run a repair on the Time Machine disk (or sparseimage for remote time machines). See if that helps.
     
  6. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #6
    Thanks for your help!

    I sleep my machine many times a day, but I reboot at least once a week... This is the way it was for the past 3 years and there were no problems...

    I'll try a repair on the backup disk, hopefully it will say something useful!
     
  7. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #7
    I would suggest looking in Console.app to see if Time Machine has placed any error messages into the log.

    Open Console.app (which is in /Applications/Utilities) and in the left pane make sure that "All Messages" is selected. Then you'll see messages logged from Sender "com.apple.backupd" -- these are the Time Machine backups.

    You can use the Clear Display button, then start Time Machine (Back Up Now). I get 18 or 20 messages from com.apple.backupd, and they pretty much make sense and don't sound like errors. Perhaps you'll see a disk mount failure or some such error to account for what's going on.

    Regards,
    Brian33
     
  8. baryon, Jun 14, 2011
    Last edited: Jun 14, 2011

    baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #8
    I did what you said, it doesn't show anything that would look like an error. This is exactly what it says:

    • Starting standard backup
    • Backing up to: /Volumes/Backup/Backups.backupdb
    • No pre-backup thinning needed: 701.4 MB requested (including padding), 14.83 GB available
    • Copied 10 files (93 bytes) from volume Macintosh HD.
    • Starting post-backup thinning
    • No post-back up thinning needed: no expired backups exist
    • Backup completed successfully.

    I have rebooted since last time and nothing changed.

    EDIT:

    I created a 60 MB file on the Desktop and hit "Backup Now" to see what the log says. It says exactly the same thing! Including "Copied 10 files (93 bytes) from volume Macintosh HD"! Why 10 files? Why only 93 bytes? It clearly didn't back up my new 60 MB file did it?​

    /EDIT

    Here's a screenshot and some explanations of my problem:

    Untitled-1 copy.jpg
    * the .jpg file has been on my Desktop for more than a month, that one has been backed up, so the problem started somewhere between now and a month ago.

    I have many files that I created in the past week, however, none of them show up when I go back as little as one hour in Time Machine. If those files get deleted, they're gone forever, as Time Machine didn't even back them up.

    The weird thing is I get no errors whatsoever, and I can see and hear a backup happening every hour, and Time Machine even says "Backing up" and "Last Backup: <time>" with the time being no older than an hour ago.

    What I have noticed lately is that backups are incredibly fast. Maybe that might be related to the problem.

    Should I just wipe my entire Time Machine disk and restart Time Machine from scratch? Deleting the backup is better than deleting data that isn't backed up...
     
  9. baryon, Jun 14, 2011
    Last edited: Jun 14, 2011

    baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #9
    (New post, because otherwise it would get really messy)

    Okay, so I checked a few things, none of them worked:
    • Deleted "Macintosh HD/Library/Preferences/com.apple.TimeMachine.plist"
    • Verified the Time Machine disk - everything seems fine
    • Placed a file into the topmost level (Macintosh HD) to see if it gets backed up - no, it doesn't

    I have read and tried everything on the following site:
    http://web.me.com/pondini/Time_Machine/D5.html

    ... and I found a thread about a guy who had a corrupted Home folder:
    https://discussions.apple.com/message/10267660?messageID=10267660

    However, if I had a corrupted Home folder, the topmost level (Macintosh HD) would still get backed up, wouldn't it? Because for me, it didn't.
     
  10. Bronken macrumors member

    Bronken

    Joined:
    Jun 11, 2011
    #10
    Im not a pro and maybe there is a better solution but I'd wipe the TimeMachine HDD and star a whole new TimeMachine like you said and keep an eye on the behaviour then...
     
  11. Jagardn macrumors 6502a

    Joined:
    Apr 18, 2011
    #11
    Strange, I just tested some of the same stuff you did by adding folders/files and backing up. Then deleting and backed up again, all my files were there. You've got something strange going on there, I am running a Time Capsule, but the functionality shouldn't be any different.:confused:
    I would try like the last poster said, maybe something is corrupt. Maybe even a re-format wouldn't be a bad idea if your going to start from scratch.
     
  12. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #12
    You mean re-format my internal HDD or just the Time Machine one? I think I'll just do the Time Machine first, and if that doesn't work, I won't have a backup, so I can't reformat my internal anyway...
     
  13. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #13
    NO! Don't format the drive containing the data you are trying to save, :eek: especially when there is evidence the backup is not working right. If you rename the file TM is backing up to on your external drive, it will simply create another one and back everything up to it. Of course you won't get to "time warp" back to previous dates but there is some reason to suspect you don't have a valid backup anyway. I'd say be willing to lose your entire backup history if it means you can back up reliably from now on, but whatever you do, don't touch your internal HDD until you know that you know TM is backing it up properly.
     
  14. Jagardn macrumors 6502a

    Joined:
    Apr 18, 2011
    #14
    Holy hell! Not your OS HDD. :eek:
    Sorry I didn't specify, I just figured you'd know not to format your internal drive. :)
     
  15. baryon, Jun 15, 2011
    Last edited: Jun 16, 2011

    baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #15
    Yes, don't worry, I wasn't going to touch my internal drive :D
    I won't have enough space to rename my Time Machine backup and let it start a new one, as the drive is full (but that isn't the cause of my problem, as Time Machine is supposed to fill up the drive, and then delete older backups).

    I think I'll just format the Time Machine drive, and that's all I can do now.

    EDIT:
    I formatted my Time Machine drive and it seems to be working perfectly fine now! The initial backup went fine and the hourly ones seem to work too. Thanks for your help!
     

Share This Page