Stuck in installing mojave.

jwlayug

macrumors newbie
Original poster
Mar 23, 2017
19
4
i tried installing mojave in my imac 27inch late 2012 but when im in process of installing, it just hangs. I tried doing cmd-opt-r(hang),cmd-r(hang),shift-opt-cmd-r(hang). I tried bootcamp, windows 10 is installed but when i tried to install the drivers, when the gfx card (gtx680mx) is about to installed, it just blackout. Someone help me pls. Thanks.
 

Honza1

macrumors 6502
Nov 30, 2013
436
143
US
It may be impossible to help you here.
Next step depends on what you have and how skilled you are.
1. I would boot from bootable backup which I would reliably have before I would try to do anything with the system. Carbon Copy Cloner or SuperDuper can clone system disk to external disk and make it bootable. And both have free/demo version which is enough for use you need.
If you have done such backup, boot from that backup (google how to select boot disk in OSX) and investigate what the state of the system disk is using Disk utility. If it is still OK, wipe it, clone the backup back to the original disk, shut down, unplug the backup and boot back to internal drive. Try upgrade again... This worked for me before.
2. If you have at least TimeMachine backup, build bootable USB installer (there are tools and instructions, google it) and boot on that. Wipe internal drive, install system and migrate from the TimeMachine.
If none of this applies, find someone locally who may (or may not) be able help you - Apple store genius bar or some Mac guru who can do the stuff - at the computer... That is probably beyond what can be done through the forum here.
 

Fishrrman

macrumors P6
Feb 20, 2009
17,449
5,665
1. Pull the plug out of the wall, wait 30 seconds, then plug it back in
2. Press the power on button and IMMEDIATELY hold down "command-option-R" and keep holding it down until the internet symbol appears.
3. You may need to enter your wifi password
4. Do you eventually get to the "Utilities" menu?

(we are trying to see if you can boot to "internet recovery")
 

1050792

macrumors Demi-God
Oct 2, 2016
2,517
3,933
This used to happen to me twice, what I did was unplugging the wall, plug back in and reinstall.