Suddenly very slow internet - can my Wifi receptor be damaged?

Discussion in 'Mac mini' started by felixen, Jan 17, 2012.

  1. felixen macrumors 6502a

    Joined:
    Apr 13, 2009
    #1
    Yo.. I had my Mac Mini for a few years now and never had any problems with Internet speed on it. I have a 14Mbit wifi connection, but lately wifi has been very "up and down" on my Mini. Sometimes it barely works, but most of the time I get like 2Mbit on speedtest.net. This has occurred for a week or two.

    However on my iDevices I get around 14Mbit, so it's not my router. So my question is if my Mini's wifi receptor can suddenly break down even though it's just been standing still the whole time (I haven't moved the Mini around or anything)?

    I'd try plug in an ethernet cable but I don't have one right now. I'll give it a shot when I get one soon, but until then I'd like to hear what you guys have to say..?
     
  2. IvanOhio macrumors newbie

    Joined:
    Jan 7, 2012
    #2
    Troubleshooting

    Have you checked for any updates for the firmware of the router?

    Have you checked your internet connection by connecting the mini directly by ethernet? (bypass the router)

    Any issues with your provider? i.e. outages, work being done, etc

    Have you done any software / hardware updates with your mini?
     
  3. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #3
    Hold down alt and click on the wifi symbol. Post a screenshot of the figures.
     
  4. MadDragon1846 macrumors regular

    Joined:
    Mar 23, 2011
    #4
  5. Mojo1 macrumors 65816

    Joined:
    Jul 26, 2011
    #5
    The modem can also fail. I recently replaced a Motorola Surfboard 5101 that was around five years old.

    Contact your ISP first because tech support can save you some time if the problem is on their end. If that checks-out OK and you lease the modem they can send someone to check the modem. But if you own your equipment do your own trouble-shooting or you will be charged a fee if a technician visits and discovers that the glitch is with your gear.

    Bypassing the router via an Ethernet cable is a basic trouble-shooting step, so bite the bullet and get the cable unless your ISP will do it for free.
     
  6. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #6
    I borrowed an ethernet cable to test and I get 13Mbit now, so with cable it works perfectly fine. On Wifi it's still bad though.

    I tried the alt + clicking wifi icon and took a screenshot:

    http://imageshack.us/f/706/20120117095107pm.png/

    So what do you guys think? My Mini is more than two years old AND I put in extra RAM back when I first got it, so I don't think Apple will repair it (for free, at least).
     
  7. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #7
    Nothing looks out of place. You're getting a decent signal strength and your transmit rate is exactly what I would expect from a router running in G mode on the 2.4 GHz channel. Are you sure the performance is worse than before?

    Have you tried restarting the router?
     
  8. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #8
    That's strange. I'm certain it's not running normally, there's a huge difference compared to just a week or two ago.

    I tried powering off the router and on again. I didn't want to reset it in case it would delete the settings I've made on it (I had problems playing BF3 online on my PS3 so I had to add my PS3 in the router settings - this btw shouldn't be what causes the problem as the wifi has been working fine after these changes).

    Can it be hardware related you think?


    Edit: just wanna thank everyone in here taking their time to try and help me out ;)
     
  9. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #9
    I don't think it's hardware related. Don't reset your router, but maybe you could do a "cold restart" on your router. In other words, switch it off, unplug it from the plug for 10-15 seconds and then start it again. It should still have all of your settings. This method works for a lot of odd behaving electronics from PVR/Cable TV boxes to TVs so it's worth a try. If it really bothers you, there isn't any point in wasting time on this. Just buy a shiny new N router - they are pretty cheap these days.
     
  10. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #10
    I tried unplugging it for a minute or two and now I get 13Mbit :) when I last tried unplugging it, it was only for a few seconds, so apparently that wasn't enough. Thanks dude
     
  11. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #11
    man now it does it again.. I'll have to call my provider :mad:
     
  12. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #12
    Try running a speed test (www.speedtest.net) and see what you're getting. It could be your service provider, or it could be the modem on its last legs.
     
  13. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #13
    That's the site I've been using :) It gives me 13 right after I unplug the router, and then a while after it goes back to not wiring at all or sometimes giving me 2Mbit.. But can it really be the router when my iPhone and iPad works fine all the time?
     
  14. Mojo1 macrumors 65816

    Joined:
    Jul 26, 2011
    #14
    If you have hardware that is connecting at the expected speed while your Mac is having intermittent problems, then it is likely that the problem is with the Mac and not the router. WiFi cards can fail.
     
  15. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #15
    This is horrible. What do you think a new one would cost me (if it's rather easy to install myself, like the RAM were)? If it's too much I have an excuse to buy a new Mini :)
     
  16. Dweez macrumors 65816

    Dweez

    Joined:
    Jun 13, 2011
    Location:
    Down by the river
  17. felixen, Jan 21, 2012
    Last edited: Jan 21, 2012

    felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #17
    yeah I guess I could look into how to change that. But wouldn't the channel only be affected by other wifi networks? Cause there's only one (thick walls in my building) and it has been there for a while when my wifi worked just fine

    Edit: How can I make the computer forget the network like you can on iPhone? Maybe that would work.
     
  18. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #18
    I am considering buying a wifi dongle that goes in the usb port. i would like to avoid the ethernet cable as I'd prefer not to have it running across the floor (I already have one list containing cables running across the floor, but it doesn't have room for more cables).

    My question is if it is possible to disable the built in wifi receiver and tell the Mini to use the USB one instead?
     
  19. Mojo1 macrumors 65816

    Joined:
    Jul 26, 2011
    #19
    Have you looked into replacing the MacMini's WiFi card?
     
  20. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #20
    Nah, not really. Don't know how to and what it will cost me, but I guess I could try and google it a bit :) It just seems easier to buy a USB wifi dongle if I can tell the Mini to use that, and not use it's internal wifi card.

    It's gonna be rather temporary anyway, I think I might buy the next Mini that comes out
     
  21. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #21
    Try changing your DNS servers.

    Go to System Preferences.
    Click on Network.
    Select the first connection in your list and click Advanced.
    Select the DNS tab and add 208.67.222.222 and 208.67.220.220 to the list of DNS servers.
    Click OK

    Those are OpenDNS servers. You can also use Google's or others. Google's are 8.8.8.8 and 8.8.4.4
     
  22. felixen, Jan 29, 2012
    Last edited: Jan 30, 2012

    felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
    #22
    Thanks. I just tried but it didn't really help.

    So I borrowed a USB wifi dongle from my dad. How do I disable the Mini's internal Wifi card so I can use this USB one instead?
     
  23. felixen thread starter macrumors 6502a

    Joined:
    Apr 13, 2009
  24. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #24
    have you ever opened your mini? pulling the card on a 2009 mini is pretty easy to do.
     
  25. Schtumple macrumors 601

    Schtumple

    Joined:
    Jun 13, 2007
    Location:
    benkadams.com
    #25
    Wifi symbol in the menu bar, triangle with 4 bars, click it, and click turn wifi off.
     

Share This Page