Tempermental iPhone 4 home button 4.1

Discussion in 'iPhone' started by applefanDrew, Sep 15, 2010.

  1. applefanDrew, Sep 15, 2010
    Last edited: Feb 20, 2011

    applefanDrew macrumors 65816

    Joined:
    Jul 17, 2010
    #1
    1st, yes I know there are other threads on this, but I wanted to make sure what I had to say was seen.

    Since I upgraded to 4.1 my home button has been kinda funky. Sometimes, it will multitask on a single click. Other times, it goes home after a double click. And just now, I hit the home button (really pushed it, not kinda pushed it) and the phone would not wake up. I had to hit it again to wake it up. Just wondering if anyone else has experienced this SINCE 4.1. I know there were problems before 4.1, but I had never had it then.

    Ps. Check out my app! Unbeatable tic tac toe
     
  2. madKIR macrumors 6502

    Joined:
    Feb 2, 2010
    Location:
    NYC
    #2
    Well, it happened to me once, I guess. I hit the home button and the screen just blinked but nothing happened...and yeah, it was on 4.1
     
  3. myphone macrumors 6502

    myphone

    Joined:
    Jan 15, 2008
    Location:
    USA
    #3
    Mine doing the same thing, single click it goes to multitasking. I did a restore, it's still the same.
     
  4. solideliquid macrumors 6502

    solideliquid

    Joined:
    Aug 8, 2008
    #4
    Similar problems here on 4.1, I sometimes hit the Home button and nothing will happen (won't exit out of an app).
     
  5. danielroman macrumors member

    Joined:
    Apr 26, 2010
    Location:
    los angeles
    #5
    I've had this problem since 4.0.2, I noticed my home button is not completely flushed with the screen and dips in on one side and makes a nasty noise when I press on it every now and then. My wifes home Button is flushed and doesn't do the single click multi task thing and is smooth to push in. It's really annoying and has been doing it a lot lately.
     
  6. iEs macrumors regular

    iEs

    Joined:
    Jun 17, 2010
    Location:
    Safari
  7. SeVeN macrumors 6502a

    Joined:
    Aug 8, 2006
    Location:
    San Jose
    #7
    hmm. and i just thought my button was going out. didnt realize it started happening after 4.1, but it has
     
  8. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #8
    Wow thought it was just me, or the fact im jailbroken but hapening to me too.

    Are you guys JB or stock, to person who restored guess it doesnt matter.
     
  9. Antimatter macrumors regular

    Joined:
    Sep 16, 2007
    #9
    I have the same exact problem. It's really really annoying. 4.1 just made my phone worse :(
     
  10. applenew macrumors newbie

    Joined:
    Aug 29, 2009
    Location:
    Singapore
    #10
    I have the same thing happening to me too.. and it started with 4.01/02... I cannot quite remember. And my set is not jailbreak'en.

    And I am from Singapore.
     
  11. iPadztr macrumors 6502

    Joined:
    Apr 30, 2010
    Location:
    Pluto avenue
    #11
    Same here, made an appointment with geniuses This coming Friday and see what they can do. It's really annoying.
     
  12. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #12
    Nice, if you can update the thread and let us know how it turns out.....
     
  13. frikfrak macrumors regular

    Joined:
    Sep 17, 2007
    #13
    Mine does it too. Did it with 4.0 as well. Very annoying. Haven't made genius bar appt because the problem is intermittent; can't reliably reproduce it.
     
  14. nfrs2000 macrumors member

    nfrs2000

    Joined:
    Jan 30, 2009
    #14
    Same here! Sux! Is it a software issue? I thought my button was bad???
     
  15. billyjoegibsonx macrumors 6502

    Joined:
    Sep 10, 2008
    #15
    my home button does my head in!

    one click takes me to multitasking, u need to press the button in a certain place to get it to do anything. sometimes if i press it like 5 times it wont do anything! so frustrating lol.
     
  16. theITGuy macrumors 6502a

    theITGuy

    Joined:
    Feb 12, 2009
    Location:
    chasing the ghost in the machine
    #16
    Mine does this occasionally...I also have a 'sticky' temperamental power button that requires sometimes 2-3 presses to lock the phone...:mad:

    -J.-
     
  17. danielroman macrumors member

    Joined:
    Apr 26, 2010
    Location:
    los angeles
    #17
    did you get your phone replaced?
     
  18. iPadztr macrumors 6502

    Joined:
    Apr 30, 2010
    Location:
    Pluto avenue
    #18
    Update: Yes I did get a replacement Week 35. Told them about the button being sticky at times and unresponsive. The guy checked the headphone jack to make sure the sensor was not messed up.

    KEY NOTE: this is not the only issue I had when I went there to get a replacement. My phone was vibrating continuously till I hold the power and restart the phone. Happens a few times. I made my arguement as my main reason I was there was the home button was unresponsive and my secondary issues was the vibration of the phone unintentionally

    The replacement is working fine now and it came with 4.0.2 firmware which I updated to 4.1 now.

    Good luck guys.
     
  19. ATC macrumors 6502a

    Joined:
    Apr 25, 2008
    Location:
    Canada
    #19
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    I also thought it was just my phone. I don't recall mine doing this till the 4.0.2 update and it's still happening now (4.1). It's annoying but at least it's not happening all the time, seems intermittent.
     
  20. Irish Rose macrumors 65816

    Joined:
    May 29, 2010
    #20
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    Not having any problems at all so far. And I've been running 4.1 since it came out.
     
  21. Mlangart macrumors newbie

    Joined:
    Oct 2, 2010
    #21
    Mine does multitask on a single click sometimes like 2-3 times a day . I'm on fw4.1 and I hope it's not a hardware problem. Very annoying T T
     
  22. madKIR macrumors 6502

    Joined:
    Feb 2, 2010
    Location:
    NYC
    #22
    I'm sorry to say that, but I do believe it's a hardware issue! I got my iPhone replaced for that. I checked a lot of iPhone 4s and some of them happen to have imperfect home buttons. On the contrary, my new replacement has a perfect home button that never malfunctions. I'm on 4.1: so far so good.

    I think those, who have this issue from time to time, will be experiencing it even more later. In the beginning my previous phone was just fine, but then bit by bit the button was getting worse and worse right to the point that I had to press it too firmly in order to make it work. I had the same issues described by other people here: sometimes one click was opening the multitasking bar, etc. As I said above, now I don't have it at all with the new replacement, which makes me believe there are some affected phones with some faulty buttons with different degrees of unresponsiveness and malfunctioning.
     
  23. ATC macrumors 6502a

    Joined:
    Apr 25, 2008
    Location:
    Canada
    #23
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    ^^^
    Yep, I'm starting to think this is a hardware issue as well. Not only did mine get worse over time (which is probably why I thought it happened with the arrival if 4.0.2), but I'm now noticing that if I consistently press down hard it always registers a single tap. I only get intermittent double-tap mis-registration when the button is pressed lightly.
     
  24. adztaylor macrumors 68000

    Joined:
    Aug 20, 2009
    Location:
    Preston, UK
  25. BUFFBOY macrumors regular

    Joined:
    Aug 23, 2010
    Location:
    Sydney

Share This Page