Terrible graphics performance on 2.2 MBP

Discussion in 'Mac and PC Games' started by Erasmus, Dec 19, 2008.

  1. Erasmus macrumors 68030

    Erasmus

    Joined:
    Jun 22, 2006
    Location:
    Hiding from Omnius in Australia
    #1
    Hi Guys!

    I need help. I'm sick of this problem, I keep trying different things over and over to try and fix it, but it refuses to change. I simply get pretty shockingly poor performance in any game in XP using Boot Camp. Everything seems to work fine in OSX, although the only game I play in OSX is Freespace 2, which continues to work fine with graphics on highest.

    For example, in XP, I can't really play Spore at anything but all low settings, if I want to keep the 1440x900 native res. Same with Command and Conquer 3. Oblivion is impossible to play.

    So far, I have tried doing a clean install of XP (more than once) which does nothing. I have tried using new graphics drivers from laptopvideo2go, tried 180.48 drivers just today, again, did nothing. Turning off powermizer does nothing, neither does turning off PhysX.

    Now, on it's own, I would think that a nuke in CNC3 (on medium at native res) dropping the framerate to 3-4 would mean that my graphics card probably has a problem, seeing as it is affected by the nvidia bit. However, I still get over 25,500 in GioFX OpenMark.

    So, can anyone help me solve my problem? I remember a time, a long time ago when I didn't have these problems, and they were good. I want them back.
     
  2. Erasmus thread starter macrumors 68030

    Erasmus

    Joined:
    Jun 22, 2006
    Location:
    Hiding from Omnius in Australia
    #2
    I tried downloading nTune from the nvidia site, to see what it said about my graphics card. I suspected that the GPU might be heavily underclocked in XP, because I'm running out of things to check.

    nTune says the core clock is 375MHz, and the memory clock is 502MHz. I had a look at barefeats, when they did a gaming analysis of the Santa Rosa MBP a while ago. These said the clock speeds should be 470MHz and 635MHz, which is still lower than the 475/700 recommended by nvidia.

    Can anyone else confirm that my GPU is clocked lower than normal, by seeing what nTune says? Anyone with a 2.2GHz SR MBP would be of great help here. I don't want to void warranty, so if these are indeed too low, can I bump them back up to the 470/635 from barefeats?

    Also, if these are too low, I don't know how they got that way. I used to have nTune on my computer, but I never actually used it to change GPU clock speeds.
     
  3. macadmiral macrumors member

    Joined:
    Nov 30, 2008
    #3
    perhaps your card is getting shot? have you taken it to an apple store?
     
  4. Erasmus thread starter macrumors 68030

    Erasmus

    Joined:
    Jun 22, 2006
    Location:
    Hiding from Omnius in Australia
    #4
    No, I have not taken it to an Apple store. Graphics performance in OSX is excellent. Surely if the card was damaged, it wouldn't fix itself whenever it was being run under OSX? Unless it's an evil ploy by Steve Jobs to stop us using XP.

    And if it runs fine under OSX, I figure 1) it can't be damaged 2) Apple probably isn't going to care.

    Despite nTune giving low clock speeds, the nTune monitor thingo gives numbers that are very close to the barefeats clocks. So I figure it's not an over-underclocked GPU. However, nTune also reports that everything else (except the CPU, which has a good ~2200MHz) is operating at between 10 and 30 MHz. Stuff like main memory, front side bus, etc. Now I'm assuming that either nTune isn't reading these right, or that there is some hidden multiplier, but can anyone try it?

    Please help me reclaim my graphics!!!
     
  5. cathyy macrumors 6502a

    Joined:
    Apr 12, 2008
    #5
    Hmm that's really strange. 375/502 for the clock is normal though. It will automaticly go up to 470/635 if it's under heavier load. It's the same on my MBP.

    I'm not really sure how to help you except to advise you to try using the 179 drivers straight from Nvidias website. I'm highly skeptical that this would fix the problem though.

    You could try posting your problem at http://forum.notebookreview.com. They could probably help you out better.
     
  6. Erasmus thread starter macrumors 68030

    Erasmus

    Joined:
    Jun 22, 2006
    Location:
    Hiding from Omnius in Australia
    #6
    Well, I think I've found the problem. My PCI lane width to the graphics card is not running at x16, as it should. In fact, most of the time, it's only at x1. Although, right now, it says x8. This is happening in both OSX and XP, so it is a hardware problem. I don't know what I'm going to do about it yet, I guess I'll have to send it in and get it fixed. Lucky I did post on notebookreview, because if I didn't, and another guy wasn't having the exact same problem at that exact time, I probably wouldn't ever have found the problem!
     
  7. dwlnetnl macrumors newbie

    Joined:
    Jun 9, 2006
    #7
    In FS2_Open you can try to play with the command line option '-no_glsl'. This disables the OpenGL Shader Language. Which is buggy, only on OS X.
     
  8. katorga macrumors regular

    Joined:
    Oct 28, 2006
    #8
    I'm not sure that is a problem. I believe the laptop parts will dynamically power down PCI lanes to save power. You want to run the test while a game is running to verify.
     
  9. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #9
    Get latest official Nvidia drivers
    Update windows

    Perhaps your windows partition don't have any free space? Or it needs defrag.
    Many multiplayer online games download maps and extra content and they can take up a lot of space.
     
  10. Huntn macrumors G5

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #10
    Hopefully I did not miss it, but how much RAM do you have? 2GB or more is a must. I've got 4GB in my MBP and it plays Crysis, the most demanding game out there at around 15-25 fps. See my sig.
     

Share This Page