TextEdit opens too many files.

Discussion in 'Community Discussion' started by jamesadrian, Jul 9, 2013.

  1. jamesadrian, Jul 9, 2013
    Last edited: Jul 9, 2013

    jamesadrian macrumors member

    Joined:
    Aug 18, 2010
    Location:
    Rochester, NY 14626
    #1
    Ever since I upgraded to OS X 10.7.5 whenever I open TextEdit it opens a lot of files and I need to close all but the one I want. Is there a fix for this?

    Thank you for your help.

    James Adrian
     
  2. Dalton63841 macrumors 65816

    Dalton63841

    Joined:
    Nov 27, 2010
    Location:
    SEMO, USA
    #2
    Open terminal and type:

    Code:
    rm -r /.DocumentRevisions-V100
    ***NOTE: Only do this if you are like the other 95% of the population who never actually uses the "Versions" feature in OS X.
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #3
    1. Hold down OPTION modifier key.
    2. Click the RED circle to close a window, press cmd-W while still holding down OPTION.
    3. Observe all windows close.
    4. Choose the one file you want reopened from TextEdit's File > Open recent menu item.
     
  4. jamesadrian, Jul 9, 2013
    Last edited by a moderator: Jul 9, 2013

    jamesadrian thread starter macrumors member

    Joined:
    Aug 18, 2010
    Location:
    Rochester, NY 14626
    #4
    Dalton63841,

    Thank you for this information.

    I neglected to mention that pictures do the same thing in Preview. Will this command cure that as well?

    Please tell me about the Versions feature or where I should read about it.

    Thank you for your help.

    James Adrian
     
  5. Dalton63841 macrumors 65816

    Dalton63841

    Joined:
    Nov 27, 2010
    Location:
    SEMO, USA
    #5
    Yes it's the same for Preview, and I think Quicktime, and probably others, but they are the big offenders where it can be a problem. Basically Versions saves a copy of every file opened in certain apps, along with a "version" of those files for every change that has been made to them.

    http://www.macworld.com/article/1165518/versions_and_auto_save_explained.html

    Note my fix above won't prevent it from reoccurring later. It just clears out the Versions saved so far. Google "disable versions and autosave mac".
     
  6. jamesadrian thread starter macrumors member

    Joined:
    Aug 18, 2010
    Location:
    Rochester, NY 14626
    #6
    TextEdit opens too many files.

    Thank you all for your help.

    The programs are working the way I want them to.

    James Adrian
     
  7. Huntn macrumors G5

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #7
    This did not happen to me with Text Edit. What causes it?
     
  8. Astroboy907 macrumors 65816

    Astroboy907

    Joined:
    May 6, 2012
    Location:
    Spaceball One
    #8
    I believe it is partly caused by Apples new "versions" feature, which auto saves documents every hour or something. Or just something to do with 10.7 on.

    TBH I hate how every app opens files I am way done and over with. Like in preview once I open it it feels the need to re-open pretty much everything in my recently opened list.

    Anyways, I'm using that command. I didn't actually know you could turn it off. You've saved me possibly years worth of closing stupid windows.
     
  9. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #9
    Try cmd-option-Q instead of cmd-Q.

    1. Click once on the Preview menu in Preview.app.
    2. Press the OPTION modifier key.
    3. What is the exact wording of the last menu-item?


    To change the "remember windows" feature for all apps, on a per-user basis, go to:
    System Preferences > General
    then find the checkbox "Close windows when quitting an application". If it's unchecked, check it. Now the default Quit action will be "quit and forget windows" instead of "quit and remember all windows". You can still get the opposite action using cmd-option-Q.
     

Share This Page