This item is temporarily unavailable when updating apps

raehogan

macrumors newbie
Original poster
Jun 9, 2017
3
0
Hello, I hope you can help me..

I haven't been able to update any apps for about 10 days now - I get an error saying "This item is temporarily unavailable. Please try again later."

It's a MBPro Sierra v10.12.5

Thank you!
 

RMo

macrumors 65816
Aug 7, 2007
1,212
207
Iowa, USA
Happens to me a lot and there doesn't seem to be any good reason. If I'm on Ethernet, switching to Wi-Fi sometimes mysteriously helps, or vice versa. I've seen threads about this on the MR forums and other places for years now. Quitting iTunes and/or rebooting may also help; it will often also just work if you try again later. I'm pretty sure it's more of an iTunes client problem than a server problem (because I'm pretty sure Apple knows how to create reliable server experiences better than that--note my lack of confidence on the iTunes client side :) ). If I'm desperate for the update, doing it on-device almost always works. If anyone has better ideas, I'm open to them as well.
 

raehogan

macrumors newbie
Original poster
Jun 9, 2017
3
0
Hi RMo, thank you for your response :)
I still haven't been able to update any of my apps on the App Store. I've tried rebooting and signing in and out but it's not coming back. I tried to get in touch with Apple support but it looks like my assistance has run out so I'll wait for the next pay check and buy another year of it. It's a weird problem though, seems to have come out of nowhere!!

Thanks again.
 

HDFan

macrumors 65816
Jun 30, 2007
1,498
363
I received this message

This item is temporarily unavailable.
when I was trying to reinstall my OS. Called Apple support. The problem was that the original OS was installed under a different AppleID. When I logged into the ID which had "purchased" the original software the message went away and I was able to install without any problem.
 
  • Like
Reactions: Zippietwo

deadmetal

macrumors newbie
Aug 4, 2017
1
8
Hello, I hope you can help me..

I haven't been able to update any apps for about 10 days now - I get an error saying "This item is temporarily unavailable. Please try again later."

It's a MBPro Sierra v10.12.5

Thank you!
This is what worked for me. Open App Store, click on the 'Purchased' tab, it said that you must be signed in to view purchases, sign in using your Apple ID, then go back to the 'Updates' page and try again. Looks like App Store didn't think I was signed in. Hope this helps.
 

raehogan

macrumors newbie
Original poster
Jun 9, 2017
3
0
This is what worked for me. Open App Store, click on the 'Purchased' tab, it said that you must be signed in to view purchases, sign in using your Apple ID, then go back to the 'Updates' page and try again. Looks like App Store didn't think I was signed in. Hope this helps.
Yes! I eventually figured it out but this is exactly what happened to me. Once I signed in again everything was back to normal. Thank you all very much for your replies!!
 

ptsmonteiro

macrumors newbie
Dec 20, 2017
1
0
This is what worked for me. Open App Store, click on the 'Purchased' tab, it said that you must be signed in to view purchases, sign in using your Apple ID, then go back to the 'Updates' page and try again. Looks like App Store didn't think I was signed in. Hope this helps.
This worked for me (MBA early 2015 on High Sierra)! Thanks!
 

andrianlee

macrumors newbie
Aug 28, 2018
1
0
This worked for me (MBA early 2015 on High Sierra)! Thanks!
And this is what worked for me. In the App Store, scroll to the bottom right and click on the country flag to change the region to the correct region of your Apple ID. I am from Cyprus, and the region was set to US for some reason. After switching regions i could update my apps with no errors.
 

NoelG

macrumors newbie
Apr 4, 2019
1
0
This is what worked for me. Open App Store, click on the 'Purchased' tab, it said that you must be signed in to view purchases, sign in using your Apple ID, then go back to the 'Updates' page and try again. Looks like App Store didn't think I was signed in. Hope this helps.
Thanks this put me on the right track and solved it. In My case I was in the 'wrong country store' and once I changed back to my usual country which matched my payment method all was well and updates resumed normal operation. I'm running MacOS Mojave so the layout or the app store has changed, click on your user name Lower Left corner and it will bring you to 'purchases page', then click 'View Information' to view your account wherein it warned my I was in the wrong country store and it had moved me back automatically. After that updates worked again.