TiBook partially works

Discussion in 'PowerPC Macs' started by AL1630, Nov 3, 2017.

Tags:
  1. AL1630 macrumors 6502

    AL1630

    Joined:
    Apr 24, 2016
    Location:
    Idaho, USA
    #1
    A few months ago, I got some beat up PowerBook DVIs cheap, and one has a dead hard drive. When I first got it, it would load the screen with the blinking folder, but now the screen doesn't load, but the fans spin up and the light on the caps lock key works. What could be causing this?
     
  2. weckart macrumors 601

    Joined:
    Nov 7, 2004
    #2
    Sounds like a failing logic board to me. I have a PB with the same symptoms. Suspected fried chip(s) onboard.
     
  3. AL1630 thread starter macrumors 6502

    AL1630

    Joined:
    Apr 24, 2016
    Location:
    Idaho, USA
    #3
    It would suck if that's the problem, but I guess I could use it for parts.
     
  4. benwild_33 macrumors regular

    Joined:
    Oct 15, 2016
    #4
    Have you unplugged the PRAM battery? I hear that sometimes helps with TiBooks that arent booting.
     
  5. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Central US
    #5
    Had those symptoms on my indigo iBook a hundred years ago, and it turned out to be a failed logic board. Same deal, no sign of life but num lock & caps lock lights (Clamshell had no fans). Same era system, so I wouldn't be shocked if the board was bad.
     
  6. AL1630 thread starter macrumors 6502

    AL1630

    Joined:
    Apr 24, 2016
    Location:
    Idaho, USA
    #6
    I've tried booting it without the PRAM battery, but the same thing happened. Weird that the logic board would fail though, it's just been sitting on a shelf.
     

Share This Page

5 November 3, 2017