Time Machine erasing external USB Drives

Discussion in 'OS X Mavericks (10.9)' started by Jamesconnery, Feb 27, 2017.

  1. Jamesconnery macrumors newbie

    Jamesconnery

    Joined:
    Mar 20, 2016
    Location:
    USA
    #1
    Hopefully someone with better knowledge than I can tell me how to deactivate/delete time machine via terminal. With out any reason or warning time machine immediately formats any external hard drive attached to the system. I never used time machine ever and have always had it turned off. So far it has erased several drives at least a half a dozen times . In frustration I deleted the time machine app and preference pane however Time Machine still rears it's ugly head and ask if this drive should be used, when I click No, It Still formats the drive and I loose everything in it. Any helpful advice will be greatly appreciated.
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    If you need to disable Time Machine in the terminal:
    Code:
    sudo tmutil disable
    type in the command, press enter. The terminal will ask for your password, so type in your password, then press enter again to run the command. (the terminal will NOT show your password as you type it in, do not be concerned about that)

    If that command completes without error, then at least part of the time machine process still exists on your Mac.

    If you get an error (cannot disable time machine, or something like that), then you have succeeded in borking your OS X installation.
    The fix for that will be to reinstall OS X. You can easily do that by booting to your recovery system - Restart, holding Command + r
    Choose Reinstall OS X from the menu.
    You won't lose any of your own documents, files, music/pictures or apps that you have installed. The reinstall just reloads the system, puts anything missing back in place (such as your Time Machine app). Your goal in a reinstall would be to have a working Time Machine, along with all its processes properly installed.
    THEN, the disable command that I listed above, should work.
     

Share This Page