Time Machine Randomly gets stuck on backups?

Discussion in 'macOS' started by todd2000, Nov 1, 2007.

  1. todd2000 macrumors 68000

    Joined:
    Nov 14, 2005
    Location:
    Danville, VA
    #1
    I set up Time Machine the yesterday, it compleated it's initial backup fine, and performed about 10 or so hourly backups, then randomly on one of it's hourly backups it got stuck. It never actually started the backup. The preferences said it was backing up, but the progress bar wasn't moving, and there was no activity on the drive. I stopped the "backup", and from then on I could not get it to do another backup.

    So last night I reformatted the external and decided to let TM start over. Once again it finished the initial backup fine, and I went to bed. While I was in bed it finished 3 more hourly backups, and I woke up this morning to find it stuck again, trying to do it's 2:05AM backup. The computer was awake all night, so it should have no problems. The preferences say it is backing up, but never makes any progress, and there is no drive activity.

    Here is the relavent errors from my System log:

    Nov 1 02:05:50 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: Backup requested by automatic scheduler
    Nov 1 02:05:50 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: Starting standard backup
    Nov 1 02:05:57 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: Backing up to: /Volumes/Backup/Backups.backupdb
    Nov 1 02:05:57 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: Ownership is disabled on the backup destination volume. Enabling.
    Nov 1 02:05:57 todd-sullivans-imac KernelEventAgent[35]: tid 00000000 received unknown event (256)
    Nov 1 02:05:59 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: Event store UUIDs don't match for volume  Macintosh HD
    Nov 1 02:05:59 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: Node requires deep traversal:/ reason:kFSEDBEventFlagMustScanSubDirs|kFSEDBEventFlagReasonEventDBUntrustable|

    Nov 1 02:09:45 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: No pre-backup thinning needed: 14.57 GB requested (including padding), 132.30 GB available
    Nov 1 02:09:46 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: MDBackupBegin() returned result (909) > 0, waiting
    Nov 1 02:10:16 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: MDBackupBegin() returned result (906) > 0, waiting
    Nov 1 02:10:46 todd-sullivans-imac /System/Library/CoreServices/backupd[304]: MDBackupBegin() returned result (906) > 0, waiting

    I bolded the entries that I assume are the problem, but I don't know what it could be. Why does it randomly get stuck on hourly backups. BTW The "waiting" is just repeating over and over etc..... Help! Or it's back to CCC for me. Thanks

    EDIT: Tried it a 3rd time, and this time it managed to do 25 hourly backups before getting stuck. does anyone have a clue here, I'd like to get this working. Every time it stops working I have to format the drive and start over to get it to backup again.
     
  2. todd2000 thread starter macrumors 68000

    Joined:
    Nov 14, 2005
    Location:
    Danville, VA
  3. soheilhas macrumors newbie

    Joined:
    Nov 5, 2007
    #3
    Same as you

    I have the same problem. I could not fix it til now. Any clue yet?
     
  4. jaz419 macrumors newbie

    Joined:
    Jun 6, 2007
    #4
    im having the same problem...for me it started after i installed the new itunes and quicktime updates.

    did this happen for you guys too?
     
  5. 50548 Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #5
    Yes, it was fine until before the updates...really.
     
  6. tat3oct31 macrumors newbie

    Joined:
    Nov 6, 2007
    #6
    Same Issue, After iTunes/Quicktime Update

    Here is the info from system.log:
    Nov 6 16:30:21 Macintosh /System/Library/CoreServices/backupd[144]: Backup requested by user
    Nov 6 16:30:21 Macintosh /System/Library/CoreServices/backupd[144]: Starting standard backup
    Nov 6 16:30:21 Macintosh /System/Library/CoreServices/backupd[144]: Backing up to: /Volumes/MacOSX External/Backups.backupdb
    Nov 6 16:30:21 Macintosh /System/Library/CoreServices/backupd[144]: Event store UUIDs don't match for volume Macintosh HD
    Nov 6 16:30:22 Macintosh /System/Library/CoreServices/backupd[144]: Node requires deep traversal:/ reason:kFSEDBEventFlagMustScanSubDirs|kFSEDBEventFlagReasonEventDBUntrustable|


    My hard drive is suffering from the click of death, so when I went to back up earlier today I found out that Time Machine didn't work. I haven't been able to create a back up successfully since I updated iTunes/Quicktime either.

    I have repaired permissions and repaired the iBook's HD, which fixed the Click of Death, but still no Time Machine. I really need to backup my files before my hard drive fails. Time Machine has been running for over an hour now. The last backup I have was on Oct 30, last time the Time Machine drive was plugged in. :(
     
  7. tat3oct31 macrumors newbie

    Joined:
    Nov 6, 2007
    #7
    It works.

    Ok after running for about an hour and 1/2 Time Machine finally finished its back up. To test if the problem was over i ran back up again.
    Here are the results:
    Nov 6 17:08:53 Macintosh /System/Library/CoreServices/backupd[267]: Backup requested by automatic scheduler
    Nov 6 17:08:53 Macintosh /System/Library/CoreServices/backupd[267]: Starting standard backup
    Nov 6 17:08:59 Macintosh /System/Library/CoreServices/backupd[267]: Backing up to: /Volumes/MacOSX External/Backups.backupdb
    Nov 6 17:09:01 Macintosh /System/Library/CoreServices/backupd[267]: No pre-backup thinning needed: 100.0 MB requested (including padding), 244.84 GB available
    Nov 6 17:09:08 Macintosh /System/Library/CoreServices/backupd[267]: Copied 499 files (254 KB) from volume Macintosh HD.
    Nov 6 17:09:09 Macintosh /System/Library/CoreServices/backupd[267]: Starting post-backup thinning
    Nov 6 17:09:22 Macintosh /System/Library/CoreServices/backupd[267]: Deleted backup /Volumes/MacOSX External/Backups.backupdb/iBook G4/2007-10-30-214509: 244.85 GB now available
    Nov 6 17:09:22 Macintosh /System/Library/CoreServices/backupd[267]: Post-back up thinning complete: 1 expired backups removed
    Nov 6 17:09:22 Macintosh /System/Library/CoreServices/backupd[267]: Backup completed successfully.
     
  8. stoney008 macrumors newbie

    Joined:
    May 14, 2009
    #8
    Any solutions?

    Did you ever find a solution. I am having the same problem. Tried to Google it but find no real answers.
     
  9. todd2000 thread starter macrumors 68000

    Joined:
    Nov 14, 2005
    Location:
    Danville, VA
    #9
    Way to resurrect my 2 year old thread :) My Time Machine problems were fixed with the 10.5.1 update.
     
  10. yashrg macrumors regular

    yashrg

    Joined:
    Feb 21, 2008
    #10
    hmm.. I installed the combo 10.5.7 update but problem still persists. We all hope to learn from our ancestor's experiences.. so please share with us any troubleshooting steps you might have taken.:D
     
  11. knightyknight macrumors newbie

    Joined:
    Jun 12, 2009
    #11
    yep i've got this problem too.

    takes ages to prepare then when it does eventually start backing up it gets stuck at about 100mb of 12gb...29th may was my last successful backup.

    anyone got any ideas?
     
  12. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #12
    One cause for that was a hard drive that was on its way to hard drive heaven :eek: If there are defective bits on your hard drive that the Mac cannot read, it will always get stuck on these bits and never be able to finish the backup. If you get the "rainbow cursor of death" a lot more often than you used to, if your Mac "hangs" randomly, then it may be time to get a new hard drive.

    At least use Disk Utility to check the hard drive.
     
  13. knightyknight macrumors newbie

    Joined:
    Jun 12, 2009
    #13
    hmmmm not sure its the hard drive. my mac never crashes and doesnt hang. Disk utility says all ok too.

    any other ideas gratefully received...
     
  14. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #14
    I've spent some quality hours on the phone with Apple level 2 support for Time Machine issues when backing up to a Time Capsule. The good news is 10.5.8 is coming with some networking and sync related fixes. The bad news is that these fixes were so long in coming. TM finds all kinds of excuses to foul up the destination volume. Mount your backup location, then drag the sparsebundle to disk utility. If it seems like disk utility will never finish checking the disk image, you probably have a corrupted backup destination volume and you can choose to blow it away and start over if you like. I have already done this twice. I care less about beaming back to July 2008 than I do about restoring from yesterday or last week. For those who think TM will get you back to the day you bought your Time Capsule, buyer beware! Chances are file corruption in your backup destination will eat your older files sooner or later, especially if you are backing up to a network drive even if it is a Time Capsule.

    When Time Machine is perpetually spinning, perpetually preparing or perpetually finishing backups, it sometimes points to "sparsebundle" corruption on the destination disk. All I can say is I hope Apple stamps out this bug once and for all as there are many of these 2 year old threads about TM working slowly, especially with Time Capsule and I bet a lot of these issues would be solved by some operating system hooks to protect the integrity of Time Machine's destination volume.

    For instance, if your Mac is about to sleep, the OS should tell TM about it so it closes files properly! :rolleyes: If a new backup is starting and there is an "inprogress" file on the destination, delete it before proceeding. If the connection is wireless and the connection is dropped, don't retry for 90 minutes. Stop backing up and try again at the next scheduled time. By all means, don't sit there spinning 24x7 starting new backups before the old backups are finished. And don't close the system log entry until the icon has stopped spinning. I wonder if Apple engineering reads these threads? Oh well. The bottom line is that many of these anomalies with Time Machine are related to less than optimal software design on Apple's part. We are talking backup software here, not iTunes or GarageBand. I will be more than merely annoyed if TM/TC goes kuckoo and takes my tax records with it! :mad:

    On my end, I've invested in a new Airport Extreme with separate N and G radios so any machine backing up over N doesn't get throttled back to G because somebody decided to print to one of our older wireless printers. I also like the idea that my backup device won't be sitting raw on the internet any more. I plan to let the new AE handle wifi and routing and let the TC merely act as a network drive and maybe, just maybe I'll let it extend the network managed by my new AE.
     
  15. Anthony Peratt macrumors newbie

    Joined:
    Nov 24, 2009
    Location:
    Los Alamos, NM
    #15
    No more time for Time Machine

    By way of introduction, I first purchased a dozen Mac's for my group in 1984 and since have purchased hundreds more. I currently use an up-to-date desktop and MacBook operating with Leopard and Snow Leopard. My other machine is Los Alamos' Roadrunner computer. But the issue is Time Machine, the sorriest product I have seen from Apple. Time Machine is appropriately named: from the discussion above and our experiences, it is a 'machine' that desecrates your time. Like you, I have zero extra time. The fix? Download AppDelete (free or $8) and remove TM. Erase your backup disk and manually copy your files (it is well worth the cost to have firewire800). Periodically use File Sychronization, the juxtaposition blue arrows app, to keep your disks up to date. You'll save time and diminish frustration. Cheers.
     

Share This Page