Time Machine stuck on Preparing

Discussion in 'macOS' started by snverhallen, Feb 11, 2008.

  1. snverhallen macrumors 6502a

    Joined:
    Oct 17, 2007
    #1
    When I backup Time Machine it's just stuck on Preparing. I've tried stopping it then starting again. I've also tried dismounting the drive then remounting then backing up but still no luck.

    snverhallen
     
  2. jameskohn macrumors 6502

    Joined:
    Sep 11, 2006
    Location:
    Connecticut
    #2
    Same deal... been "preparing" for quite some time now.
     
  3. gamera~ macrumors member

    Joined:
    Apr 28, 2005
    Location:
    Boston MA
    #3
    Open up Console.app and under "LOG FILES" to the left, click on "system.log" When you start a backup, some output should appear. If it mentions a "deep traversal" that means that it needs to re-index everything (or something like that) so that your next backup will take a while: it will stick for a time on "Preparing..." (could be an hour or more), but after that subsequent backups will be quick.

    This happens after your computer freezes, and apparently after installing 10.5.2.

    ~Michael
     
  4. snverhallen thread starter macrumors 6502a

    Joined:
    Oct 17, 2007
    #4
    Mine is backing up now. I believe the reason it's so slow after updating to 10.5.2 is because it's checking the whole drive to make sure nothing happened to it while updating. That is why you can hear the drive spinning while it is Preparing. I would just keep on leaving it Prepare, eventually it should start, I'm guessing the larger the drive the longer it will take to Prepare. I had 350 GB HD and it took around 20 minutes.

    snverhallen

    EDIT: Here is my console reading (including my Cancel's haha :) -

    traversal:/ reason:kFSEDBEventFlagMustScanSubDirs|kFSEDBEventFlagReasonForceDeepBackup|
    Feb 11 17:51:26 S01060017f2c733ed /System/Library/CoreServices/backupd[260]: Backup canceled.
    Feb 11 17:52:04 S01060017f2c733ed Finder[157]: NSOpenGLAutoscaleBounds=NO
    Feb 11 17:52:23 S01060017f2c733ed /System/Library/CoreServices/backupd[260]: Backup requested by user
    Feb 11 17:52:23 S01060017f2c733ed /System/Library/CoreServices/backupd[260]: Starting standard backup
    Feb 11 17:52:23 S01060017f2c733ed /System/Library/CoreServices/backupd[260]: Backing up to: /Volumes/TM Backup/Backups.backupdb
    Feb 11 17:52:24 S01060017f2c733ed /System/Library/CoreServices/backupd[260]: Event store UUIDs don't match for volume: Macintosh HD
    Feb 11 17:52:24 S01060017f2c733ed /System/Library/CoreServices/backupd[260]: Forcing deep traversal on source: "Macintosh HD" (mount: '/' fsUUID: EA0E32F0-2A79-3701-9A0B-3E11CF169197 eventDBUUID: B5CEA73F-6653-41F4-B43B-185466F38C68), {1, 1, 0, 1}
    Feb 11 17:52:24 S01060017f2c733ed /System/Library/CoreServices/backupd[260]: Node requires deep traversal:/ reason:kFSEDBEventFlagMustScanSubDirs|kFSEDBEventFlagReasonForceDeepBackup|
     
  5. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #5
    It took quite a while preparing on my machine. Completed fine, though.

    The preparation is going to be long the first time after the update because of the large number of changed files.
     
  6. FF_productions macrumors 68030

    FF_productions

    Joined:
    Apr 16, 2005
    Location:
    Mt. Prospect, Illinois
    #6
    I got the same message, it froze up everything, couldn't even stream to Apple TV.

    I don't understand how time machine can be so buggy.

    They introduced the damn feature in August 2006 and still haven't made it as stable as it should be. It's a back-up utility for ****'s sake, how can I rely on it when it craps on my system?

    EDIT-I would have waited the 20 or so minutes to have it backup, but I was trying to show off apple TV to my parents, not impressive when it skips and stutters to a complete stop.
     
  7. kevinwiz macrumors regular

    Joined:
    Feb 1, 2007
    Location:
    socal
    #7
    yup mine says deep traversal. i'll wait then. time machine is great but it sucks at the same time with how unreliable it is.
     
  8. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #8
    Time Machine has been significantly changed. I was going through the same thing, my machine spent 20 minutes in "preparing" and as usual, i am patient, so i wait some more, and poof 1.4Gb is being written to external hard drive and done. And this is with relatively minor changes since my last backup. Maybe a couple documents more at most.

    Patience everyone.
     
  9. eliotw macrumors member

    Joined:
    Nov 16, 2006
    #9
    Yep...takes a bit the first time

    On my PM G4 (802.11g) the first post-10.5.2 TM backup ran for a little less than 2 hours and nearly 1 hour was the 'preparing' stage as it read through the old backups. It backed up about 1.5GB of data.

    So you may want to give TM plenty of time to do that 'deep traversal' before giving up on it...

    My TM disk is attached to my iMac across a wireless network.

    E
     
  10. Icewind macrumors regular

    Icewind

    Joined:
    May 23, 2006
    Location:
    Scotland
    #10
    Are you saying that you can use a standard FW or USB external HD attached to an iMac on your network as a TM drive... and it works?
     
  11. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #11
    I did a backup before and afterward. After the update it was preparing for at least 15 minutes and had to backup 1.3 GB of data.
     
  12. johnthegreen macrumors newbie

    Joined:
    Feb 10, 2008
    #12
    Preparing when I went to bed and preparing when I awoke

    I purchased my time capsule about a week ago. I have a 750 gb hd in my mac pro, occupied with about 260 gb of data. I installed following the directions and it took about 10 or so hours to do the initial backup. That was no big deal. I had found at one point a day or so later that time machine was preparing.
    It was bed time, so I left the computer on overnight to let it do its thing. I awoke to find it "preparing". I do not run any antivirus. I thought something must have been screwed up so I stopped it. It has continually went to this preparing stage and I have left it up for numerous hours (I no longer keep the computer on to let it do its thing when I go to bed) and it has never moved beyond that preparing stage. I am at my wits end.

    UpDate,
    I just checked and found after about 3 or 4 hours this time, it is no longer preparing. But there was an error message that the latest backup failed. I tried another backup and it is now preparing again, probably will a few more hours and then ultimately fail again.


    Next update:
    After not a very long time, it went to backing up 34,411 items 32 kb of 11.3mb. It has been stuck here for about an hour. I think I am getting closer to having this work properly, but am not certain what to do now.

    Update,
    Numerous backups have been attempted after these long preparations, every single one has failed though. This really stinks.
     
  13. johnthegreen macrumors newbie

    Joined:
    Feb 10, 2008
    #13
    time machine working flawlessly now

    I contacted Apple. They had me reset me delete everything on the hard drive and reset the time capsule. Time machine then once again created the initial backup (took about a day and a half) and it has been backing up on schedule ever since without fail.
     
  14. bananaquit macrumors member

    Joined:
    Jan 27, 2007
    Location:
    Montana
    #14
    Same "preparing" behavior here. I have about 44 GB backed up and after some very quick scheduled backups it starts a long stretch of "preparing." The icon spins but I hear nothing from the hard drive. I have waited over two hours for something to happen, and by that time assumed it was frozen. I will check the log as suggested, and if I just need more patience, then great. At this point I don't trust the system to work properly.
     
  15. bananaquit macrumors member

    Joined:
    Jan 27, 2007
    Location:
    Montana
    #15
    Okay, it's "preparing" and this is what the log repeats every five minutes:

    computer kernel[0]: IOSCSIPeripheralDeviceType00::setPowerState(0xb214000, 1 -> 4) timed out after 100133 ms

    Does this mean anything to anybody?
    Thanks.

    System Preferences freeze up as well.
     
  16. sidharth80 macrumors member

    Joined:
    Jan 30, 2008
    Location:
    Chicago,IL
    #16
    ok... this is a bit off topic.. but i dint know where else to post this query.
    I have a 500 GB TC. I attached a 120 GB WD external drive to it's USB port.
    But I dont see that drive in my finder window, though i can see it in the "Disks" section of the airport utility.

    Do I need to format that drive before I can use it with Time capsule?
    Any inputs will be highly appreciated.

    Thanks
     
  17. bananaquit macrumors member

    Joined:
    Jan 27, 2007
    Location:
    Montana
    #17
    Just an update on my time machine's incessant "preparing" problem. I unchecked "put the hard discs to sleep when possible" in the system preferences "Energy Saver." It seems like that may have been the fix since my time machine hasn't hung up since the change (about 24 hours). I hope it was that simple (and obvious I suppose to many of you savvy Mac people :rolleyes:).
     
  18. jzuena macrumors 6502a

    jzuena

    Joined:
    Feb 21, 2007
    Location:
    Lexington, MA, USA
    #18
    I've been chasing down a similar hang since January or February and finally noticed the same system log time out messages this morning. What are people's take on not allowing disks to be put to sleep? The work PowerBooks where I am went through a rash of disk failures a couple of years ago due to not checking that sleep option, so our IT people have recommended that our MacBook Pro's should all use this setting (we still run Tiger at work, so no Time Machine issues because of it). I made sure my home Mini also has this setting checked, and never gave it a second thought when upgrading to Leopard. Does disabling disk sleep put the disks at greater risk? Also, is there a way to just disable this on the Time Machine disk but let other disks sleep normally? I leave my Mini on 24/7 and would prefer if the boot disk and the internal disk still powered down when not in use even if the Time Machine disk stays spinning all the time.
     
  19. marclevoy macrumors newbie

    Joined:
    May 19, 2008
    #19
    Time machine no longer preparing forever

    I took banannaquit's suggestion, and set my disks to no longer sleep
    (in System Preferences/Energy). This seems to have fixed the problem.
    Since making that change a few days ago, I have no longer seen the problem,
    which I was experiencing nightly, of having Time Machine hang forever on
    "Preparing Backup". Thank you, banannaquit!

    By the way, double clicking on the disk's icon on the desktop while Time
    Machine was preparing the backup (but sleeping) didn't wake up the disk;
    it should have. This looks like a driver bug. My disk is a 1TB WD from Apple,
    cabled through Firewire 800 to my MacPro.

    -Marc Levoy
    Stanford University
     
  20. MD-Canberra macrumors newbie

    Joined:
    Aug 23, 2008
    #20
    Fixed "stuck on Preparing"

    My TM was also stuck and I unchecked the disk sleep preference, too. This fixed it, as it has for others.
     
  21. GR33NIE macrumors 6502

    Joined:
    Jul 9, 2008
    Location:
    UK
    #21
    Useful thread and post many thanks :D

    Mine's doing this right now and it's taking aaaaages!:(
     
  22. poppe macrumors 68020

    poppe

    Joined:
    Apr 29, 2006
    Location:
    Woodland Hills
    #22
    Hope the hard drive to sleep thing works for me... I just got some error that I have run out of room (800 gbs gone some how?); started with 300 full when I started the whole time machine thing.

    It told me it was going to delete the back up from Sept 2007. Ever since then mine has been preparing.......
     
  23. GR33NIE macrumors 6502

    Joined:
    Jul 9, 2008
    Location:
    UK
    #23
    Mine didnt fix in the end, I even left it on overnight...

    I started from scratch :)
     
  24. poppe macrumors 68020

    poppe

    Joined:
    Apr 29, 2006
    Location:
    Woodland Hills
    #24
    Really really weird. Mine ended up clearing up once I turned off the hard drive to sleep thing. I think this is a really sad flaw that needs to be updated because I don't want to have to switch between turning it on during normal use and turning it off at back up.

    Did you call Apple?
     
  25. khenleywrfr macrumors newbie

    Joined:
    Jun 16, 2008
    #25
    Mine is erroring still...

    Right now I am running a hard drive repair, which hopefully works or helps. (Running on my backup drive)

    When I run a backup I get the following in the console:
    Sep 26 15:27:36 PBG4 /System/Library/CoreServices/backupd[443]: Waiting for index to be ready (910 > 0)
    Sep 26 15:28:21 PBG4 ReportCrash[457]: Formulating crash report for process backupd[443]
    Sep 26 15:28:23 PBG4 [0x0-0xd00d].com.apple.finder[151]: Failed to send message to backup server: error = -2
    Sep 26 15:28:23 PBG4 [0x0-0xc00c].com.apple.systemuiserver[150]: Failed to send message to backup server: error = -2
    Sep 26 15:28:24 PBG4 com.apple.launchd[1] (com.apple.backupd[443]): Exited abnormally: Segmentation fault

    I may not be the smartest person in the world, but something tells me that isn't good. (No, I haven't called Apple yet)

    Thoughts?

    Thanks.

    Khenleywrfr
     

Share This Page