• Did you order new AirTags? We've opened a dedicated AirTags forum.

slattery69

macrumors regular
Original poster
Jun 16, 2009
187
8
Paid Shill
Since updating to 8.3 I'm having problems with touch id and the app store. Before the update when i purchased paid and free apps it asked for my touchid. since i updated and I've changed no settings its asking for my password.
Any ideas how to get it back to touchid. tried toggling the setting , re doing my fingerprints reset settings etc
 

Mabus51

Suspended
Aug 16, 2007
1,366
847
It always asks for the password after a reboot. Until you make the first purchase or tap on AppleID in the app/music store to verify your password it won't use TouchID.
 
Comment

nightstalkerz

macrumors 6502
May 9, 2013
271
12
It always asks for the password after a reboot. Until you make the first purchase or tap on AppleID in the app/music store to verify your password it won't use TouchID.

I've made multiple purchases after rebooting and it asks for my password every time.

I know I need to enter my password the first time after reboot.
 
Comment

gordon1234

macrumors 6502a
Jun 23, 2010
574
163
I've made multiple purchases after rebooting and it asks for my password every time.



I know I need to enter my password the first time after reboot.


Under Settings > Touch ID & Passcode, is iTunes & App Store selected? I know on my system, it automatically deselected after the update for some reason.

4f870f579ea2c5290cc715fc09509157.jpg
 
Comment

slattery69

macrumors regular
Original poster
Jun 16, 2009
187
8
Paid Shill
All thats done on mine, even tried to toggle it on and off and still always asks for password no matter what. Ive reset settings (not content) re done all the fingerprints still the same. Works for all third party apps

I've tried everything bar a setting up as a new phone which I'm trying to avoid
 
Comment

kmpoboy2

macrumors 6502
Jul 10, 2010
374
1
Alabama
Yeap, seeing this behavior too. Guess it's a bug with the new password settings for purchases.
 
Comment

Shanghaichica

macrumors G5
Apr 8, 2013
12,907
10,440
UK
I have this on my devices since the update and I'm not pleased. I'm in the UK and we don't have apple pay so using Touch ID to make purchases on my devices was the main highlight of the Touch ID.
 
Comment

TitanTiger

macrumors 6502
Jun 8, 2009
376
76
Also having this issue with iTunes Store payments. Doesn't even prompt me for TouchID even though all the settings are right.
 
Comment

Enjoylife1788

macrumors 6502a
Aug 22, 2011
800
109
I read in another forum that signing out and then signing back in helps. I have not installed 8.3 yet. Can somebody confirm if that works?
 
Comment

thanh.n

macrumors newbie
Mar 10, 2015
3
1
No, i got the same issue :/ and i logged out in itunes on phone and logged in again. device asking me always for passwort
 
Comment

f00f

macrumors 65816
Feb 18, 2009
1,109
54
New Yawk
For the record Touch ID doesn't work for purchases on my iPhone 6 which was installed clean (as a "new phone"). Likewise for my iPad Air 2. I never get prompted for a Touch ID when making purchases despite rebooting the devices, logging out/into my iTunes account and so on. This is clearly an annoying bug.
 
Comment

slattery69

macrumors regular
Original poster
Jun 16, 2009
187
8
Paid Shill
For the record Touch ID doesn't work for purchases on my iPhone 6 which was installed clean (as a "new phone"). Likewise for my iPad Air 2. I never get prompted for a Touch ID when making purchases despite rebooting the devices, logging out/into my iTunes account and so on. This is clearly an annoying bug.

Good to know in the sense that its not worth me doing a clean install. Annoying hope its fixed quick
 
Comment

Tom G.

macrumors 68020
Jun 16, 2009
2,300
1,284
Champaign/Urbana Illinois
I have this problem on my iPad Air2. All settings are correct, and I tried more than one purchase. All it does is as for password, it never even asks for the Touch ID.

I have not yet updated my iPhone 6.
 
Comment

bchreng

macrumors 65816
Jul 26, 2005
1,054
347
I'm having the same issue with my 6+. The settings are what hey should be and I have made several free purchases since updating and rebooting. It asks for my password every single time. I hope Apple fixes this soon.
 
Comment

cwosigns

macrumors 68000
Jul 8, 2008
1,906
1,848
Columbus,OH
Someone in another thread said he was still on the last 8.3 beta and it was happening to him after the update went live, when it had worked fine before 8.3 was released to the masses. He speculates it may be server side. I don't know if the App Store pings your phone which prompts Touch ID, and maybe that is broken?

Odd that it's still happening on the beta for him.
 
Comment

hlevolve

macrumors regular
Aug 19, 2014
111
341
Anybody having other bugs??? I'm seeing a number of things, one glaring one is that the status bar (Cellular status, time, and battery %) disappears when going into the call history and voice mail screen...

I'm also experiencing the app store TouchID bug which is annoying...
 
Comment

BeeGood

macrumors 68000
Sep 15, 2013
1,827
6,075
Lot 23E. Somewhere in Georgia.
I read in another forum that signing out and then signing back in helps. I have not installed 8.3 yet. Can somebody confirm if that works?

I just tried it and that didn't work for me.

I did notice under Settings>TouchID that "iTunes and AppStore" was turned off, but turning it back on again didn't help. Purchases in the App Store only asks for a password and doesn't give you the option to use Touch ID.

All my third party apps that use Touch ID work fine, as does unlocking the phone.
 
Comment

Morac

macrumors 65816
Dec 30, 2009
1,396
262
Is the bug on a 5S?

It's broken on my 5S and my iPad Air 2.

What's odd is the first time I made a "purchase" in the app store, I got prompted if I wanted to enter my password "always" or once every 15 minutes. I chose always and it said I could change this in settings, which you can't unless you disable Touch ID.

I say it's a bug. It seems like the iTunes & App Store "Password settings" are overriding the Touch ID settings. If I turned off Touch ID for iTunes, then change the settings to not prompt for passwords for free downloads and then turn Touch ID back on, I won't get prompted for free downloads. I still get prompted every time for paid downloads though, so it's like it's completely ignoring the Touch ID setting for iTunes and App Store.

----------

Anybody having other bugs??? I'm seeing a number of things, one glaring one is that the status bar (Cellular status, time, and battery %) disappears when going into the call history and voice mail screen...

I'm also experiencing the app store TouchID bug which is annoying...

Only other bug I've seen so far is that the free space and usage reported by iTunes is completely inaccurate. It's off by several GB.

I'm also having a problem accessing a web server since Apple removed some root certificates in iOS 8.3, but that's technically not a "bug" per say.
 
Comment

thanh.n

macrumors newbie
Mar 10, 2015
3
1
It worked for me now, iTunes and Appstore asking me for TouchID. I just logged out from my Account, go back to TouchID-Settings and turned it on again that TouchID can used for purchases -> logged in again -> works.
 
Comment

slattery69

macrumors regular
Original poster
Jun 16, 2009
187
8
Paid Shill
Mines working again, haven't done anything since starting the thread and seeing the front page article on it. Just left it assuming 8.3.1 might come along.
Just gone in to the app store to get an app and it asked for my touchid.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.