TRIM Possibly Causing Boot Failures? OSX Lion, 7.0, MBP Mid 2007

Discussion in 'Mac OS X Lion (10.7)' started by GypsyLion, Aug 19, 2011.

  1. GypsyLion macrumors newbie

    Joined:
    May 13, 2011
    #1
    I'm not sure what is causing this, but this is the third time (though not in a row) that my MBP Mid 2007, with a Kingston SSD (not the stock HD that comes with this model) with Lion installed on it fails to boot up... I've had to erase and restore from back up 3 times.

    1. First Time this happened, it was after "updating" Snow Leopard to 10.6.8. (NOTE: TRIM was enabled via a utility I found HERE prior to update)
    2. Second Time was after Installing Lion from the App Store (TRIM was eventually enabled again prior to this failure)
    3. This last time was after backing up, then using the machine for 6 hours until I restart, and then there is this boot failure. (TRIM not Enabled for my Kingston Drive prior to this failure— I think I learned my lesson ;-P )
    4. But this last time I attempted to restore from back up, got an issue with time machine where my target volume "didn't have sufficient space" to restore from my latest back up...I had to pick a back up from a few days prior ;-)

    This is what happens NOW;

    1. turn power on
    2. apple logo shows
    3. gray progress bar quickly flashes
    4. machine cuts off

    Actions performed prior to failure:
    1. logged out of guest account*
    2. logged out of main account
    3. restart
    4. logged into main account
      [*]ran time machine back up
    5. used machine for a little while (mostly surfing)
    6. performed power down
    7. power on
    8. boot failure

    Wierd Symptoms before this recent failure to boot:
    1. Switching between logged in guest user account and main account seemed to hang or freeze
    2. pressing esc. unfreezes, login resumes (SL NEVER did this)
    3. user account login field finally appears after a long delay
    4. noticed a web page that appeared differently on my mac, than on others in the same room with me browsing to the same site... this behavior prompted me to restart—after which, my MBP fails to boot completely

    Wondering if my Kingston 128GB (system drive) has compatibility issues with this mid 2007 model MBP, or if Lion destroys my drive after about 3 weeks of use every time.

    Question:
    • Anyone have any ideas on what could be causing the seemingly random boot failures?
    • Anyone experiencing boot failures after powering down with a similar config? (MBP 3,1 Mid 2007, Kingston SSD installed)
    • Anyone run Disk Utility only to find "Node Errors" preventing a disk repair?
    • Anyone think it's ridiculous to have to erase and restore for the third time after your machine fails to boot up?

    I miss the stability of SL.

    Thoughts?
     
  2. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #2
    If you're hacking a driver level service (TRIM), then don't be surprised when an OS change breaks the hack.
     
  3. iLidz macrumors member

    iLidz

    Joined:
    May 19, 2011
    Location:
    California
    #3
    Wirelessly posted (iPhone 4: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8G4 Safari/6533.18.5)

    I've had a some what similar problem with my intel SSD (510 series). However, I only had the TRIM hack enabled the first time my drive became corrupt. I erased the drive and reinstalled Lion without TRIM enabled and my disc error came back. I initially suspected the TRIM hack to be causing the error, but the problem has happened again twice with no TRIM enabler. Im having trouble finding the root cause to my disc errors. At this point I am suspecting either a problem with the OS/SSD SATAIII connection or a faulty SSD drive. I plan on a clean install of Lion and just leaving the negotiated link speed at SATAII. If the drive works, it's coming out and will be swapped with a different drive. If it fails again, it's going back to intel.

    Ps, I only have had Lion installed on my SSD so I don't have any lion vs SL experience here.
     
  4. GypsyLion thread starter macrumors newbie

    Joined:
    May 13, 2011
    #4
    Lion Fails to Boot after Restart, Shut Down

    TRIM hack was not enabled after my first restore... Back everything up twice last night, and now, after a restart this morning, Lion has trouble booting up. It seems to happen right after a backup, and right after rebooting after a back up... Very wierd... Here goes another hour wasted hour restoring my machine!!

    Anyone have any solutions?

    MBP Mid 2007
    Kingtson 128GB SSD
    Kingston RAM 6 GB (2GB + 4GB)
     
  5. mad2511 macrumors newbie

    Joined:
    Aug 28, 2011
    #5
    Hey guys,

    I'm having the same problem for 2 weeks now.
    I have a 128Gb Kingston SSD (in a bay, no more optical drive, macbook unibody late 2008) and upgraded from SL to Lion. Worked perfectly for couple days and then couldn't get Lion to boot. The screen is stucked on the grey screen and the spinning wheel keeps ... spinning.

    I had to reinstall Lion via usb on my second hard drive. It's a pain.
    Looks like it happens everytime I use the computer until the battery dies.

    I don't know what to do either. I tried Disk utility and it says node error, failed to repair etc.. Please note that my SSD worked perfectly under Snow Leopoard for about 6 months, so the problem is really Lion.

    Does anyone has a solution to provide? I'm desperate here.

    Thanks a bunch.
     
  6. TPadden, Aug 28, 2011
    Last edited: Aug 28, 2011

    TPadden macrumors 6502a

    Joined:
    Oct 28, 2010
    #6
    Don't know if it's a solution but I've found most of my problems are with TM. With a fresh install (either clean or restore) I've found once everything is running a format of the TM drive or partition is needed. Otherwise it takes forever to backup, hangs somtimes, and the CPU stays pegged.
     
  7. mad2511 macrumors newbie

    Joined:
    Aug 28, 2011
    #7
  8. GypsyLion thread starter macrumors newbie

    Joined:
    May 13, 2011
    #8
    I will try this firmware Update too!

    Thanks for posting! Didn't get around to checking out Kingston's resources, as I thought the issue might have been related to Apple's biased support for TRIM. My Kingston 128 SSD worked like a charm until I started messing with TRIM hacks.

    But it would make sense, to try the firmware update as the next step!

    On a side note, I performed a "Repair Permissions" on my drive after a backup and then before my latest update to Lion. It went smoothly, and even booted up after a restart. So as a precaution, before every Time Machine back up, I'm performing these checks on the drive anyway.

    Ok, off to try the Firmware Update from Kingston...
     
  9. 50548 Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #9
    As exhaustively explained elsewhere, Apple has enabled TRIM only on its stock SSDs for a reason - do NOT use TRIM Enabler, as it won't probably bring you any benefits at all.

    It is a low-level hack applied to kext files that totally disregards timing/optimization aspects that normally need to be configured on each SSD concerned. Besides, if your SSD is SandForce-enabled, it does NOT need TRIM at all - just forget about that soon-to-be-deprecated technology.

    p.s.: I DO have a Vertex 3 SSD custom-installed on my iMac (by an AASP), and it runs without a hitch on Lion.
     
  10. RS2 macrumors member

    Joined:
    Apr 4, 2011
    #10
    Do not install Trim Support Enabler 1.2 if you are running Lion! There are other ways to patch the kernel extension to enable TRIM in Lion.

    Trim Support Enabler 1.2 will install an outdated kext from Snow Leopard and you can't restore to the original Lion kext using the app!

    Read more starting here. Please read ALL before you try to restore the Lion kext.

    Trim Support Enabler
     
  11. mad2511 macrumors newbie

    Joined:
    Aug 28, 2011
    #11
    Any updates on that? I cannot burn the firmware update on a disc as I replaced my optical drive with the Kingston 128Gb SSD Drive. Only way for me would be to "burn" the .iso file to a usb key and boot from it. I tried that via Terminal, with no luck. If anyone has a solution to do that properly, I really appreciate.

    Thanks.
     
  12. eych macrumors newbie

    Joined:
    Sep 19, 2011
    #12
    Hello.

    Don't bother with the firmware upgrade.

    I have exactly the same problem on the early 2011 MacBook Pro and Kingston SV100S2/256G SSD. I updated the firmware to the latest one and when I tried to reboot MacBook after a day of usage I got the same Apple Logo/unable to boot problem again.

    I was using this SSD from March on Snow Leopard with zero problems. The apparent corruption of data which prevent MacBook from booting started right after I upgraded to Lion.

    Subjectively it seems like Lion writes some extra data to disk compared to Snow Leopard when you power off the machine and due to some failed communication between the OS and the SSD or wrong expectations on one of the sides not all of the data ends up being actually written on the SSD when the machines powers off, thus the data corruption happens and I can't boot it anymore. It makes sense that the boot related data is being corrupted as this is probably what Lion writes to disk when you shut it down.
     
  13. jschmied73 macrumors newbie

    Joined:
    Oct 14, 2011
    #13
    I have a Corsair Performance 3 Series 128GB SATA3 drive and have the same issues. I'm running the latest release of Lion and a 27inch iMac. I added the SSD and removed the superdrive. Is anyone with this issue running a SATA2 drive or are we all SATA3? As of now, I've reinstalled (4th time) back on my old HDD.
     
  14. jeremyjaytaylor macrumors newbie

    Joined:
    Dec 1, 2011
    #14
    Kingston 256 SSD

    I think your hypothesis makes a lot of sense.
    I've had the EXACT same series of events happen (as described extensively on this blog), in the last week... I noticed that it consistently seems to be happening right after an update and restart... In fact, I'm not so sure it isn't related (somehow) to the update process although your hypothesis about the boot process also seems reasonable), because of something that happened tonight:
    *
    Since my last crash/reformat/reinstall (about three days ago), I've been verifying the hard disk a few times a day to monitor things. Tonight, I received a notification to install the Safari 5.1.2 update. After it finished (and it prompted me to restart), it occurred to me that I should check my disk before restarting... Sure enough (before rebooting), when I verified with Disk Utility, it said I had a disk error and needed to repair (which of course fails also, and the cycle begins again). HOWEVER, before I restarted, I copied all the logs from my console from today, so I'm hoping I might find some clues there (although I'm fairly novice, so it may not be realistic).
    *
    If anyone had any additional info (beyond disk warrior and/or get a new drive), it'd be greatly appreciated. BTW, my drive is also a 256 GB Kingston (only 8 weeks old) and was supposed to have the firmware upgrade already... My MacBook is a late 2009 13-inch MacBook Pro.
     
  15. chekofif macrumors newbie

    Joined:
    Mar 13, 2011
    #15
    Have any of you guys found a solution to this problem? :(
    I am having the same trouble with my Kingston sv100s2 256GB.

    My drive is new enough so it had the firmware installed already when I got it...
     
  16. Frixo Cool macrumors member

    Joined:
    Jun 10, 2004
    Location:
    Croatia
    #16
    I have the same problem with Kingston V100 128GB in my Mac Pro. It comes in every 3-5 weeks and then I have to do full TM restore. Never had this problem on Snow Leopard.

    Today I have made the recommended firmware update on SSD, but I don't expect much as I see here that it's not related to our problem.

    Is Kingston aware of this problem on Macs with Lion?
     
  17. srhb macrumors newbie

    Joined:
    Jan 30, 2012
    #17
    I can confirm that this has nothing to do with TRIM, nor the firmware update. I bought an V100 128GB drive that had the fixed firmware from factory already, and I have not tried enabling TRIM by any third party software. The problem is exactly the same.
     
  18. mct74 macrumors member

    Joined:
    Aug 15, 2008
    #18
    I have been dealing with this issue since moving to Lion as well. I have a KINGSTON SV100S2 256GB SSD and I have not installed any TRIM hacks at all. System is completely stock except for replacing my OEM Apple hard drive with the Kingston SSD. My first failure occurred after a system update that forced a reboot. Upon reboot, the system just hung and would not boot. I finally had to reinstall Lion and restore from a backup.

    This happened a few more times, each time I rebooted the machine. Since I normally just put the machine to sleep, I don't reboot too often, so the times I had to reboot, the system would hang and not boot up.

    I started observing the drive a bit more closely and I would run disk verification every now and then to make sure things were ok. What I noticed was that if I rebooted the machine frequently, reboots would happen without a hitch. If, however, I used the sleep function instead of fully shutting down my machine each day, the system would schedule a disk check on the reboot which took a few extra minutes (the disk check would take place upon boot after the spinning progress wheel would appear on the grey boot up screen - there would be grey progress bar that would show up and indicate the progress of the disk check).

    If I went weeks without a reboot, the next time I rebooted, the disk check on boot took even longer. If I went a month or more without a reboot, I was pretty much guaranteed a corruption on boot that could not be repaired by the disk check.

    Just this week I had the disk check take place when I rebooted my machine and when it came up, WebKit was not loaded and a bunch of applications would not open, including the Software Update App, Safari, Adium, etc. I looked in the error logs and everything pointed to Webkit modules not loaded. I decided to install the latest Lion combo update and luckily upon install, it reinstalled the corrupt components and I was back in business.

    Bottom line - there is a serious issue with Kingston SSD's and Lion. I cringe each time I reboot. I am now making sure I have a good time machine backup before each reboot. I hope there is a fix soon or I may have to ditch this SSD.

    BTW - is anyone having these issues on a non-Kingston SSD?
     
  19. DLary macrumors member

    Joined:
    Oct 21, 2005
    #19
    I'm having the same problems with an Intel SSD 510 120GB. Seems to occur after a reboot. I run disk warrior and it finds overlapped files, but cannot fix them. Tech Tools Pro fixes the overlapped files, but won't recognize the drive until I have made a first attempt with disk Warrior. I wonder if the drive is corrupting the cache files when shutting down?
     
  20. aarreoskari macrumors newbie

    Joined:
    Apr 10, 2012
    #20
    Kingston SSD SV100S2/128G

    Thanks for all the info! I've been strugling with the same problem and symptoms seem to match. So I confirm the issue with Kingston SSD SV100S2/128G on Mac Mini. I bought the disk with the new firmware (D110225a) already installed.

    Since I already had Lion installed I cloned a disk image from old HD to new SSD. Everything went fine for a month or so. Until I used Software Update to update OS to 10.7.2. After restart I got the grey progress bar and Mac died.

    First I thought it was the update that caused it but since then I've had the issue every time I shut down the Mac for a weekend or a longer holiday. Usually I just put it to sleep.

    I'm gonna try rebooting it more frequently but I'd like to see a better fix.

    Mac Mini 2.0Ghz, Early 2009 (macmini3,1)
    Kingston SSD SV100S2/128G (D110225a)
    Mac OS X 10.7.1
     
  21. aurora72 macrumors newbie

    Joined:
    Jun 7, 2010
    Location:
    Türkiye
    #21
    On my 2 Mac minis (with Lion 7.2 or 7.4 and Intel X25-M SSD) I do have the same type pf problem.

    I have installed SSD to speed up the boot process but it end up taking 2 or 3 times longer than ordinary HD, because of that problem!

    The TRIM is not enabled by default. Here's the screenshot
    [​IMG]
    Sorry for Un-English lines, my Mac OS is Turkish. "Hayır" means "No" and "Evet" means "Yes" in Turkish. TRIM Desteği>TRIM Support.

    I have done everything to cure that problem and none helped. I've performed Disk Verify/Repair, Permissions Repair. It's apperantly a lower level problem than the OS or the filesystem level.

    It cannot be a bad SSD because the same SSD boots and works perfectly fine in other OS'es such as Linux/Ubuntu and S.Leopard. So I'm sure that this is a problem of Lion. What an unfortunate case.

    The summary of the problem:

    The Mac mini boots almost always problematic if it's been shut down for more than several hours, for example, say it's been shut down overnight. When I turn it on in the morning, it almost always boots with gray progression bar under the Apple logo and what's worse, after that the Mac mini fails to load many things such as NTFS-3G external HD's, graphics accelerators, audio, etc... rendering the system useless.

    However, when I restart the system from that moment on, it boots perfectly fast and fine!

    I wonder if that problem was adressed in Mountain Lion. If I upgrade to Mountain Lion will that SSD problem be gone?

    Thanks.
     
  22. nomanstool macrumors member

    Joined:
    Oct 4, 2010
  23. eych macrumors newbie

    Joined:
    Sep 19, 2011
    #23
    Fixed in Mountain Lion?

    After almost two weeks on Mountain Lion it seems that this issue is either fixed or at least it definitely has changed its behavior.

    Now after a restart I sometimes do get an Apple logo and a progress bar indicating (I assume) a disk check. But on Lion in most cases this resulted in Mac powering off almost immediately after the beginning of the check and a restore from a backup being necessary. Now the check successfully finishes and Mac boots normally after that.

    There is a new issue now though because of SSD :) Sometimes after a restart color profile for the dedicated graphics card doesn't load and when some application triggers a switch to a dedicated card, suddenly all windows get a blueish tint. This can be fixed by logging off and then back on.
     
  24. chandakmayank macrumors newbie

    Joined:
    Oct 3, 2012
    #24
    [Solved] TRIM Actually solves this problem

    I just got a macbook like 3 months back. Fitted with a patriot Torqx 128gb drive as boot and a normal hdd with the Data Doubler in the optical bay. I was also having the exact same problems (Gray progress bar, reboot loop) multiple times. 1 time i even did not have TM backup after 21 days of use.

    But after ML and TRIM script below, things were pretty smooth here. Last night my itunes said the library file is corrupt,even photoshop also said it cannot read from disk, so i just shut it down to let it rest. Boot MBP today morning with the same bloody problem.
    But i was prepared for this day, so i had another OSX install in my second HDD just for emergency purposes, mainly used for disk utility and Disk Warrior. As usual disk utility could not repair ssd. But DW rebuild the directory indexes. Phew. Reboot to SSD all's fine. But when i check the DW graph running from the SSD it showed 27% of disk is unoptimised.

    Well then i remembered, the Trim Enabling script i used from here (http://digitaldj.net/2011/07/21/trim-enabler-for-lion/) was applied to 10.8, but 3 days back i had applied the 10.8.2 update, so that patch must be gone by now. It was, as i checked in system report. So i reapplied the TRIM Patch and rebooted.

    So now after the reboot when i build another graph for the SSD, it tells me only <1% drive not optimised. Wow. And the system is again running like breeze. I hope it goes on this way for long.

    So Grant Pannel(http://digitaldj.net/) actually saved a lot of my time. Hit the link to read more about TRIM etc. Very detailed and informative
     
  25. aarreoskari macrumors newbie

    Joined:
    Apr 10, 2012
    #25
    Thanks chandakmayank for the detailed instructions.

    Do you think TRIM enabler fixes the disk corruption?

    Which brand and model SSD disk do you have?
     

Share This Page