Trying to Disable SIP, Can't Access Recovery Mode

Discussion in 'OS X El Capitan (10.11)' started by Heavenly Spoon, Oct 19, 2015.

  1. Heavenly Spoon macrumors newbie

    Joined:
    Jan 4, 2010
    #1
    I've recently gotten around to updating to OS X El Capitan and I've encountered an unanticipated problem. I've been using custom Icons for apps and folders for ages now, and apparently I can't edit the icons of some essential applications without disabling SIP. To do this, however, it seems I have to use Recovery mode, which turns out to be a bit of a problem. I'm not sure how or why, but I can't seem to access the Recovery Partition. I know it exists, I can see it with "diskutil list". I can't access it by holding either CMD+R or CMD+ALT at start-up, though. I'm using a mid-2009 Macbook Pro, so I can't access the online Recovery Mode. I've had my DVD drive replaced with SSD a while ago, and I think the Recovery Partition may have gotten disabled or something as part of the associated back-up.

    I've tried creating a new recovery partition using a specific app (Recovery Partition Creator), with no success. I've tried turning a USB drive into a Recovery Disk, but when trying to boot from it it just boots like usual for some reason I can't begin to fathom. I don't know what else to do, and searching the web seems to yield no solutions.

    So what I'm basically looking for is either a way to disable SIP without Recovery Mode or a way of accessing Recovery Mode.

    I've been trying things for the last few hours, and I'm at a loss. I'm not sure I can go back to the regular icons, especially considering most of my folders and apps still have custom icons. I honestly don't recognise half of what my apps are supposed to be and it's frustrating me to no end. Any help would be greatly appreciated.
     
  2. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #2
    If you have, or are able to create a USB install disk, you can use it to manage SIP. When you boot with it, go to Utilities > Terminal. There you can run the csrutil commands. When you are done, just reboot back to your normal disk.

    DS
     
  3. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #3
    Command-Option is incorrect, try holding down only the Option/Alt key and see if it appears in the boot menu.
     
  4. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #4
    Command+r is correct for the Recovery, command+option does not do anything for start up. Here is a list of start up key combinations:
    https://support.apple.com/en-us/HT201255

    Booting from a USB thumb drive installer should work. The best solution would be to get your Recovery partition back by reinstalling the OS.
     
  5. ssn637 macrumors 6502

    Joined:
    Feb 12, 2009
    Location:
    Switzerland
    #5
    I have the same problem. My SSD is divided into three separate HFS+ partitions, which allows me to keep my music and video library on a dedicated volume independent of the OS X System. A clean installation of El Capitan reported that due to this configuration some features couldn't be added, and no recovery partition was created.
    I tried the same utilities as the OP to manually created a Recovery HD, but the applications reported that the resulting volume would be too small (or large, depending on the attempt).
    I suspect the only solution will be to reformat my SSD to a single partition from a USB Flash Drive installer and then recreate the volumes later, but I haven't tried this yet since it would take forever to copy over all my files from a backup drive.
    I even ran the Recovery HD update package that was released in August for one of the El Capitan Beta versions, which did indeed create the partition (I confirmed this via DiskUtil List in Terminal), but I couldn't boot into it with CMD+R.
     
  6. tywebb13, Oct 23, 2015
    Last edited: Oct 23, 2015

    tywebb13 macrumors 68000

    Joined:
    Apr 21, 2012
    #6
    There seem to be 3 issues here in this thread.

    1. How to disable sip without a recovery partition.
    2. How to access a recovery partition if cmd+r doesn't work
    3. How to create or update a recovery partition.

    To disable SIP WITHOUT a recovery partition


    Here are more details on dsemf's suggestion.

    Make a bootable usb of the el capitan installer using apple's instructions here https://support.apple.com/en-au/HT201372

    Boot up from it by holding down the option key and then selecting Install OS X El Capitan in the startup manager.

    Then in the utilities menu open terminal and to disable SIP, type

    csrutil disable

    Press return and restart the computer and check in terminal that it has been disabled by typing

    csrutil status

    In case you ever want to re-enable SIP without a recovery partition, you can boot up again from the bootable usb and type in terminal

    csrutil enable

    and then press return and restart.

    To access a recovery partition if cmd+r doesn't work

    Booting up with the option key should show the recovery partition in the startup manager if one exists - UNLESS it a core storage volume has been created which will hide it - in which case you can revert it this way:

    Run these 2 commands in terminal.

    diskutil cs list

    and then

    diskutil coreStorage revert lvUUID

    where lvUUID is the last lvUUID reported by the previous Terminal command.

    Then restart for everything to get back to normal after you have run these commands in Terminal.

    You may then boot up with the option key to access the recovery partition.

    To create or update a recovery partition

    You can use the method in this thread:

    http://forums.macrumors.com/threads/how-to-update-the-recovery-partition.1931536/
     

Share This Page