Trying to restore to custom 5.0.1

Discussion in 'Jailbreaks and iOS Hacks' started by lukeman3000, May 3, 2012.

  1. lukeman3000 macrumors regular

    Joined:
    Nov 20, 2007
    #1
    So, I'm currently running 4.2.1, and I want to upgrade to the latest untethered jailbreak (which I think is 5.0.1, no?)

    Anyways, I followed this] guide, and was able to make the custom firmware successfully.

    I started the phone in DFU mode, and it had a black screen (like snowbreeze said it would). I went into itunes, shift+clicked on "Restore", and selected my custom firmware. It didn't get very far before it threw an error 3194 at me.

    So I did some googling, and it sounded like I needed to edit my hosts file, turn off some anti-virus, restart my computer, etc. So I tried all of these things with no success.

    Then, somehow my phone got out of DFU and started up normally, and I tried to restore with the custom firmware. It just said "Preparing to restore phone" forever, so I unplugged it. Now, on my iphone, it just shows a usb cable pointing to an itunes icon.

    I know I screwed it up, but now I don't know where to go. I am completely lost as to what I should do. My goal is to get a 5.0.1 untethered jailbreak while preserving my baseband. I thought I had done everything correctly up to this point, but obviously I jacked something up. Help?
     
  2. Ishmumrhmn macrumors regular

    Joined:
    Feb 3, 2012
    #2
    Nope, unless you have the SHSH Blobs for 5.0.1 you won't be able to upgrade.
    And FYI, 5.1 is the latest firmware, Apple does NOT sign 5.0.1 anymore
     
  3. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #3
    Ok, so then two questions:

    1. Wtf are SHSH Blobs, and can someone give them to me, or are they specific to my device?

    2. Can I (at least) upgrade to 5.1 tethered since, apparently, I can't do 5.0.1? My iPhone seems unresponsive now that it just shows the "connect to itunes" logo.

    3. Is there any way to salvage my old jailbreak, or is it gone at this point?
     
  4. Ishmumrhmn macrumors regular

    Joined:
    Feb 3, 2012
    #4
    1. SHSH Blobs are files/sigs that tell itunes that you can restore to certain firmware(s) You can only get em by using cydia and being on those firmwares.
    2. Yes, you can upgrade to 5.1 and the reason why your phone is stuck is because the baseband is corrupted and needs to be reflashed. Use tinyumbrella to kick it out of recovery then use redsn0w to install iPad baseband.
    3. I don't get what you're saying
     
  5. sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #5
    1. SHSH blobs are you verification tickets that Apple requires for firmware upgrades and they are specific to your device yes but seeing as you've been jailbroken in the past they still likely to be there. You need to download the latest version of Tiny Umbrella which you can use to kick your device out of recovery as well as extract and save those blobs to your pc/mac which you need to build a custom ipsw using iFaith or redsnOw.
    2. iPhone 4 with saved blobs, yeah. IPhone 4s not so much :p
    3. Kick your device out of recovery using Tiny Umbrella and your device should be as you left it before.
     
  6. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #6
    I got the latest version of Tiny Umbrella, but the recovery options are all greyed out...
     
  7. sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #7
    Your device connected to pc/mac via cable? Turn off anti-virus, select your device which is hopefully displaying in the Tiny Umbrella device menu on the left, option to exit recovery should be available...

    You can also try holding down power and home button, same time for 10 seconds, then release both, press and hold power button for 3 seconds and watch/hope the device boots normally...
     
  8. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #8
    No dice. I can get it into DFU mode where the screen is black, then "Fix Recovery" becomes clickable, but it doesn't seem to do anything. When I turn it back on, I just get the "connect to itunes" logo again.

    I have a feeling that I'm going to have to restore to fix this. And I'm assuming that means I'll have to restore to the newest firmware since Apple is signing it (5.1).

    However, can I create a custom .ipsw of 5.1 and at least preserve my baseband?
     
  9. sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #9
    iPhone 4 yes, 4s I don't think so...

    Have a look here:

    http://maypalo.com/2012/03/09/download-ios-5-1-without-upgrading-baseband-for-iphone-43gs-guide/

    http://www.coolestguyplanet.net/upg...-to-ios-5-and-preserve-baseband-with-redsn0w/

    Are you using an iPhone 4 or 4s? windows or mac?
     
  10. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
  11. sand_man, May 3, 2012
    Last edited: May 3, 2012

    sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #11
    Yeah, then you okay.

    Check your C drive for your blobs. If you got them saved on your pc you'll find them at the following location:

    C:\Users\(your name)\.shsh

    If you don't find them there you can use Tiny Umbrella to get them.

    http://www.ijailbreak.com/how-to/ho...inyumbrella-and-downgrade-using-tinyumbrella/

    Once you successfully got the blobs on your pc the rest is quite easy, seriously...

    You tried the hard reboot method detailed above, home and power for 10 sec, release both, power for 3 second...?

    http://www.iphoneleaks.net/2012/03/download-ifaith-1-4-2-v1-4-2-free-for-windows-shsh-blob-dumper/

    I use the iFaith tool for custom ipsw and find it to be the most effective...

    PS: If you running Teamviewer I can offer some remote support, we can try get this running..
     
  12. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #12
    I do have Teamviewer.. However, I was able to save some SHSHs! I didn't realize I had to click on the device in the left window before the button would become clickable in Tiny Umbrella.

    So, then I go to C:\Users\Lucas\.shsh and I see this:

    .cache
    .known_devices
    1728020927822-iphone3,1-4.2.1.shsh
    1728020927822-iphone3,1-4.3.3.shsh
    1728020927822-iphone3,1-4.3b1.shsh

    I opened up snowbreeze and chose the ifaith option which lets you build a custom firmware with blobs. But I quickly realized that I probably need to download a 4.2.1 firmware file so that it will work with my blob, right? Is that the next step? (Or, 4.3.3 for that matter?)

    But, I am stuck at 4.3.3.. right? I can't upgrade to 5.0.1 can I...

    And my iPhone is still stuck on that screen that has the itunes logo and the usb cable. I tried to "fix recovery" with TU, and a bunch of white text came up on the screen, but it eventually just went back to the itunes logo.
     
  13. sand_man, May 3, 2012
    Last edited: May 3, 2012

    sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #13
    Yeah, that's a pity. The latest software you got there is 4.3.3 although using Tiny Umbrella, go to advanced tick Request SHSH from Cydia option and try Save SHSH again. Maybe the 5.0.1 blobs have been backed up to Cydia.

    Surprised TU can't kick it out of recovery. I assume you tried the Fix recovery option too?... EDIT: My bad, of course you did...
     
  14. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #14
    Try a different route, you're using old stuff, snowbreeze was nice, but redsn0w is better.

    Try to kick it out of recovery with redsn0w.

    otherwise just go back into DFU.

    If your phone was jailbroken on 4.2.1 cydia should have your shsh's+APticket saved automatically.

    Use redsn0w to find out if you have all your blobs for 5.01.

    Download the latest redsn0w from here:
    http://blog.iphone-dev.org/post/18906290309/march-mayhem

    Start it up

    Go to Extras/SHSH/Fetch

    Than do Extra's/SHSH/Query

    If ist says full or partial blobs for 5.01 you should be able to make a custom IPSW to upgrade to 5.01

    First make a No_BB custom IPSW with redsn0w. This to avoid BB errors during the upgrade.

    Go to Extras/Custom IPSW
    Now select your downloaded stock 5.01 IPSW
    redsn0w will make a custom NO_BB IPSW

    with that one go to Extras/SHSH/Stitch
    Now select the NO_BB custom IPSW
    and the new blobs for 5.01

    redsn0w will make a second IPSW with your 5.01 SHSH and APTicket stitched to it, it will have a longer number as name.

    With that one go to itunes, go into DFU-mode and SHIFT-restore the stitched IPSW.

    after restore jailbreak with redsn0w
     
  15. sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #15
  16. lukeman3000, May 3, 2012
    Last edited: May 3, 2012

    lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #16
    Well, a blob for 5.1 just appeared.. I'm not really sure how/why because I haven't put 5.1 on my phone.. ?

    But I'm really not sure how it works. Would I have necessarily had to have the firmware installed on my phone for it to be downloaded from Cydia? It also gives me a warning when the "download from Cydia" button is checked. Something about it being unreliable or something.

    Edit: For clarity -- I was referring to Tiny Umbrella here. I will certainly try your advice, TriJetHero. Thanks for all the help thus far everyone. I'll keep you updated.
     
  17. sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #17
    Blobs are automatically saved afaik. If you got 5.1 you must have 5.0.1... Which is good news. You can use redsnOw to stitch a custom 5.0.1 ipsw, preserving the baseband and then do a restore via iTunes...
     
  18. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #18
    No you don't have to have the firmware on your phone to have the blobs saved.
    TU probably told you that host is said to Cydia, for upgrades to work the host has to pint to apple again.

    In TU go to advanced, make sure you have Set host to Cydia UNchecked.
     
  19. lukeman3000, May 3, 2012
    Last edited: May 3, 2012

    lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #19
    Ok, I downloaded redsn0w 0.9.10b8b and went to Extras/SHSH/Fetch and it eventually said this:

    "Nothing to do!

    Cydia server already has a FULL set of blobs for this configuration.

    Device: iPhone 4
    ECID: 1728020927822
    Build: iPhone3,1_4.2.1_8C148

    Success!"

    Then, I hit "Query" and it asked for an ECID, so I just assumed it wanted the same one that I had been given when I clicked "fetch" (correct me if I'm wrong) and this is what it said:

    "iPhone3,1 1728020927822 full blobs:
    4.2.1, 4.3.3"

    So, am I screwed for 5.0.1?

    On a better note, redsn0w was able to kick my phone out of recovery mode. Should I just stick with 4.2.1 and unlock it, or is there any way I can upgrade to 5.0.1? If not, is it worth going to 4.3.3?

    Edit: Again for clarity, my phone is already jailbroken, but it is not unlocked. I was wanting to upgrade to the most recent untethered jailbreak OS (5.0.1), but I was ignorant of the fact that, apparently, you can't do that anymore because apple isn't signing it. Unless you have a blob or something to that effect, which I'm not sure how I would've had one for 5.0.1 in the first place.
     
  20. sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #20
    At least you out of recovery. Sure the blobs for 5.0.1 are there somewhere. Have you had another look in your C:\Users\Luke\.shsh

    Also open Cydia and check what it says above Welcome to Cydia, SHSH: and listed would be all your saved blobs..
     
  21. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #21
    When I open up Cydia, at the top it says this:

    "SHSH: iOS 4.2.1, 4.3~b1, 4.3.3, 5.1"

    So.. should I have taken some sort of action to get the blob for 5.0.1? Did I miss out on something? Am I out of luck?
     
  22. sand_man macrumors 6502a

    sand_man

    Joined:
    Jun 3, 2011
    Location:
    Johannesburg, South Africa
    #22
    Yeah, nothing saved for 5.0.1. Seems you were out of circulation for an extended period of time where you didn't connect to Cydia when 4.3.5, 5.0 and 5.0.1 were being signed...

    If I were you I would stay put for now. Wait it out until JB 5.1 is released (if ever). Or upgrade and forfeit your jailbreak (I wouldn't). There's been speculation that the next JB will be for iOS 6 and not on 5.1 :eek:
     
  23. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #23
    Well, I could do a tethered 5.1, right? The only restriction is that I must connect to my pc whenever I restart the phone, but other than that, it would be the same as what I'm using now except for the updated firmware, and I'd still be able to preserve the baseband and unlock it, correct?

    Or, if I'm not completely wrong about that, do you still think it's advantageous to stay put? Or should I upgrade to 4.3.3 since I have the blob? As I understand it, I have three options:

    1. Stay put

    2. Upgrade to 4.3.3 with custom ipsw and preserve baseband (untethered)

    3. Upgrade to 5.1 with custom ipsw and preserve baseband (tethered)
     
  24. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #24
    Yes you're out of luck on 5.01

    You can go to 4.3.3 untether, but i would stay put until 5.1 or 6 untether.

    Is it correct that at the moment you don't have an unlock, or you don't need one?

    Keep up on the jailbreaking scène not to miss out on the next cycle.

    edit:
    Yes you can go to 5.1 tethered, but do you need an unlock?
     
  25. lukeman3000 thread starter macrumors regular

    Joined:
    Nov 20, 2007
    #25
    I would really like an unlock, yes. I ditched at&t a few months ago because I got tired of paying 80+ bucks each month for my bill, but I have a friend who can get me a sweet deal at t-mobile. He said that if my phone was unlocked, he could hook me up no problem.

    So it'd be nice to have it unlocked. How does that affect my choice to stay put, upgrade to 4.3.3, or 5.1? For the record, I definitely prefer the untethered options.

    Also, what utility should I use to unlock (assuming it's a possibility)?

    My modem firmware is 03.10.01
     

Share This Page