[Tutorial] How to Enable USB Install on Mavericks for unSupported Bootcamps

Discussion in 'Windows, Linux & Others on the Mac' started by RahulRulz, Dec 4, 2013.

  1. RahulRulz macrumors member

    RahulRulz

    Joined:
    Sep 18, 2013
    Location:
    London, UK
    #1
    Hello, I have recently posted a Guide on how to Enable USB Installation on Bootcamp in a thread. I can see that many users are having this issue like some of them don't have SuperDrive or want to install using USB but there Bootcamp doesn't support USB Installation.

    So now I will show you how to enable USB Installation on Bootcamp on any unSupported Mac Systems
    (MacBook, MacBook Pro, MacBook Air and more.)

    Things you required:

    • Mac OS X Mavericks
    • Bootcamp Assistant
    • Terminal
    • Xcode (Download from AppStore)

    Steps are as Follows:

    1. Open Terminal and type the code below, this will copy Info.plist to Desktop as a Backup.
    Code:
    sudo cp /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/Info.plist Desktop/Info.plist.bak
    
    2. again in Terminal type the code below, It will open Info.plist.
    Now move down and Add your BootRom Version under "DARequiredROMVersions" at Top of the List.
    (to find BootRom Version open "System Information" from Spotlight)
    Code:
    sudo nano /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/Info.plist
    
    [​IMG]

    3. move Down again, find "PreUSBBootSupportedModels" and delete "Pre" from a word also add your Model Identifier at Top of the List.

    [​IMG]

    4. now Save and Exit Terminal by Pressing "control + x" then " Y " and "enter"

    5. now I assume that you have already installed Xcode, If not Download and Install it now for further steps or else you will get error.

    6. After Xcode is installed open Terminal again and type the code below:
    Code:
    sudo codesign -f -s - /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/MacOS/Boot\ Camp\ Assistant
    [​IMG]

    now It will ask you to read License Agreement, Hit enter to read Agreement and press "control + q" to exit the License Agreement.
    [​IMG]
    after that It will ask you to agree the terms of Software type "agree" and hit enter.
    [​IMG]

    7. Done, now You can install Windows using USB Flash Drive.
    [​IMG]

    If you get any Error or having Problem, Post here.

    Thank You
    Tutorial created by RahulRulz
     
  2. shamash macrumors 6502a

    shamash

    Joined:
    Jul 19, 2008
    Location:
    Taichung, Taiwan
    #2
    Hopefully you can help. This lets me make the USB drive, but when I try to install from it, I get stuck on a black screen after partitioning+restarting that says there is no bootable disk.
     
  3. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #3
    All the above procedure does is un-grey the checkbox about creating a bootable USB drive, no more, no less. It doesn't solve the inherent lockdown Apple placed on its machines that mandates the SuperDrive be used for Windows installations. The only workaround I know of that's had at least a small degree of success involves using VMWare Fusion and rEFIt. Do a search for it, and you'll find a couple variations of this process. One might work.
     
  4. PhGodinho macrumors newbie

    Joined:
    May 7, 2013
    #4
    If I manually remove the Super Driver the option will be enabled and the setup process will work?

    I'm thinking about removing my Drive to put an extra SSD.
     
  5. RahulRulz thread starter macrumors member

    RahulRulz

    Joined:
    Sep 18, 2013
    Location:
    London, UK
    #5
    Yes, It will.
     
  6. FettStuhl macrumors newbie

    Joined:
    Mar 27, 2014
    #6
    Hi
    i have a problem!
    i followed your tutorial till step 6.
    after i tiped
    "sudo codesign -f -s - /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/MacOS/Boot\ Camp\ Assistant"

    i got:
    "2014-03-27 15:36:12.353 codesign[576:507] There was an error parsing the Info.plist for the bundle at URL Contents/Info.plist -- file:///Applications/Utilities/Boot%20Camp%20Assistant.app/
    The operation couldn’t be completed. (Cocoa error 3840.)
    <CFBasicHash 0x7fd502d00a30 [0x7fff79174f00]>{type = immutable dict, count = 2,
    entries =>
    0 : <CFString 0x7fff79157e00 [0x7fff79174f00]>{contents = "NSDebugDescription"} = <CFString 0x7fd502d01230 [0x7fff79174f00]>{contents = "Encountered unexpected character < on line 43 while looking for close tag"}
    1 : <CFString 0x7fff7915a3a0 [0x7fff79174f00]>{contents = "kCFPropertyListOldStyleParsingError"} = Error Domain=NSCocoaErrorDomain Code=3840 "The data couldn’t be read because it isn’t in the correct format." (Malformed data byte group at line 1; invalid hex) UserInfo=0x7fd502d009a0 {NSDebugDescription=Malformed data byte group at line 1; invalid hex}
    }
    /Applications/Utilities/Boot Camp Assistant.app/Contents/MacOS/Boot Camp Assistant: replacing existing signature"


    yes i downloaded and installed "Xcode"

    please help me!

    and sorry for my bad english
     
  7. jamesbwills macrumors newbie

    Joined:
    Apr 14, 2014
    #7
    Error at codesign step

    When I do sudo codesign -f -s – /Applications/Utilities/Boot\ Camp\ Assistant.app

    I get:
    –: no identity found

    And it doesn't work. Any help with this would be greatly appreciated! Everything I've seen online doesn't seem to help.
     
  8. part12studios macrumors newbie

    Joined:
    May 19, 2014
    #8
    need help with this big time!

    Ok so I've done this tutorial and everything looks right.. but it crashes. I've heard of other people experiencing this insta-crash but haven't seen a suggestion to address it.

    If i revert the the pinfo list it works again.. i have a 2011 macbook with superdrive removed (SSD in it's place).

    Model Identifier: MacBookPro8,3

    Boot ROM Version: MBP81.0047.B27


    I'm running the latest version of maverick and have the latest version of xcode (5.1.1)

    I'm simply adding these bits of information to the top of the array, not replacing the top lines..

    I hate to risk breaking something reinstalling the superdrive for this one tasks.. doing it the first time was tough enough..

    Thanks!
    Caleb
     
  9. jumaforce macrumors newbie

    Joined:
    Jul 13, 2014
    #9
    Worked great on my 2011 MBP, no issues! Thanks for the tutorial!
     
  10. buckthelaw macrumors newbie

    Joined:
    Jul 15, 2014
    #10
    Unfortunately, this isn't working for me. I did everything exactly like in the first post but now it seems like boot camp assistant won't start any more (the application keeps bouncing in the dock until I shut it down with force quit)

    My system is a Mac Pro 4,1 running Mavericks 10.9
    Hope someone can help me out.
     
  11. RahulRulz thread starter macrumors member

    RahulRulz

    Joined:
    Sep 18, 2013
    Location:
    London, UK
    #11
    It seems like you might have not re-signed the bootcamp.app after editing the file.
    I recommend you to redo every step and if it still not working message me I will do it for you using TeamViewer.
     
  12. nim6us macrumors member

    nim6us

    Joined:
    Nov 20, 2012
    #12
    I've got a MBP 13" Late 2011 running Mavericks 10.9.4 and followed the steps worked like a charm!

    The only caveat was I installed XCode before I started the process. Once it installed I opened XCode and it had me agree to the terms and authenticate. So when I went through the steps and I ran the last line:
    Code:
    sudo codesign -f -s - /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/MacOS/Boot\ Camp\ Assistant
    It didn't ask me to do the ToS procedure, as I'm guessing it was already done.

    Either way, I was feeling very frustrated before I found this thread, so thank you OP for the assist!

    TAGS:
    boot camp no option to create windows install Mavericks
    boot camp install windows from ISO Mavericks
     
  13. ccs224 macrumors newbie

    Joined:
    Aug 26, 2014
    #13
    This worked great for me, in terms of getting the USB to be created, but once that is done I get a message saying "The installer disc could not be found. Insert your Windows installer disc and wait a few seconds for the disc to be recognized."

    USB is in, I've redone it a few times, nothing seems to work and I can't find any further info online. Any ideas?
     
  14. shinzupml macrumors newbie

    Joined:
    Aug 29, 2014
    #14
    hi

    i m facing an error, every step i foolow as u said, but when i enter the last command to resign, it gives error i installed xcode as well, when i open bootcamp it crashes :(
    kindly help me out
     
  15. malware1 macrumors newbie

    Joined:
    Aug 28, 2014
    #15
    Try this: http://forums.macrumors.com/showthread.php?t=1769650
     
  16. Sir-cookie macrumors newbie

    Joined:
    Sep 9, 2014
    #16
    Anyone had this problem? Or anyone knows a possible solution?

    Kevins-MacBook-Pro:~ kevin$ sudo codesign -f -s - /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/MacOS/Boot\ Camp\ Assistant
    /Applications/Utilities/Boot Camp Assistant.app/Contents/MacOS/Boot Camp Assistant: replacing existing signature
    /Applications/Utilities/Boot Camp Assistant.app/Contents/MacOS/Boot Camp Assistant: object file format unrecognized, invalid, or unsuitable
     
  17. acarr620 macrumors newbie

    Joined:
    Sep 10, 2014
    #17
    7 hours plus now..

    I am running into all sorts of issues. Please help..when running sudo command it is telling me no identity found. I know the command has been typed correctly.
     
  18. acarr620 macrumors newbie

    Joined:
    Sep 10, 2014
    #18
    so figured this out, there is a space between '-' and '/Applications' in the command line. hard to tell that. hope that helps someone else!:)
     
  19. jloveland87, Oct 8, 2014
    Last edited: Oct 8, 2014

    jloveland87 macrumors newbie

    Joined:
    Oct 8, 2014
    #19
    I am having issues with this as well. Every time I try to run boot camp after doing the steps above, I get an error message ("Bootcamp quit unexpectedly"). I reverted back to the original and boot camp worked fine again. I reworked all of the steps, went to save it in terminal, and hit control+c by accident (didn't notice a change in anything, not sure if it changed anything) instead of control+x, but I saved anyway. I still had an error. So I reverted again, but this time, I have the error message with boot camp every time.

    Is there a way to restore this file? I have restored what I changed, but it isn't working at all now.

    Have I screwed myself here?
     
  20. acarr620 macrumors newbie

    Joined:
    Sep 10, 2014
  21. jloveland87 macrumors newbie

    Joined:
    Oct 8, 2014
    #21
    Everything seems to execute fine except step 6. This is what it says every time I try step 6:

    Jeremys-MacBook-Pro:~ macbookpro$ sudo codesign -f -s - /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/MacOS/Boot\ Camp\ Assistant
    Password:
    /Applications/Utilities/Boot Camp Assistant.app/Contents/MacOS/Boot Camp Assistant: replacing existing signature
    /Applications/Utilities/Boot Camp Assistant.app/Contents/MacOS/Boot Camp Assistant: code object is not signed at all
    In subcomponent: /Applications/Utilities/Boot Camp Assistant.app/Contents/Info.plist.save
    Jeremys-MacBook-Pro:~ macbookpro$

    The other steps seemed to execute, though boot camp would crash every time I tried to open it, even now after reverting. I'm hoping there is a solution so I don't have to reboot my whole computer. Is there an option just to restore system default, which would include the boot camp plist?
     
  22. ti toaster macrumors newbie

    Joined:
    Oct 11, 2014
    #22
    Sort of worked...

    So I tried your remedy, and in fact it worked awesome all the way to re-booting from Boot Camp....and then I get a black windows screen that says "No boot disk found. Insert bootable disk and hit any key"..... which I happen to have, but I only have an external DVD drive, so it never sees it, and I can never install Windows 7.

    Would you have a fix for this?
    I have a Early 2011 MBP,
    Removed the dvd drive and installed an SSD and use an external DVD drive.

    Really need to get Windows working on this laptop.

    Thanks for the great post and tutorial. Hope you can help.

    ----------

    Just noticed you had the same issue....
    Did you ever fix it? Find a solution?

    Thanks

     
  23. macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #23
    Can it be that if I remove the Superdrive the MacBooK Pro 7.1 also wil boot Windows ( Setup / PE ) from USB then ?

    Currently it boots Windows Installation / PE rescue environments from the Superdrive only. However, it can boot Linux Live environments from USB.
     
  24. heber85hsr macrumors newbie

    Joined:
    Oct 20, 2014
    #24
    Thanks

    Worked fine on a macbook pro with yosemite
    you are the man :)
     
  25. AmbientChaos macrumors member

    AmbientChaos

    Joined:
    Feb 11, 2014
    #25
    IIRC on my Mid-2010 MBP most non-OSX (e.g. Windows installer) USBs don't show up on boot. Removing the drive means you can't install windows. My workaround was to re-insert the superdrive if you've removed it, and install a temporary windows, Vista or higher, via DVD. Then follow these instructions to add a bootloader extender type thing that adds a mini OS that is installed alongside Windows and lets you boot from USBs

    http://www.intowindows.com/how-to-b...n-if-your-pc-doesnt-support-booting-from-usb/
     

Share This Page