TV Shows not grouping by season in iTunes

Discussion in 'Mac Apps and Mac App Store' started by Greg_C, Jan 17, 2008.

  1. Greg_C macrumors member

    Joined:
    Mar 18, 2005
    Location:
    USA
    #1
    I just began adding some episodes of House MD to my iTunes library that I ripped from the Season 1 DVD's I got for Christmas. My only problem is that despite being tagged properly (to the best of my knowledge), they are all showing up as separate shows in iTunes rather than being all grouped into House MD Season 1. I like to keep things organized in iTunes so this is starting to irritate me.

    Here's what I'm seeing:
    [​IMG]

    Instead of something like this (screenshot taken from an iLounge.com article):
    [​IMG]

    I've gone through and tagged all the episodes as being TV Shows, with the Show as House MD and Season 1; everything matches as far as I can tell, so I'm not sure why iTunes isn't grouping them together. FYI I'm running iTunes 7.6 on Leopard. Any ideas/tips are appreciated...Thanks!
     
  2. kkachurak macrumors regular

    Joined:
    Jun 26, 2007
    Location:
    Orlando, FL
    #2
  3. MajereXYU macrumors regular

    Joined:
    May 11, 2005
    #3
    First of all: how are you tagging your files?

    If by tagging them, you mean opening get info in iTunes and changing the fields, you may want to resort to a more powerful solution.

    I suggest MetaX, which is free, powerful and allows you to tag any .mp4 file with great ease.

    I recommend to watch their video tutorial because at first, the interface may not be as intuitive as it should be.

    If you have further questions, feel free to ask!

    Since I've discovered MetaX and VisualHub, I converted every and all video file on my computer to .mp4 in order to import it into iTunes and watch them on my HDTV in Frontrow.
    Best part is, you don't even have to copy the files over to your iTunes library, thus not filling up your main drive. I have all mine stored in a 500GB external USB 2.0 drive.
     
  4. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #4
    I'm seeing the same problem, tagging the files as I have been doing all along. It looks like they changed something (bug?) that is causing shows to split on seasons. I should say that I do not see this issue with all of my TV shows, just ones that I have added to since upgrading to 7.6.
     
  5. kkachurak macrumors regular

    Joined:
    Jun 26, 2007
    Location:
    Orlando, FL
    #5
    Yes, this is definitely not a tagging problem. Before 7.6, everything was fine. Now, there is suddenly this issue that myself and the above users are having and no one has changed anything except for the version of iTunes.

    It's got to be a bug.
     
  6. pedz macrumors regular

    Joined:
    Jul 2, 2007
    #6
    I think they changed the way they group shows. Before the software update all of my shows (e.g. Arrested Development) were in one group with one image shown (using the middle display option of the three). Now they are split by season, so I have 3 groups now, one for each of the three seasons. But for all shows within a season they are grouped correctly. I actually like the change, makes it much more readable.

    I use atomicparsley for the pc to tag because certain tags are not available in iTunes and some don't stick. For example, if you set something as a TV Show in iTunes, then remove it and add it to your library it doesn't retain that tag. If I set the --stik parameter to 'TV Show' in atomicparsley then the change is permanent.

    Maybe there is an issue when tagging through iTunes? Not sure though since I always tag tv shows through atomicparsley.

    Peter
     
  7. kkachurak macrumors regular

    Joined:
    Jun 26, 2007
    Location:
    Orlando, FL
    #7
    Nope.

    For me, iTunes 7.6 is separating the pilot episodes from the rest of the episodes in the same season.

    Even if they made the change to separate shows by season, this problem falls outside of that change.

    This is especially true for the individual that started this thread. He has multiple episodes in the same season that are all being grouped separately, episode by episode.
     
  8. Greg_C thread starter macrumors member

    Joined:
    Mar 18, 2005
    Location:
    USA
    #8
    Problem Solved

    I managed to get everything working correctly using MetaX, per MajereXYU's recommendation. I first deleted the three episodes I already had in iTunes from my library, then tagged them on my external drive using MetaX. When I imported them into iTunes they all grouped correctly under Season 1, including the Pilot episode which some people seem to be having trouble with. Not sure exactly how or why it worked, but I'm glad it did. Thanks to MajereXYU for the helpful link. My only remaining issue is that they aren't sorted in any real order on my iPod Classic. Not nearly as frustrating though. Hopefully this might be of some help to anyone having similar troubles.

    Edit: Screenshot added

    :cool:
    [​IMG]
     
  9. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #9
    That's just it; I use MetaX exclusively and am still seeing this where I didn't before the 7.6 upgrade. Not a huge issue by any means, but a minor annoyance.
     
  10. stevearm macrumors 6502a

    Joined:
    Nov 15, 2007
    #10
    I'm assuming Apple will fix this? Got the same problem here ever since I updated iTunes
     
  11. kkachurak macrumors regular

    Joined:
    Jun 26, 2007
    Location:
    Orlando, FL
    #11
    I also use MetaX, but typically just for movies that I rip w/ HandBrake.

    I'm seeing this issue with TV shows I solely purchased from the iTMS. Purchased files have always been tagged correctly from the get-go and have never exhibited this issue before 7.6
     
  12. ibradly macrumors newbie

    Joined:
    Dec 21, 2007
    Location:
    Phoenix, AZ, USA
    #12
    Another "me too" post. Something with the iTunes 7.6 update made the TV Shows display all funky. It's happening with both iTS purchased shows and handbraked shows. I've submitted feedback to Apple over at apple.com/feedback

    [​IMG]
     
  13. stevearm macrumors 6502a

    Joined:
    Nov 15, 2007
    #13
    Ok this is getting ridiculous. The TV Shows view is now a complete mess with all the shows being grouped by seasons and repeated album artwork for each.

    Is this a bug?? Or did some stupid moron at Apple think this was an improvement?
     
  14. stevearm macrumors 6502a

    Joined:
    Nov 15, 2007
    #14
    Anyone?
     
  15. Shoesy macrumors 6502a

    Shoesy

    Joined:
    Jun 21, 2007
    Location:
    Colchester, UK.
    #15
    I've found the trouble usually lies in mismatched fields, I have scratched my head over this a couple of times and have found the only answer was to add a space charachter as the entry for 'album artist' :confused:.

    I guess the real answer is to make sure everything matches up correctly, but finding what is at fault is a difficult task.
     
  16. Shoesy macrumors 6502a

    Shoesy

    Joined:
    Jun 21, 2007
    Location:
    Colchester, UK.
    #16
    you guys do realise that itunes now groups each show by season?

    Just checking...
     
  17. stevearm macrumors 6502a

    Joined:
    Nov 15, 2007
    #17
    What do you think this whole topic is about?
     
  18. Zillatron macrumors member

    Joined:
    Dec 1, 2004
    #18
    Has anyone managed to find an answer for this?
    Is it a bug or just a really annoying change?

    I can't seem to find an answer either way...or how to make it go back to the way it was:confused:

    Z
     
  19. cmonster macrumors member

    Joined:
    Mar 23, 2007
    #19
    Has any figured out this problem. MetaX only works on Mac.
     
  20. cmonster macrumors member

    Joined:
    Mar 23, 2007
    #20
    I figured mine out. Some of the artist field's had names in it. I made them all blank and changed them to the correct season and it worked. Maybe try removing all the tags and add them back one at a time.

    Hope this helps
    Cmonster
     
  21. mjrainwater macrumors newbie

    Joined:
    Feb 3, 2008
    #21
    I found a solution

    I had this exact problem. I read all of the posts, and then tried several things on my own. I found a combination that I am able to repeat, so I believe it is the answer.

    1) First, I edited the "Season" tag in all of my shows individually so they were all the same. This broke things up horribly and the groups were not correct.
    2) Next, I selected all the shows in iTunes in the season. I edited the tags by selecting "Get Info".
    3) Then, I simply edited the Artist, Album Artist, and Album to all match. Note that if all three of these already match, then edit the album artist to blank.
    4) You may need to repeat step 3 if you made the album artist blank.

    Whenever you edit these tags, iTunes will examine the episodes and again. When it does, it will group then correctly.

    Looks like an iTunes defect to me. But this is at least an easy work-around.

    Now, I think I'll try that external tag editor before I import my next batch into iTunes. Thanks for the discussion!
     
  22. peeaanuut macrumors 65816

    Joined:
    Sep 10, 2007
    Location:
    Southern California
    #22
    iTunes is quite picky when it comes to tagging. YOu need to make sure that your caps and spaces are exactly correct for them it to sort correctly. After I spent some times making sure that was correct they come out nicely now.
     
  23. Snuff925 macrumors newbie

    Joined:
    Feb 4, 2008
    #23
    Be careful with your Show Name

    After mucking about with this for awhile I believe that I finally figured this out and how to get it working 'correctly' without using a 3rd party software. I will say up front that I believe this to be a bug though, but there I think I have a workaround.

    It appears that the 'correct', or at least the intended way to group shows is per the Video tab on the info of the file. The grouping occurs based upon the 'Show' field, and the 'Season Number'. While it visually may look like the 'Show' is correct, I found that you must manually populate the field in order to have it sort correctly.

    I use a Miglia and eyeTV to DVR my TV Shows. Most of the time the sorting works just fine, as eyeTV populates the necessary field based on the information it gets from TitanTV. But I have bought some shows from iTunes (that my recording schedule missed), and I have some shows that are much older.

    I noticed the problem occurring as I was updating my episode ID and season numbers of some older stuff and the sorting didn't work right. (I think I'm rambling now...)

    Okay... THE "FIX"...
    Select info on a single show episode
    Go to the 'Video' tab
    Clear the 'Show' field
    Type, NOT paste, the name of the show. (The name should start coming up as you type. You can accept the show once it autopopulates, but do NOT paste.)
    Click 'Ok', 'Next', or 'Previous' and repeat as needed.

    (If the above does not work, clear the show field, click ok, then go back and add it in.)

    You should find your shows sorting correctly by show/season.

    I call this a bug, because you have to manually enter the show name, despite them appearing the same.

    -darryl
     
  24. wwooden macrumors 68000

    wwooden

    Joined:
    Jul 26, 2004
    Location:
    Burlington, VT
    #24
    I personally don't like how iTunes now separates a show by the seasons, I liked how everything was under one image. I now have to scroll a lot farther to get down the list. Some show I only have one episode of a season so there is a whole extra section just for that one episode. I hope they add the option to have them all under one image again in an iTunes update.
     
  25. ascender macrumors 68000

    Joined:
    Dec 8, 2005
    #25
    I've got this annoying bug too, but double checking the tags and re-entering the fields manually doesn't seem to fix the problem.

    Very annoying....
     

Share This Page