TvOS 11.4 has broken my airplay set up

Discussion in 'Apple TV and Home Theater' started by Seamusphillips, Jun 11, 2018.

Tags:
  1. Seamusphillips macrumors newbie

    Joined:
    Jun 11, 2018
    #1
    My TV and airplay set up has been broken by the last update can anyone help?

    I have an Apple TV which plays audio via an Airport Express to my stereo. This has always worked fine however I choose to get content on the TV.

    Since the update however I can no longer stream from an iPad or iPhone with audio. When I try the airplay speakers are deselected, and whenever I reselect using the remote it stops the video stream.

    Have tried a lot of different ways and can’t seem to work it out. Looks to be a bug. Any ideas?

    Thanks!
     
  2. mpainesyd macrumors 6502

    mpainesyd

    Joined:
    Nov 29, 2008
    Location:
    Sydney, Australia
    #2
    Search for Airplay2 and Airport Express on this forum. I think you will find it is no longer a supported device.
     
  3. Seamusphillips thread starter macrumors newbie

    Joined:
    Jun 11, 2018
    #3
    Thanks. I knew that airplay 2 wasn’t going to work with the AX but I thought that airplay 1 features would still work after the update!

    This really sucks, guess I need to figure out how to downgrade the AppleTV... or get a second AppleTV and audio extractor...

    While lamenting the AX being discontinued I thought I was lucky to have several already and a set up that works. I did not think they would stop working so soon, only a matter of time until Airplay 1 is completely dead I guess.
     
  4. Reverend Benny macrumors member

    Reverend Benny

    Joined:
    Apr 28, 2017
    Location:
    Europe
    #4
    Hold on a second now...I might have got this completely wrong but as far as I have read Airplay 1 devices will still continue to work but won't benefit from the new added Airplay 2 functionality such as multi room.
    tvOS 11.4 has just been released and 11.4.1 is around the corner.
    Since most articles point to that Airplay 1 devices still will work my guess is that this will be fixed.

    Can you still stream things from your 11.4 iPhone straight to the AX?
     
  5. Seamusphillips thread starter macrumors newbie

    Joined:
    Jun 11, 2018
    #5
    Yes, I can stream to AX from iOS or tvOS fine. Just the combination that fails. I am guessing that it’s related to the way Airplay 2 handles multiple feeds/streams. Fingers crossed re next update, will report back. In the mean time better submit the bug/feedback.

    Keen to know if anyone else is having the issue, or found a workaround. Can’t be the only one using aTV and AX together!
     
  6. macrumoursnerd macrumors newbie

    macrumoursnerd

    Joined:
    Jun 16, 2018
    #6
    literally just posted this on reddit. might be something related.

    So I use a very nifty tool called AirConnect on a RP for streaming audio to my "old" Sonos One which has not been updated to get AirPlay 2. Anyway, everything used to work more or less seamlessly (if not for the eventual hiccup inherent to AirPlay 1 itself) before iOS 11.4.
    Now my iPhone SE and 6 won't even detect the Sonos One when laughing the AirPlay sheet. I wonder if the upgrade and addition of AirPlay 2 broke something. What's even stranger is that I can still use AirConnect on my Mac running the latest High Sierra stable build. You mentioned you can still stream from iOS. Strangely enough I can from my MacBook Pro 2015 but not from the iPhones.
     
  7. chabig, Jun 16, 2018
    Last edited: Jun 16, 2018

    chabig macrumors 603

    Joined:
    Sep 6, 2002
    #7
    It makes sense to me. When you tell the iPad to stream video to your AppleTV it chooses airplay 2 because both devices are capable. That disables your Airplay to the Airport Express. If you tell the iPad to stream audio to your Airport Express, it chooses the AirPlay protocol which turns off AirPlay 2.

    I think you should just run a wire from your TV audio out to your stereo.
     
  8. Seamusphillips thread starter macrumors newbie

    Joined:
    Jun 11, 2018
    #8
    Thanks, that makes some sense. I have been in touch with Apple Support about this and they have taken logs etc. will see what comes of it.
    Running a wire isn’t so easy with ATV without audio jack, need to get myself an extractor...
     
  9. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #9
    The wire should run from your TV audio out to the stereo's audio in.
     
  10. Seamusphillips thread starter macrumors newbie

    Joined:
    Jun 11, 2018
    #10
    Unfortunately not so simple, as I don’t have a TV with audio out. I am pretty sure I need additional hardware to make this work, or an update/downgrade of software to fix the ‘bug’.

    I accept that my set up (and limited options of simple work arounds) is unusual, but I do think in basic terms it should work as before. Will give an update when I hear back from Apple.
     
  11. kungLao macrumors newbie

    Joined:
    Jun 21, 2018
    #11
    I have the exact same issue as the OP and it's super annoying. Please do give us an update if they get back to you.
     
  12. Seamusphillips thread starter macrumors newbie

    Joined:
    Jun 11, 2018
    #12
    Apple got back to me.

    The Enginnering department are aware of the issue and it is ‘expected behaviour’ at the moment, however they do intend to improve backward compatibility to Airplay 1 as best they can in future updates. There is no timeline on this though.

    They could not assist with downgrading tvOS. I was advised to find a hardware workaround...

    If you are experiencing the issue then please submit feedback to help this get up the priority list. https://www.apple.com/feedback/
     
  13. Seamusphillips thread starter macrumors newbie

    Joined:
    Jun 11, 2018
    #13
    The AE AirPlay 2 update seemed hopeful, but having tested, it still doesn’t work pretty much same behaviour.

    I can now stream to both ATV and AE at same time, but only audio (it cuts the video).

    Anyone else tried it, or found a new work around?
     

Share This Page