Unable to delete a particular file

Discussion in 'Mac Basics and Help' started by bobhammer, Jan 21, 2008.

  1. bobhammer macrumors member

    bobhammer

    Joined:
    Dec 13, 2007
    Location:
    Hong Kong
    #1
    Any idea...?? I couldnt delete it using any method[​IMG]
     
  2. flyinmac macrumors 68030

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #2
    Try going to the Finder menu and choosing Secure Empty Trash.

    But, be sure that the file is unimportant first.

    If that doesn't work, I don't know. But, Secure Empty has always worked on the ones that I couldn't remove before.
     
  3. hotrodsinner macrumors newbie

    Joined:
    Jan 18, 2008
    #3
    I have the same problem except I have two files that seem to be corrupt and still haven't found a way to get rid of them, The thread that I started may be of some use.

    http://forums.macrumors.com/showthread.php?t=417485

    I've tried secure delete, didn't work
    I've tried OnyX, didn't work
    I've tried repairing disk permissions, didn't work
    Dragging the file out of the Trash, the file just disappears but does get removed from the Trash until you back into the Trash window and its returned.
    Get Info on the file has the same results as dragging, file just disappears then reappears when you go back into the Trash.

    Hope this helps, I'm still trying to fix it
     
  4. Mernak macrumors 6502

    Joined:
    Apr 9, 2006
    Location:
    Kirkland, WA
    #4
    try
    Code:
    rm -rf [drag file you want to delete here, make sure to have a space before you drag]
    however you only want to do this if you are sure to delete something.

    note: be careful with this
     
  5. bobhammer thread starter macrumors member

    bobhammer

    Joined:
    Dec 13, 2007
    Location:
    Hong Kong
    #5
    My situation is same as yours on every aspect!!!!! What else can I do? the file is created on 1904 WTF....is this a virus?
     
  6. hotrodsinner macrumors newbie

    Joined:
    Jan 18, 2008
    #6
    I'm still unable to fix the problem and I've even resorted to a re-install which still didn't get rid of the problem, Although I did do a achieve and install not a complete fresh install which might have different results. I would like to do a fresh install but I don't have the back up capacity for all my files but I would hope it wouldn't have to come to this sort of extreme. There must be some type of solution for this and I doubt its any sort of virus if it is its not doing anything except making the trash bin full.
     
  7. r88my macrumors regular

    Joined:
    Oct 28, 2007
    Location:
    Manchester UK
    #7
    Could you drag the file(s) to a USB thumb drive and try trashing it on a different mac or windows pc? Just a thought.
     
  8. zxcvBorg macrumors newbie

    Joined:
    Feb 18, 2008
    #8
    Similar problem

    I have a similar problem.

    I have an alias on a fat32 formatted external drive that I can't delete. The file name has japanese encoded characters. Sometimes it will disappear when clicked on, but it always comes back.

    I tried to "rm -rf theContainingFolder" but it failed. I get "Directory not empty". Variations on that theme produce similar results. "rm *" tells me "No such file or directory".

    Even "ls -l" inside the directory gives me "No such file or directory" at both the alias and a duplicate "._" prefixed file which I think is a data or resource fork or something.

    Renaming the file in the finder gives me an error -43 "file not found", and the "mv" command also gives "No such file or directory". I'm starting to notice a pattern here...

    Of course the trash can doesn't work. And unfortunately disk repair utility reports no problems. Command-i on the file opens but immediately closes too fast for me to see. Strangely enough, Quicklook will actually show the alias' file name.

    The file has zero size, but still it's bugging the hell out of me. I am eager to hear any report of success in removing these gremlins.



    EDIT:

    No solution, but we are not alone...
    http://garybernhardt.blogspot.com/2007/09/undeletable-zombie-files-on-os-x.html


    EDIT 2:
    fsck does NOT fix it! In my case it was fsck_msdos, maybe your HFS+ drives will be different.
     
  9. Quint macrumors member

    Joined:
    Feb 4, 2008
    #9
    I read this hint in a magazine a while back that may work for some of these problems. It said to create a new user account. Move untrashable file into that new user's folder. From original account, delete the new user. Select delete immediately. The new user's folder and anything in it should be permanently deleted.
     
  10. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #10
    The brute force method: Borrow an external hard drive, backup using Time Machine, then start using the Leopard disk and restore.
     
  11. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #11
    I have two thoughts.

    1) its a file used by a running application that will simply recreate it when its deleted, giving the illusion it doesn't delete.

    2) The file name might be causing an issue, I'd suggest trying to rename the file first to something a bit more normal, like deleteme and then empty the trash.
     
  12. bobhammer thread starter macrumors member

    bobhammer

    Joined:
    Dec 13, 2007
    Location:
    Hong Kong
    #12
    everything back to normal, I was deleting some files like music and photos, after I emptied the trash, everything gone...back to normal!!
     
  13. robarpa macrumors newbie

    Joined:
    Mar 25, 2008
    #13
    I think I figured out.

    I was trying many different methods to get rid of 3 of these files. So I was searching the internet and found different sites that said I needed to use some commands in terminal and drag and drop the items.

    I also read a post that said it had something to do with files on a windows partition, I just don't have one.

    So I tried a terminal command and dragging and droping the file into the terminal window. It didn't work.

    However I noticed that the path of my particular files had something to do with my ipod. I launched Itunes, and apparently 3 songs I recently purchased hadn't made their way to my ipod or vice versa. Itunes took care of the problem for me.

    If someone else has a similar issue, I would try to drag and drop the icons into the terminal window just to get a path to the original file that the alias is associated with. This should help you get rid of the original file or deal with appropriately to empty out the trash.
     
  14. Druel macrumors newbie

    Joined:
    Jan 19, 2012
    #14
    Delete issues

    I am hoping someone can help with this...

    I am on an iMac running Mac OSx 10.6.6

    I have a 1 TB external HDD, on which I have two .part files which I cannot delete. When I send them to Trash, they disappear and reappear a second later. I use Transmission to download, but I've ensured all programs are closed and tried reboots, etc. Also tried renaming. Cannot delete from the Mac.

    I tried plugging the HDD into my Windows 7 Starter netbook, and when I tried to delete the files I was given Error 0x80070570.

    I do not want to format the drive as it has 792 GB filled, which would be a big pain to backup, so if anyone has another suggestion, I would be grateful.

    I should mention that I am somewhat new to Macs, have been a PC user all my life and so consider me a noob.

    -CanaDan
     
  15. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #15
    In the Transmission download list, did you right-click on those downloads and select "Remove Data File"?

    First, restart your computer. Then follow these instructions:
    You can't empty the Trash or move a file to the Trash
    Solving Trash Problems
    Can't move files to trash
     
  16. Druel macrumors newbie

    Joined:
    Jan 19, 2012
    #16
    First of all, when I downloaded this file, I had stopped the download before finishing and downloaded a different version of this same file. This was quite some time ago (I've been out of the country for the past year) so I cannot remember how I deleted it from Transmission, but in any case it is no longer in my list of torrents.

    I've restarted the computer, and upon logging in with Administrator account, opened this page and nothing else.

    When attempting to delete, the file reappears and does not go into the Trash.

    When renaming, I get this error: The operation can’t be completed. An unexpected error occurred (error code -36).

    When I try to move the file, I get: The Finder can’t complete the operation because some data in “<filename>.avi.part” can’t be read or written.
    (Error code -36)

    So it does not appear to be locked as I would get error code -1 ?

    As far as the "Can't move files to Trash" help page, I have no other troubles with any other files, only this particular .part file...

    *sigh*
     

Share This Page