Underallocation Detected on Main device (10.13 PB4)

yaroslavm

macrumors newbie
Original poster
Jun 19, 2016
7
1
Hey guys,

There is a lot of APFS erroneous-free-space talk on these forums, wonder if that is something that is related.

Just moved from a 10.12 HFS+ install to a 10.13 PB4 APFS one. When running Disk Utility—both via Rescue mode and live mode—this is what I get:

/dev/rdisk1s1: ** Checking volume.
/dev/rdisk1s1: ** Checking the container superblock.
/dev/rdisk1s1: ** Checking the EFI jumpstart record.
/dev/rdisk1s1: ** Checking the space manager.
/dev/rdisk1s1: ** Checking the object map.
/dev/rdisk1s1: ** Checking the APFS volume superblock.
/dev/rdisk1s1: ** Checking the object map.
/dev/rdisk1s1: ** Checking the fsroot tree.
/dev/rdisk1s1: ** Checking the snapshot metadata tree.
/dev/rdisk1s1: ** Checking the extent ref tree.
/dev/rdisk1s1: ** Checking the snapshots.
/dev/rdisk1s1: ** Verifying allocated space.
/dev/rdisk1s1: error: Underallocation Detected on Main device: (28794938+1) bitmap address (31111)
/dev/rdisk1s1: Space Verification failed.
/dev/rdisk1s1: ** The volume /dev/rdisk1s1 could not be verified completely.


1. Does anyone else get this?
2. Do you think it may be related to the problems a lot of people were having with the free space not being returned, etc.?

Already reported to Apple, but I wonder if that is something everyone is seeing.
 

Erdbeertorte

Suspended
May 20, 2015
1,180
500
I just tried this in live mode on my boot volume with DB6 and the MacBook froze completely. :oops:

Had to do a force shut down by holding the power button.
 

Erdbeertorte

Suspended
May 20, 2015
1,180
500
That's okay, for some reason fsck_apfs takes around 10x the time compared to fsck_hfs, just wait it out.
In know everything is slowing down very much while doing this. But this time everything besides the power button got unresponsive.
[doublepost=1502798349][/doublepost]I tried it again with all external drives removed and waited about 10 minutes. It always freezes at "Checking the fsroot tree.".

From Recovery that didn't happen but I got a strange "Warning.... BSD whatever error" and several of those with the same text after "Checking the snapshots." and "Verifying allocated space.".

I waited again some minutes but nothing happened after the last warning. At least it didn't freeze and I was able to restart normally.

Seems something got messed up in my file system or it's a bug in the new beta. Also I have a BOOTCAMP partition on the same drive.

But I never noticed any problem with my Mac and Boot Camp also works.
 

yaroslavm

macrumors newbie
Original poster
Jun 19, 2016
7
1
Hm, was fixed for me. Can you try a Rescue mode Disk Check?

In any case, try to report the bug, I guess.
 

andrewkendall

macrumors member
Apr 30, 2005
49
0
Hm, was fixed for me. Can you try a Rescue mode Disk Check?

In any case, try to report the bug, I guess.
Thank you. Yep, tried rescue mode. No luck.

Have reported to Apple. Wanted to open this thread back up to see if anyone else was also having the issue after the GM as it seems to be one of the only places discussing this error.

I'm expecting to have to reinstall once the final GM is out as this GM candidate is still labelled beta, we'll see if the final release on the 25th makes any difference.
 

robokop

macrumors newbie
Sep 25, 2017
2
0
Hey guys,

There is a lot of APFS erroneous-free-space talk on these forums, wonder if that is something that is related.

Just moved from a 10.12 HFS+ install to a 10.13 PB4 APFS one. When running Disk Utility—both via Rescue mode and live mode—this is what I get:

/dev/rdisk1s1: ** Checking volume.
/dev/rdisk1s1: ** Checking the container superblock.
/dev/rdisk1s1: ** Checking the EFI jumpstart record.
/dev/rdisk1s1: ** Checking the space manager.
/dev/rdisk1s1: ** Checking the object map.
/dev/rdisk1s1: ** Checking the APFS volume superblock.
/dev/rdisk1s1: ** Checking the object map.
/dev/rdisk1s1: ** Checking the fsroot tree.
/dev/rdisk1s1: ** Checking the snapshot metadata tree.
/dev/rdisk1s1: ** Checking the extent ref tree.
/dev/rdisk1s1: ** Checking the snapshots.
/dev/rdisk1s1: ** Verifying allocated space.
/dev/rdisk1s1: error: Underallocation Detected on Main device: (28794938+1) bitmap address (31111)
/dev/rdisk1s1: Space Verification failed.
/dev/rdisk1s1: ** The volume /dev/rdisk1s1 could not be verified completely.


1. Does anyone else get this?
2. Do you think it may be related to the problems a lot of people were having with the free space not being returned, etc.?

Already reported to Apple, but I wonder if that is something everyone is seeing.
[doublepost=1506390550][/doublepost]I upgraded from 10.12 to 10.13 today. After that completed I decided to try and convert my external drive from hfs to apfs. The attempt failed and I got the same errors. I don't know the cause but I have been running first aid and with that the volume mounts and files are available but a reboot causes the volume to not mount again and I have to run first aid again. I will try rerunning that to see if it clears up
 

robokop

macrumors newbie
Sep 25, 2017
2
0
[doublepost=1506390550][/doublepost]I upgraded from 10.12 to 10.13 today. After that completed I decided to try and convert my external drive from hfs to apfs. The attempt failed and I got the same errors. I don't know the cause but I have been running first aid and with that the volume mounts and files are available but a reboot causes the volume to not mount again and I have to run first aid again. I will try rerunning that to see if it clears up
Now I found out the Time Machine cannot use the APFS. So the attempt to reconfigure my external device was in vein. I have since reformatted the device back to HFS+
 

wmertens

macrumors newbie
Apr 4, 2017
2
0
I have the same issue on the release candidate. I'd like to not worry about it, because it was returning error code 0, but then freshly downloaded files were not showing up in finder. Only after rebooting did they show up. Grrr.

I tried doing first aid from recovery mode but that had the same result.
[doublepost=1506510444][/doublepost]
freshly downloaded files were not showing up in finder.
Turns out that after you run First Aid live, Finder is unhappy. Just restarting Finder seems to fix it.
 

andrewkendall

macrumors member
Apr 30, 2005
49
0
Turns out that after you run First Aid live, Finder is unhappy. Just restarting Finder seems to fix it.
I saw exactly the same thing with Finder after running First Aid. It happens even if you don't have the 'Underallocation Detected on Main device' error. I've been rebooting all machines after I run First Aid just to make sure, had me worried for a moment.

I couldn't find a fix for the 'Underallocation Detected on Main device' error so I ended up making a Time Machine backup, erasing the Macintosh HD and then restoring. No more errors with the drive now and it's benchmarking faster too, so seems worth the effort.
 
Last edited:

schrepfler

macrumors newbie
Sep 27, 2017
1
0
Gibraltar
I’ve bumped at a similar situation during install of final release of High Sierra. Left the computer for a whole day to install, was hanging with the Apple sign. Rebooted it and it now won’t start. When entering Restore mode and diskutil this is what I get back when I try the first aid utility:
What’s left? Fsck is not very helpful
 

Attachments

what on earth

macrumors newbie
Feb 22, 2018
1
0
West Yorkshire
I can add... I too noticed the underallocation error after FMP started crashing and I ran disk first aid. Did a wipe and reinstall and although it still indicated an underallocation error everything seemed a lot slicker... until FMP fell over. Could the underallocation and FMP be related, as I have my suspicions that the FMP could be related to dodgy pdf files.

Incidently I can now add as I have been told by someone instore, that the problem isn't so much with the OS but with the First Aid Disk Utility and APFS formatted disks... does that make sense, does to me.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.