Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

MacRumors

macrumors bot
Original poster
Apr 12, 2001
54,699
16,886


Universal Control, one of the main new features that Apple highlighted for macOS Monterey back in June, has yet to be implemented even in the tenth beta and it is still unclear if it will be available when the software launches.

universal-control-beta-label.jpg

Though not yet implemented, Universal Control settings can be force enabled with a feature flag, and it is clear that Apple is working on it behind the scenes. In the latest beta update released this morning, Universal Control settings that have been manually enabled have a "Beta" label.

The "Beta" labeling suggests that Apple could be planning to make the feature available to users when macOS Monterey launches, even if all the bugs have not been worked out. Apple did something similar for the iCloud+ Private Relay feature, which is also available in a beta capacity at the current time.

Universal Control, which is an iPadOS 15 and Monterey feature, is designed to allow multiple Macs and iPads to be operated the same time using the same input devices, so Mac and iPad owners can use a single mouse and keyboard across more than one Mac, more than one iPad, or a mix of Macs and iPads.

Article Link: Universal Control Remains Unavailable in macOS Monterey Beta 10, But Now Has 'Beta' Label
 

sdf

macrumors 6502
Jan 29, 2004
491
459
Since it's clearly not ready (even for testing), I wonder if Apple will hide the UI better now.
 
Last edited:
  • Wow
Reactions: Babygotfont

glindon

macrumors 6502
Jun 9, 2014
409
695
Phoenix
Outside of “weird“ safari, I can’t even think of any features added to MacOS that I care about or have even noticed were added and I‘ve been using Monterey as a daily driver since WWDC. This is the strangest release in quite some time. It has been very stable for me though so at least there’s that.
 

nt5672

macrumors 68020
Jun 30, 2007
2,399
5,143
I guessing that we are going to have to get in the habit of waiting a full year for all of the keynote functionality to be delivered. I'm surprised Cook does not announce the Apple car now, for delivery 2028. That way he gets on all of the magazine covers before he retires.
 

slydar

macrumors newbie
Sep 15, 2017
3
8
United Kingdom
Well, the executable files certainly exist for it, and Monterrey loads them at boot even without the "force enable" hack, so it looks like Universal Control interacts with the rest of the System at a pretty fundamental level.
UCont Apps.png
If you use Activity Monitor to force quit either of the running process, they are automatically relaunched.
UCont Processes.png

They seems to take up virtually no CPU resources or CPU Time.
 

chrisleeolson

macrumors newbie
Oct 13, 2021
1
5
It looks like UC won't work with a non apple external display? I'm running an LG Ultrafine 5K Display of an M1 Air and not seeing the advanced option even after clicking on display settings.
 

Attachments

  • Screen Shot 2021-10-13 at 15.43.49.png
    Screen Shot 2021-10-13 at 15.43.49.png
    582.2 KB · Views: 422

jinx.pt

macrumors newbie
Apr 8, 2014
18
6
It looks like UC won't work with a non apple external display? I'm running an LG Ultrafine 5K Display of an M1 Air and not seeing the advanced option even after clicking on display settings.
Ugh, I'm seeing the same thing. My iMac shows the advanced button, but my Macbook only shows it if I disconnect the two external monitors.

...I'm hoping this is still in the works in terms of UI, since we literally had nothing on the previous version of the Beta.
 

allenvanhellen

macrumors 6502
Dec 8, 2015
335
789
I'd really prefer that Apple just wait to announce and ship stuff until it's totally ready and (at least mostly) bug-free. I'm not paying to be a beta tester, and I'm definitely not paid either.
 

mistert1bbs

macrumors newbie
Sep 16, 2020
5
1
I am on the latest public beta and did a preferences search for Universal Control. It came up, I launched it, and it could see my 2nd Gen iPad Pro (running 15.0.1 at the time. Couldn’t see my new iPad mini though). It connected and launched Universal Control on the iPad. It realigned my displays (was running an LG 5k on USB-C) and I could move the mouse across them, but it threw an error when I tried to rearrange the displays. The Universal Control app stayed up on the iPad with a black screen.
 
  • Like
Reactions: roncron
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.