Updated nVidia 330m driver (270.61) - external display not working

Discussion in 'MacBook Pro' started by huythanhv2, May 26, 2011.

  1. huythanhv2 macrumors regular

    Joined:
    Apr 5, 2010
    #1
    Hi all,

    So I have just updated the nvidia driver in bootcamp for my MBP 2010, GT330M.

    The new version is 270.61 I got from nvidia website.

    The machine can still 'see' the external display and have option to duplicate display, display only on external, etc.

    But no matter what, the external will just not receive any signal.

    Anyone experience sth like this?

    PS: the screen is connected via mini displayport - dvi, it was working fine on the old driver
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    I guess you could simply revert the driver back to the old version?
     
  3. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #3
    was going to suggest this... if it ain't broke, don't fix it =D there are so many drivers for nvidia, use one that works for you. Update when you need to, which is something I've learned for both nvidia and AMD. If you're an avid gamer, sometimes this can be a hassle, but if you need/want best performance, then you should be used to updating and uninstalling drivers that work and others that simply break or do not work.

    I've been using stock 11.2 AMD drivers on my 2011 even with all the updates. 11.5 broke my OC and didn't let me play brink. etc etc so I reverted and have been on it since. Games run as well as I want them to so I'm not going to bother until something isn't working as how I want.
     
  4. Daytona 360 macrumors member

    Joined:
    Apr 29, 2010
    #4
    I have the same problem with my 15" 2010 MBP as well, sometimes you can get the display to recognize by rebooting, but I have decided that it's not worth the trouble and reverted back to 266.58.
     
  5. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #5
    Ditto here. I have a late 09' mbp with the 9600m chip. The latest nvidia driver (270.61) gives me the same issue with my external monitor. I uninstalled the latest driver and reverted back to my old one. It's a shame, we may have to wait until the next driver release. However, apple technically supplies nvidia driver updates in their bootcamp updates, but they're ALWAYS waaaay older than the latest you can get from the nvidia website. Let us know if you found a way around the non-functioning external monitor issue.
     
  6. treegirl macrumors newbie

    Joined:
    Apr 7, 2008
    #6
    How do I get old driver?

    Hi there,

    I am having the same problem with my macbook mid-2010. I am running Windows 7 in bootcamp. Could someone please tell me how to get the old driver? It is no longer on my computer and I don't know which driver I had before to get from Nvidia.

    Thanks!
     
  7. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #7
    my external display worked with the 270.61 I had other troubles though.
    Some time at night my MBP seemed to wakeup from sleep and showed a BSOD when I opened it up. I woke up and the fans ran full speed with this BSOD.
    The only thing that could cause it is the 270.61. 275.33 is out and I installed. I haven't checked if the problem is gone or not.
    I used to run it on a 26X.xx for more than a year without any problems. Not sure which one maybe it was even older. Never change a running system but it takes some time to fine a new working one as it seems.
     
  8. nickjf20 macrumors member

    Joined:
    Jan 2, 2009
    #8
    Fix

    Google laptopvideo2go and download the latest certified from there.

    I had the exact same problem with the 270.61 and spent ages trying to fix it, but my mbp restarted everytime I plugged in the external.

    Downloading the laptopvideo2go drivers fixed everything and made BC2 run 40fps on medium :D
     
  9. Constantine1337 macrumors 6502

    Joined:
    Dec 3, 2009
    #9
    I have the same issue. Ended up reinstalling Windows 2 times because I thought it was OS problem. I currently have the default bootcamp drivers. Can anyone just explain how does one search for appropriate drivers on laptopvideo2go.com?
     
  10. NotoriousBOG macrumors newbie

    Joined:
    Jul 3, 2007
    #10
    I tried the 275.33 drivers this morning, and the same external monitor issue persists. Downgrading to the 267.76 drivers again...*sigh*.

    (No need to download the drivers from laptopvideo2go.com either -- they link directly to the drivers available on nVidia's site.)
     
  11. Constantine1337 macrumors 6502

    Joined:
    Dec 3, 2009
    #11
    Can you report if the drivers 267.76 drivers work?
     
  12. treegirl macrumors newbie

    Joined:
    Apr 7, 2008
    #12
    Reinstalling Windows worked for me

    Ater trying 3 different drivers from nvidia I decided to reinstall windows 7 in bootcamp. I then hid the evil Nvidia update in windows update that caused all of this and after many hours of reinstalling windows, updating windows, and reinstalling my software I am a very happy camper. Everything is working great. The Nvidia driver that is now running on my mid-2010 macbook is version 196.82, which I cannot find on their website. :( Good luck.
     
  13. RockwellB1 macrumors newbie

    Joined:
    Jun 8, 2011
    Location:
    Ohio
    #13
    I finally found this thread after searching all day for why I could not get my external monitor to work in Win7 bootcamp. I checked and had the latest 275.33 drivers from nvidia so I thought that wasn't it. But I rolled back to 267.76 and my monitor works great now so I can confirm that they work. My monitor is connected through a mini displayport to hdmi cable and I'm able to mirror, extend, or just run the MBP display or the external.

    I can't say if there are any sleep issues or anything since I don't let it sleep, I just always turn it off, but hopefully this will help others having similar issues.
     
  14. Constantine1337 macrumors 6502

    Joined:
    Dec 3, 2009
    #14
    Thanks for the info. I'll try the 267.76 later today and see how it works.
     
  15. Jottle, Aug 17, 2011
    Last edited: Aug 17, 2011

    Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #15
    bump. Anyone installed any official nvidia driver updates lately that don't cause this bug on our mbp's? The latest is 280.26 as of 8/9/11. Please post updates as I'd like to upgrade my video card driver again in boot camp.
     
  16. dwaxs macrumors newbie

    Joined:
    Aug 25, 2011
    #16
    Yeah I tried the 280.26 but mini dp still doesn't work. I'm using 267.76 right now.
     
  17. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #17
    Thanks for reporting! Hopefully, this gets fixed in a future driver update.
     
  18. benj07 macrumors member

    Joined:
    Oct 26, 2007
    #18
    Tried the latest driver and had problems. Currently using 267.76. I used the latest driver for quite awhile and for what it's worth, I didn't notice any difference in game performance at all. The windows experience score for graphics actually went up 0.1 after I downgraded to 267.76.
     
  19. Wafflausages macrumors 6502

    Joined:
    Jun 27, 2010
    #19
    Well if your in bootcamp I had the same problem don't know if my fix would work for you. I had to disconnect my external monitor then install the drivers after everything was good I just reconnected it and my ext monitor got detected :D
     
  20. dadopap macrumors newbie

    Joined:
    Sep 13, 2011
    #20
    problem solved (at least for me)

    I had the same problem, it seems that something is wrong with the old settings I solved it in this way:

    press Start Key + P (like you connect a projector) until you see both monitor enabled
    then you go on the windows screen resolution settings and you reset your monitor as it was before (for me extended desktop).


    hope it works for you!
    Cheers
     
  21. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #22
    Bump. Is this problem still happening on the 285.62 drivers?
     
  22. ElHummer macrumors newbie

    Joined:
    Oct 7, 2009
    #23
    It's still not working, at least not for me.

    No luck, even with 285.79
     
  23. crmega05 macrumors newbie

    Joined:
    Jan 1, 2008
    #24
  24. ElHummer macrumors newbie

    Joined:
    Oct 7, 2009
    #25
    It seems to me that the new 290.36 beta drivers resolve the issue with a not working external display over mini dp.

    At least for me.
     

Share This Page