curtisinoc

macrumors 6502
Original poster
Mar 13, 2011
258
0
Southern California
I have 2 "Skype" icons in Launchpad after upgrading Skype today. Both icons launch same version of Skype. How do I remove one of these icons? Click and hold for "jiggly" doesn't work (no "x") and can't move one to the trash can in dock.

Any help would be appreciated.
 

mrgraff

macrumors 65816
Apr 18, 2010
1,018
712
Albuquerque
You can't.

You can't remove icons from Launchpad unless they are apps bought from the Mac AppStore. Try working out if you have two Skype apps in your Applications folder and delete one of those, or uninstall Skype altogether and re-install it to get just one icon. You can also create a folder of unneeded icons in Launchpad and hide one of them in there, but you'll have at least two icons in that folder.
 

imahawki

macrumors 6502a
Apr 26, 2011
612
8
Launchpad is a freaking MESS at this point. Hopefully they fix it in an upgrade.
 

curtisinoc

macrumors 6502
Original poster
Mar 13, 2011
258
0
Southern California
You can't.

You can't remove icons from Launchpad unless they are apps bought from the Mac AppStore. Try working out if you have two Skype apps in your Applications folder and delete one of those, or uninstall Skype altogether and re-install it to get just one icon. You can also create a folder of unneeded icons in Launchpad and hide one of them in there, but you'll have at least two icons in that folder.

Thanks. Checked "application" folder and I have only one "skype" in there. I guess I'll just patiently wait for apple to fix this in a future update.
 

Brendan03

macrumors member
Aug 9, 2011
68
1
Brisbane, Aus.
Hi there.

I don't know if this is the same issue as I was having, with two Skype icons.

I had one which was simply "Skype" and the other was ".Skype_Upgrade" which I couldn't get rid of.

I found this thread a few moments ago looking for answers myself and considered what was mentioned here, so I removed Skype from Applications, placing it into trash, then I emptied trash, went to Launchpad with .Skype_Upgrade still there, clicked on it which resulted in a question mark over it, then I attempted to drag it to the Trash and it vanished.

I think re-installed Skype and everything now seems fine and dandy.

I don't know if this will help you but I figured I'd post my experience here in hope that it does help.

Thanks
Brendan.
 

curtisinoc

macrumors 6502
Original poster
Mar 13, 2011
258
0
Southern California
Hi there.

I don't know if this is the same issue as I was having, with two Skype icons.

I had one which was simply "Skype" and the other was ".Skype_Upgrade" which I couldn't get rid of.

I found this thread a few moments ago looking for answers myself and considered what was mentioned here, so I removed Skype from Applications, placing it into trash, then I emptied trash, went to Launchpad with .Skype_Upgrade still there, clicked on it which resulted in a question mark over it, then I attempted to drag it to the Trash and it vanished.

I think re-installed Skype and everything now seems fine and dandy.

I don't know if this will help you but I figured I'd post my experience here in hope that it does help.

Thanks
Brendan.

Thanks Brendan. I'll try your suggestion when I get home.
 

ashkan2200

macrumors newbie
Jul 23, 2011
7
0
Hi there.

I don't know if this is the same issue as I was having, with two Skype icons.

I had one which was simply "Skype" and the other was ".Skype_Upgrade" which I couldn't get rid of.

I found this thread a few moments ago looking for answers myself and considered what was mentioned here, so I removed Skype from Applications, placing it into trash, then I emptied trash, went to Launchpad with .Skype_Upgrade still there, clicked on it which resulted in a question mark over it, then I attempted to drag it to the Trash and it vanished.

I think re-installed Skype and everything now seems fine and dandy.

I don't know if this will help you but I figured I'd post my experience here in hope that it does help.

Thanks
Brendan.

same issue as you and I did the same thing, worked for me
 

EvanLugh

macrumors 68000
Aug 29, 2007
1,929
1
Developer land
Launchpad Controller might be of some use to you

Launchpad_Controller.jpg
 

sashakla

macrumors member
Feb 8, 2010
34
1
Here we go: https://discussions.apple.com/thread/3249085?start=0&tstart=0

The solution presented by Purpleshift worked for me, although I moved it to Trash, instead of moving it to Desktop. Dragging to Desktop was only creating a shortcut on the Desktop for some reason. Guess I should have Control-dragged, or something, but it doesn't matter. Got it to work - that's what counts!

So, changing it to the way I did it, with the diff in bold:

It happened to me as well after the last upgrade and i fixed it with a "windows-like" trick:

1) move skype from your application folder to Trash

2) open lounchpad and you should see Skype icon(s) disappear.

3) put skype where it was

at the end of this i still had only one skype icon in my lunchpad.
 

baryon

macrumors 68040
Oct 3, 2009
3,650
2,096
I also have two Skype icons after the update. Here's my solution:

Open.jpg

Sure, you can mess around with special apps, deleting apps and restoring them, and then uninstalling and reinstalling them, but just for an icon, it's not worth the hassle. Especially that this stupid Launchpad is supposed to be very user-friendly.
 

OutGolfn

macrumors regular
Aug 8, 2010
163
56
Here we go: https://discussions.apple.com/thread/3249085?start=0&tstart=0

The solution presented by Purpleshift worked for me, although I moved it to Trash, instead of moving it to Desktop. Dragging to Desktop was only creating a shortcut on the Desktop for some reason. Guess I should have Control-dragged, or something, but it doesn't matter. Got it to work - that's what counts!

So, changing it to the way I did it, with the diff in bold:

It happened to me as well after the last upgrade and i fixed it with a "windows-like" trick:

1) move skype from your application folder to Trash

2) open lounchpad and you should see Skype icon(s) disappear.

3) put skype where it was

at the end of this i still had only one skype icon in my lunchpad.

This worked, thanks!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.