upgrading a Ziphoned Bootloader

Discussion in 'Jailbreaks and iOS Hacks' started by Yoram, Apr 1, 2008.

  1. Yoram macrumors newbie

    Joined:
    Jun 30, 2007
    #1
    Well, I'm not quite sure what to think. Is it possible to upgrade the bootloader after having used Ziphone (which incidentally I have done already)? Ziphone downgraded mine to 3.9
    Now in some forums they've written it isn't possible, as it is a "permanent" downgrade and would require disassembly of the phone - hang on - why do I have to disasemble it if I didn't have to do so to downgrade it in the first place?
    Soem other people wrote that there's "Tons of software out there" that would upgrade the bootloader - haven't found any of that.

    Any advice on this issue would be much appreciated!
    cheers!
     
  2. bhsu21 macrumors 6502

    Joined:
    Feb 25, 2008
    Location:
    Jacksonville, FL
    #2
    As far as I know from what I have read, your bootloader is stuck at 3.9. That is because you used Ziphone. If you had used IPlus or ILiberty you would have had a 3.9BL and that would be reversable.
     
  3. Hudzilla macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #3
    The bootloader shouldnt be an issue as the 4gb and pre week 45 iphones all have it, so as long as you edge, wifi, and calls are working, don't worry about it!
     
  4. phytonix macrumors 6502

    Joined:
    Jan 26, 2006
    #4
    Ziphone developer claimed that Apple can release update when they feel necessary and it can be upgraded.

    Because many iPhones have 3.9 so it is not a problem.
     
  5. ian-frs macrumors 6502

    Joined:
    Apr 12, 2007
    Location:
    Jax
    #5
    I have used ziphone on a OTB 1.1.3 to unlock the phone at 1.1.4 and then DFU'd my phone and reupdated. It went from the 3.9 BL to the 4.6 BL. So my assumption is that when you DFU your phone you will not have a problem updating the BL.
     
  6. the_insider macrumors regular

    the_insider

    Joined:
    Apr 20, 2005
    Location:
    USA / UK
    #6
    what about with the Pwnage tool? wouldnt this program upgrade a ziphoned 3.9 bootloader?
     
  7. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #7
    You can't upgrade your bootloader if its 3.9 original and was downgraded by ZiPhone... Its not possible - well it might be because of:

    Pwnage

    Apparently - and until it is released we can't be sure pwnage can flash the original 3.9 bootloader either way.

    But thats not confirmed and it may not be the case... You will have to wait and see!
     
  8. Yoram thread starter macrumors newbie

    Joined:
    Jun 30, 2007
    #8
    Well, thanks for your replies everyone! What exactly is DFU? If that doesnt work I guess I'll have to wait for someone to come up with a way to flash the bootloader.
     
  9. auburnfan24 macrumors regular

    Joined:
    Mar 6, 2008
    #9
    sooooo....i did the deed and jailbroke with ziphone...i know i know, bad, dont do it, BL issues, etc...so i read and restored last night.

    so now i am scared that come june and the sdk update...i will be screwed. true? i have not a clue. i am confused :confused: help?
     
  10. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #10
    Ok people good news for those people who have had their iPhone downgraded to 3.9 from 4.6.

    Pwnage tool for Mac can "Pwn" your iPhone and install custom [already pre-jailbreaked, pre-activated and pre-unlocked] firmware into the iPhoen straight from iTunes. You can also install BootNeuter which can update your Bootloader back to 4.6 and have the bootloader neutered and have the baseband unlocked regardless of baseband version.

    Also, for those using Winodws, WinPwn does the same as Pwnage tool. The only difference as of now is that WinPwn is in Beta stage and has BootNeuter disabled. However, there is no need for panic. To use you iPhone if you WinPwn just do the following>>

    1. Pwn you iPhone using WinPwn.
    2. Create a Custome IPSW that is activated, you can customize the images of boot-up and recovery mode if you wish.[iPhone firmware]
    3. Install your custom IPSW using iTunes
    4. Once everything is running go to Installer and add iClarified as source
    5. Install from the Install tab iClarified category "BootNeuter"
    6/ Once installed run on your iPhone with the settings you want.
    >>>> NOTE: Optimal settings are Neuter 'ON' Fakeblank 'OFF' and Unlcok 'ON' <<<<
    >>> You can choose which Bootloader you want, just tap the version you like and BootNeuter will do the rest <<<
    7. Tap Flash and WAIT the process will take some time DO NOT interrupt of let the iPhone go to standby.
    8. After BootNeuter process is over Reboot iPhone and enjoy.
     
  11. auburnfan24 macrumors regular

    Joined:
    Mar 6, 2008
    #11
    all great info and thank you. but i am not the type of person to do this. can i just wait for the sdk and update it? :confused: will the 3.9 affect me since early owners are on it as well?? ahhh!
     
  12. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #12
    Since many iPhone owners already have 3.9 don't worry about it. Just don't use ZiPhone again.
     
  13. auburnfan24 macrumors regular

    Joined:
    Mar 6, 2008
    #13
    yeah, dont plan on it....im just worried now since i have been reading about an irreversible BL that will affect all future updates...and that really worries me. but thanks for your help
     
  14. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #14
    Nah, future updates won't be screwed up due to 3.9. Remember many people have 3.9 originally and are on official contracts. Bootloader can be reversed back to 4.6 thanks to Pwnage, so don't worry.
     
  15. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #15
    If you have already jailbroke/unlocked your iPhone through ziphone you don't need to go through the whole pwnage tool process. You can just install BootNeuter and run it.
     

Share This Page