URGENT help needed!

Discussion in 'Mac Basics and Help' started by VeganBryan, Jan 16, 2008.

  1. VeganBryan macrumors member

    Joined:
    Jan 25, 2006
    #1
    my macbook was working fine last night. starting this morning it wouldn't boot up. it turns on, does the tone, shows the apple, and the progress indicator, but then just hangs eternally.

    i ran disk utility and verified the disk, it said it was okay. however, i did get an error when i tried to verify/repair permissions. something about there being no valid packages.

    i then booted up in verbose mode and it keeps doing this same message every 10 seconds, so i suppose this is where it is stuck:

    Code:
    Jan 16 20:28:54 bryans-macbook com.apple.launchd[1] (com.apple.mDNSResponder[16]): posix_spawnp("/usr/sbin/mDNSResponder", ...): No such file or directory
    the only part that changes is the number in brackets after the first "mDNSResponder". it increases by one each time.

    i am a college student and really need my laptop to be working. i am using my roommate's to post this right now. please help.:(
     
  2. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #2
    Here is a helpful thread detailing a fix.

    You will need to boot up in safe mode (hold the shift key during startup).

    You then need to check /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist to make sure it isn't messed up (as described in the link).
     
  3. iCube macrumors 6502

    Joined:
    Nov 3, 2007
    #3
    Do you remember if your HD was a Seagate?
    Was your HD full or close to being full?
    Were you using 10.4 or 10.5?
     
  4. VeganBryan thread starter macrumors member

    Joined:
    Jan 25, 2006
    #4
    checked it. it's not messed up. tried to edit the file like the guy in the link said. but then it says "Error writing [FILE NAME]: Read-only file system ]

    i think i might have screwed up my permissions on my hard drive, because i was messing with my file-sharing preferences yesterday.
     
  5. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #5
    Well the thing that is messed up is related to bonjour networking. Did the computer crash while you were doing anything?

    At the moment all I can suggest is to try reinstalling and hoping that fixes it.
     
  6. VeganBryan thread starter macrumors member

    Joined:
    Jan 25, 2006
  7. VeganBryan thread starter macrumors member

    Joined:
    Jan 25, 2006
  8. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #9
    I was too. Did booting into safe mode at least work?
     
  9. VeganBryan thread starter macrumors member

    Joined:
    Jan 25, 2006
    #10
    it just hangs even when i try to boot into safe mode.
     
  10. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #11
    And if that wasn't the fix in single user mode then you're pretty much out of options. At least the options I'm aware of.
     
  11. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #12
    One way...

    I made a copy of these files and put them on an external drive, then i deleted these files, I have not seen any of those messages again, if your system starts acting funny then just put them back or, install Leopard on an external drive, get these same files from the fresh install and replace them and the affected computer, I have not had any issues so far without them.
     
  12. shamino macrumors 68040

    shamino

    Joined:
    Jan 7, 2004
    Location:
    Purcellville, VA
    #13
    I realize that this answer comes months too late, but I just saw this problem today and I solved it. This message is so anybody else getting in this situation will find it when Googling for help (much as how I found this thread today.)

    This morning, I went into the File Sharing configuration. I added my root directory (the disk volume) as a shared item. In doing so, the system presented default permissions that grant "everybody" read-only access to the volume. Since I don't want network-guest users to access all my files, I removed those permissions.

    What I didn't realize at the time was that the file sharing system manipulates file system permissions in order to configure this. So when I removed "everybody" access from the drive, the permissions for "/" were reset to "rwxrwx---".

    At that point, parts of the system started acting weird (printer not working, keychains not unlocking, etc.). When I rebooted, I got the same symptoms you reported. The startup scripts (which are obviously not running as "root" or the "admin" group) could no longer read anything, making key files (like /usr/sbin/mDNSResponder) inaccessible, making the boot process hang.

    The solution:
    • Boot into single-user mode (boot while holding down CMD-S)
    • Follow the on-screen instructions to mount the file system as read-write (a fsck command followed by a mount command)
    • Type the following: "chmod o+r /" followed by "chmod o+x /"
    • Type "exit" to leave single user mode and complete the boot sequence.

    I filed a bug report on this with Apple feedback telling them that:
    • Modifications to file sharing permissions should not change file-system permissions
    • It should never be possible for an action from a system preference panel to render the system non-bootable
    • The boot sequence should check for this situation (bad permissions on the root directory) and automatically reset them. There really is no legitimate reason for these kind of permissions, since all they do is render the system useless.

    Hopefully, these will be addressed in a future service pack (but I won't be trying it out, if they are.)
     
  13. drew3 macrumors newbie

    Joined:
    Mar 27, 2008
    #14
    thanks and a Q

    thanks for posting this, as i did this very thing last night. i changed "everybody"s permission to "no access" to prevent unknown users from seeing my stuff (went through get info on my hard drive -> sharing and permissions -> everybody and changed from read only to no access). what i didn't know was that by everyone they meant me too. a little error message would have been nice. anyway, a quick question, after i type chmod o+r / do i hit enter or do i then type chmod o+x / and then hit enter? i realize this thread was buried but hopefully shamino or someone can answer. i won't be able to try this until this afternoon anyway until i get home from work. on a side note been lurking these boards for a while, but this issue has prompted me to join, as i was freaking out. thanks in advance for any help

     
  14. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #15
    Apparently it even made it into the thread I posted at the top of the page a few days later. Neat.
     
  15. shamino macrumors 68040

    shamino

    Joined:
    Jan 7, 2004
    Location:
    Purcellville, VA
    #16
    Hit enter between the two commands.

    I think you can combine them together into one command: "chmod o+rx /", but when working on something this critical, I like to make each step as simple as possible, just in case I mis-remembered the correct syntax.
     
  16. WindowsOrMac macrumors newbie

    Joined:
    Feb 14, 2008
    #17
    Thank You!

    Oh my god... thank you so much for this fix. I had a feeling it was a simple fix if only I knew what commands to type. Wow. what a huge, gaping problem... Whoosh, okay.

    FYI, if you try to archive and install to fix this problem it won't work (probably because write access has been turned off), good thing I didn't get frustrated enough to erase and install...

    ALSO, I think this breaks Time Machine backups (it won't back anything up) when the permissions have been changed in this way, I'll confirm once I get home and it tries to back things up. Thanks again.

    w.
     
  17. InfraEngineer macrumors newbie

    Joined:
    Apr 29, 2008
    #18
    AWESOME!!! Saved my neck!

    :D
    I just bought this nice new iMAC (newby unfortunately) and tried to do updates. However, being a PC man with MANY years experience in security and patching etc., I found a little thing called Everyone with Read Only on my shared files.. I thought I would tighten up security a little:eek:
    Guess not! This little bit of info saved my bacon!

    Thanks a million (just dont try to collect):D

     
  18. Radroz macrumors newbie

    Joined:
    May 1, 2008
    Location:
    Clarksville, TN
    #19
    Perfect!

    This solution is EXACTLY what I needed. The closest Mac service store/retailer is over an hour's drive, and I just didn't have the time to waste in the car (or the gas money!)

    Thank you... as always, a little persistence will pay off! :D
     
  19. mojohojo macrumors regular

    Joined:
    Nov 24, 2006
    #20
    Urgent Help Needed 2!!!

    hi, i've got the same problem as the OP.

    to let you know what happend:
    there was some file which was locked on my external HD, that couldnt be deleted. so i followed the instructions on this help:
    http://support.apple.com/kb/TS1402

    which told me to use the terminal:
    Option 3 (Advanced) -

    1. Open Terminal (/Applications/Utilities).
    2. Type: sudo chmod 775 /
    3. Press Return.
    4. Enter your password and press Return.
    5. Using the Finder, move the item(s) to the desired location.
    6. In the Terminal, type: sudo chmod 1775 /
    7. Press Return.

    this did not help my problem. instead program stopped working, and i saw the Macintosh HD with a 'stop' symbol next to it, i couldnt open it.

    i thought to restart my macbook hoping it would solve this, but now it won't even startup! it stops at a blue screen. trying to repair disk permission form the bootup disk says 'no valid packages'

    i tried the CMD+S, type FSCK, MOUNT, chmod o+r, chmod o+x, exit, but it still does not start up!!

    URGENT HELP PLS! got lots of work due in and im stressed!
     
  20. redmachine macrumors member

    Joined:
    Dec 4, 2007
    #21
    this thread is genius! saved me losing everything, thanks so much!
     
  21. raph959 macrumors newbie

    Joined:
    Sep 12, 2008
    #22
    Hello everyone, I had the same problem and "fixed" it using mount -uw / then chmod 775 /

    The only problem is that I have to do this each time I boot... apparently the HD is locked. I can unlock it once the Mac is up and running, but on each reboot the drive will lock itself up again. I tried to repair authorisations using Disk Utility and I also tried to login as root to unlock for good, but nothing's worked. Any advice?

    Thanks!
     
  22. itskathywithak macrumors newbie

    Joined:
    Feb 12, 2009
    #23
    Better late than never!

    OMG.. I joined the forum just to say 'thanks'. I thought I was facing a reinstall until I found this answer and it worked. I too was fiddling with the 'everyone' permission. Should have known better. thx.

     
  23. ibelee macrumors newbie

    Joined:
    Jun 20, 2009
    #24
    Outstanding Fix!!!


    I've spent several hours on several sites trying to fix this same problem....shamino...you are a genius...I was so close to reinstalling...this fix is excellent and simple...it should be posted EVERYWHERE macs are talked about...thank you! thank you! thank you!:)
     
  24. Wyvyrn macrumors newbie

    Joined:
    Jul 30, 2009
    #25
    Many thanks, shamino

    Thanks for your very helpful post. This is exactly what I did with my Macintosh HD's permissions, not realising that it would affect more than guest users. I had forgotten I had played with the permissions until I happened on your post after a few hours' angst and searching for a solution.

    Perfect, thanks. I agree, it should know better than to let me break my system from a Preferences Panel!

    W
     

Share This Page