USB 3.0 via Dell Monitor worked for Mac Pro 3,1 but not 5,1, any ideas?

Discussion in 'Mac Pro' started by lewis_cooper, Jul 5, 2017.

  1. lewis_cooper macrumors newbie

    lewis_cooper

    Joined:
    May 9, 2016
    Location:
    London, UK
    #1
    Hi all,

    I have cMac Pro connected to a Dell U2713H monitor. The monitor has USB 3.0 ports on the side and an SD card reader. There is a USB 3.0 cable that runs from the back of the monitor to a USB 3.0 port (via Inateck PCIe card) on the Mac Pro.

    When the Mac Pro was a 3,1 model everything worked as expected without the need for drivers. All USB and SD card ports worked at USB 3.0 speeds through the monitor.

    However, I've recently switched the cMac Pro for a 5,1 model and none of ports mount anything I connect. It doesn't even appear to send power as it won't charge my iPhone via its cable and the LED on my pen drive doesn't light up.

    Can anyone suggest why this might be?

    For what it's worth, every single component is identical other than the Mac itself.

    I read once that OS X installs drivers it needs based on the configuration of the mac at install time. Could it be that because I restored from Time Machine I have my old mac's drivers? Does that ring any bells to anyone?

    Thanks in advance
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    Some Dell monitors, like mine, have two upstream USB ports (see "SS1" and "SS2" in the following image). If you have two like that, try connecting the cable to the other port.

    [​IMG]

    If that doesn't work, make sure whatever SS port that connects to the Mac is mapped in the monitor's configuration to whatever input (DP, mDP, etc) that you are now using. This is in the USB Selection menu.
     

Share This Page