Vertex 3 2011 Macbook Pro 17" pathetic read performance.

Discussion in 'MacBook Pro' started by PrimalNaCl, May 10, 2011.

  1. PrimalNaCl macrumors newbie

    Joined:
    May 10, 2011
    #1
    Greetings,

    I'm seeing some disturbingly pathetic read performance on my shiny new 17" MacBook Pro w/my equally shiny and new Vertex 3 SSD.

    Here are the Xbench results:

    Code:
    	
           Disk Test	154.09	
    		Sequential	105.64	
    			Uncached Write	503.08	308.88 MB/sec [4K blocks]
    			Uncached Write	521.73	295.19 MB/sec [256K blocks]
    			Uncached Read	91.73	26.85 MB/sec [4K blocks]
    			Uncached Read	43.36   21.79 MB/sec [256K blocks]
    		Random	284.65	
    			Uncached Write	2638.43	279.31 MB/sec [4K blocks]
    			Uncached Write	920.23	294.60 MB/sec [256K blocks]
    			Uncached Read	2886.75	20.46 MB/sec [4K blocks]
    			Uncached Read	81.70   15.16 MB/sec [256K blocks]
    
    And here are the AJA System Test results:

    Code:
             I/O Transactions
      Frame     MB/sec
               Read      Write      
    00.0      287.9      511.4      
    01.0      510.3      234.7      
    02.0      511.7      460.6      
    03.0      13.9      453.8      
    04.0      506.7      465.6      
    05.0      501.0      473.4      
    06.0      503.8      474.7      
    07.0      496.6      484.8      
    08.0      16.1      500.1      
    09.0      491.3      469.7      
    10.0      509.4      472.5      
    11.0      14.4      494.8      
    12.0      15.6      479.7      
    13.0      15.6      481.2      
    14.0      192.1      500.4      
    15.0      193.0      503.5      
    16.0      515.5      485.5      
    17.0      503.8      468.0      
    18.0      15.0      470.5      
    19.0      508.7      504.2      
    20.0      505.9      471.9      
    21.0      506.9      473.1      
    22.0      16.0      502.8      
    23.0      14.4      474.2      
    
    
    Note the 'drop-outs'. Settings were:

    Test: Disk Read/Write
    Video Frame Size: 1920x1080 10-bit
    File Size: 128 MB
    Video Device: <empty>
    Disable file system cache: <checked>

    The overall/average(?) stats in the box to the right of the test show:
    Write: 439.3MB/s
    Read: 40.1 MB/s

    This is really wretched. I've seen some mention of problematic SATA cable but I've not seen this as a noted symptom.

    From hardmac.com:
    "Different problems can occur, and are more or less serious. It ranges from the unrecognized SSD to the SSD blocked during installation or in some cases, a temporary freezing with a "death wheel"."

    Anyone else have this or any ideas?

    Thanks,
    --Gary
     
  2. altecXP macrumors 65816

    Joined:
    Aug 3, 2009
    #2
    It's due to having a 17in. OWC makes a shield for the SATA cable in the 17in that fixes the problems.
     
  3. mjohnson1212 macrumors member

    Joined:
    Nov 15, 2007
  4. madonionrings macrumors member

    Joined:
    Jun 10, 2007
    #4
    After reading the previous posters link, I am not sure this issue has truly been resolved. It appears that the shielding kit provides inconsistent results on the 17 inch.

    As someone who is in the market for a 17 inch with intent to upgrade to a Vertex 3 SSD, this is troubling to say the least.

    Can anyone else provide further insight or share their own personal experience with the matter?
     
  5. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #5
    Should apple not replace affected MBPs? Surely if this is a manufacturing issue apple need to address it?

    I for one copped a new MBP for a sata-6G as well as TB
    both of which have been a let down!

    I'm planning of gettin the new owc 240gb drive- after anands r/v I think in leaning towards the vertex 3 now
     
  6. rolexman1008 macrumors newbie

    Joined:
    Apr 12, 2011
    #6
    Diglloyd had his 17 replaced by Apple n is working very well with a OWC 6G 240GB.

    Matters seem to be a Russian Roulette installing SATA 3 SSDs into 2011 MBP 17. Some worked, some are lemons.

    Hence, just stay away for the moment. If u really need an SSD, like I did, I went for reliability, sacrificing speed until these issues are settled: Intel 320.
     
  7. NickZac macrumors 68000

    NickZac

    Joined:
    Dec 11, 2010
    #7
    What is your actual link speed? I ask this as it looks like your speeds are all cutting off at SATA2's max. If it is the cable, I would send the computer back and demand it be fixed. With that said, some posts I have read have made me question if that is the real reason for the observed issues. Who knows about that, but so what is your link speed? 3.0 or 6.0?
     
  8. rocque macrumors newbie

    Joined:
    Mar 9, 2011
    #8
    I've had issues with my OWC Mercury Extreme Pro 6G in my 2011 17", but with a different twist. I seem to get performance consistent with SATA 3G (240 write/250 read with AJA). When I check System Profiler, the negotiated link speed seems to flip between 3G and 6G depending on whether I reset the computer/power cycle the computer/PRAM reset the computer/etc. It's inconsistent, but benchmarks seem to indicate constant 3G configuration.

    I just received the OWC shielding kit today, but I'm doubting if this would fix anything at all. I'm tempted to buy a different SATA 6G SSD to see if it's the drive that's the culprit. Otherwise, it's the computer... is the SATA cable problem known to cause this sort of behavior?
     
  9. PrimalNaCl thread starter macrumors newbie

    Joined:
    May 10, 2011
    #9
    I've heard an overwhelming majority of horror whenever one has to surrender their notebook to Apple. I fear inheriting someone else's less obvious issues w/some damnable refurbished POS.

    But I'm also concerned about the logistics of the 'ordeal' in the first place. To demonstrate the issue for a 'genius' I'd have to show up with unit + ssd. Then I'd have to remove the ssd, extra ram, and replace those items w/what the unit was originally shipped. I've never seen anyone doing any kind of surgery at the 'genius' bar so I'm not even clear what the protocol in that/this situation would be.

    Prior to any of that however, this Sunday I'm going to my friend's place to do a bit of drive swapping try to narrow down which item is at fault. He purchased his at the same time as I did. He was able to get his vertex before me but they are the same model devices. I am hoping it's the ssd as I would envision OCZ/NewEgg being infinitely easier to deal with than Apple.

    Thanks,
    --Gary
     
  10. PrimalNaCl thread starter macrumors newbie

    Joined:
    May 10, 2011
    #10
    System Profiler shows both link and negotiated speed of 6Gb. The only time I've seen it veer from that is w/the stock 5400 mechanical drive. That was the expected 6/3 respectively. It was the first thing I did after the fresh install to the ssd.

    Thanks,
    --Gary
     
  11. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #11
    Is it me, or something just does not feel right about the 17" MBP, i mean this has to be one of the most awesome upgrades to the MBP - however, also one of the most troublesome too! I feel this update was very rushed, and hence waited 6 wks till after the release date for a CTO, and lay and behold had i waited a week or 2 more, i would of copped a SATA 6/6: HDD/ODD :mad:

    Now, if my lil baby does not sit well with a sata-6G drive - im gonna be enraged
    i mean there was a catalogue of failures in my orders- but i swallowed them up and did not make a fuss. If my V3 does not work i will be livid, and will demand a new machine - i finally have my machine how i like it!
     
  12. mac jones macrumors 68040

    Joined:
    Apr 6, 2006
    #12
    What a mess this is. What makes it so disturbing is that this shielding mod doesn't seem to be 100% effective.

    Best to just go with a good SATA 2 drive. DO IT! don't obsess over a little gain. The SATA2 drives are just as fast. Wait until it's resolved and then buy the desired drive. If you try to troubleshoot this now, you are asking for a huge headache.

    It's not the end of the world, and a minor issue really as SATA 2 is fine even for the hard core.
     
  13. Knuck macrumors newbie

    Joined:
    Mar 29, 2011
    #13
    I have the same setup. Early 2011 17" with 240 gb Vertex 3.

    Here are my results at 1920x1080 10 bit, 128 MB:


    I/O Transactions
    Frame MB/sec

    Read Write
    00.0 519.7 185.2
    01.0 517.4 485.5
    02.0 511.6 492.2
    03.0 517.1 469.9
    04.0 526.6 492.3
    05.0 528.7 507.3
    06.0 522.6 494.0
    07.0 527.2 482.8
    08.0 522.8 484.2
    09.0 527.7 315.0
    10.0 525.6 524.8
    11.0 527.6 522.7
    12.0 523.0 526.6
    13.0 525.3 526.0
    14.0 520.6 521.8
    15.0 523.1 522.1
    16.0 525.0 524.7
    17.0 519.4 528.1
    18.0 522.8 525.7
    19.0 527.6 523.6
    20.0 528.0 521.4
    21.0 526.5 522.6
    22.0 526.8 525.7
    23.0 513.5 521.3
     
  14. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #14
    wow- awesome speed u got!

    did you do that ridiculous sata wire shield mod?
     
  15. Knuck macrumors newbie

    Joined:
    Mar 29, 2011
    #15
    No, just installed the Vertex 3 into the HDD bay.
     
  16. mpkayeuk macrumors member

    Joined:
    Feb 3, 2010
    #16
    Same here, just slapped it in the HDD bay (OptiBay for original HD) and it works like a charm, I get similar results to you.
     
  17. sunnyd76 macrumors newbie

    Joined:
    Dec 15, 2009
    #17
    Has anyone heard about the LPM (link power management) disabling fix under windows 7? Saw it on the crucial forums, seems to have fixed a bunch of crucial C300 issues. I'm hoping it'll fix my M4, tonight!

    I'm running a MBP 2011 17", 8Gb, M4 256GB with bootcamp... if this works then it's probably a safe bet that Apple will fix this issue in an update. But what this doesn't answer is why people like mpkayeuk, knuck and johnnyturbouk don't appear to have any issues whatsoever! I recon it's probably a hardware and software issue, hardware= cable shielding, software= LPM tweaks

    http://forum.crucial.com/t5/Solid-State-Drives-SSD/Solution-C300-Disk-Freeze-ups-in-Windows-7-solved-for-me/td-p/38766
     
  18. mauritsb macrumors newbie

    Joined:
    May 7, 2011
    #18
    My numbers are also in the low 500's, see below (Vertex 3 - 120). I did nothing other than installing it in the HDD bay, make two partitions and reset PRAM/SMC. I have a 17" 2.2 MBP with 6/3 SATA ports. Runs great!

    No shielding, no tweaks. Even the EFI 2.1 does not show up in my list of installed software. I do have the MacBook Pro Software Update 1.4. Software Update says there is nothing to update on my system.


    I/O Transactions
    Frame MB/sec
    Read Write
    00.0 516.1 509.0
    01.0 519.9 519.9
    02.0 515.0 518.4
    03.0 515.7 520.4
    04.0 523.1 522.7
    05.0 516.5 518.5
    06.0 512.7 523.2
    07.0 519.9 518.6
    08.0 518.6 521.6
    09.0 522.4 522.6
    10.0 514.4 520.4
    11.0 525.8 519.7
    12.0 515.5 516.7
    13.0 522.0 516.4
    14.0 512.7 515.8


    .
    15.0 510.6 515.7
     
  19. Knuck macrumors newbie

    Joined:
    Mar 29, 2011
    #19
    I don't know if the OP or others with performance issues have tried to enable trim. I know many have had problems doing this. I haven't done it and am getting excellent results. I highly recommend against it.
     
  20. JayMBP macrumors regular

    Joined:
    Apr 25, 2011
    Location:
    Richmond, BC/Bellingham, WA
    #20
    I don't see much benefit of enabling trim with MacOS and SF based SSD anyhow.

    I have had my Vertex3 for over a month now and can't tell any performance hit without the trim enabled. As a matter of fact, after the EFI update, it works even faster than when I got it.
     
  21. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #21
    good news

    out of all the sata-6 drives the v3 seems like the most alluring option in my book
     
  22. p1ngputts macrumors member

    Joined:
    Feb 13, 2010
    #22
    i just installed the vertex 3 into my 13" mbp. How do you check the bench marks? I'd like to see where I compare.
     
  23. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #23
    I've been having trouble finding the instructions on how to update the firmware on my MBP and Vertex 3. Any tips for someone with out Bootcamp installed?
     
  24. JasonH42 macrumors 6502

    Joined:
    Feb 9, 2010
    #24
    The first firmware revision for the Vertex 3 only came out a day or two ago and doesn't seem to change much. However, instructions are here. To update your MBP firmware just click on Software Update...
     
  25. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #25
    Good lord! I'll just install Bootcamp\Windows 7.
     

Share This Page