Visual voicemail gone after jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by sd13, Aug 5, 2010.

  1. sd13 macrumors regular

    Joined:
    Jun 16, 2009
    #1
    Anyone else having this problem? Mine shows up as an empty visual voice mailbox. I am not receive any incoming voicemail alerts either.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Try acessing it a few times.
    It will eventually give you the popup to punch in your pin number and it will download all your previous messages.
     
  3. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #3
    Mine hasn't worked since I purchased the iPhone 4 on release day... Ended up installing HulloMail and am using their service instead since AT&T's won't work.
     
  4. sd13 thread starter macrumors regular

    Joined:
    Jun 16, 2009
    #4
    Its not even giving me that popup. It just shows up as an empty mailbox. When i dial 1 to access the voice mailbox, i find new and saved messages. However, when i click on the visual vm tab it shows 0 messages.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    You should call up AT&T and have them reset your Visual voicemail inbox.
    You shouldnt have to use a workaround for something you're paying for.
     
  6. Blueline29 macrumors 68020

    Blueline29

    Joined:
    Jun 16, 2009
    Location:
    Windermere, FL
    #6
    This just worked for me; thanks! TBH, I hadn't even noticed it was missing until just now. Whoops.
     
  7. Dammit Cubs macrumors 68000

    Dammit Cubs

    Joined:
    Jul 31, 2007
    #7
    im getting the same issue. All my old VM's work that are logged. But all new ones do not make it to my phone. i have to call my voicemail to access them.


    Lame. Real Lame.
     
  8. Kayan macrumors 6502

    Joined:
    Jul 7, 2010
    Location:
    CA
    #8
    Seriously, AT&T's visual voicemail is a great feature, and I don't want to have to have another app or subscription to another thing if I'm on AT&T. Now if I went over to TMO, then of course that's a different story not having visual voicemail capabilities at all. MAKE AT&T SERVE YOU for all the money we pay them.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Call up AT&T.
    Maybe its something they need to fix on their end.
    Have them reset your visual voicemail.
     
  10. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #10
    mine works. i just tested mine out. i have a 3gs running 4.0.1.
     
  11. Dammit Cubs macrumors 68000

    Dammit Cubs

    Joined:
    Jul 31, 2007
    #11
    I actually removed the Ultra snow carrier unlock. and restarted my phone.

    I should of just done one instead of both. Now i have to figure out which one fixed the issue.

    Doesn't really matter. what's the point of a carrier unlock if its soft unlocked.

    Visual voicemail now works.
     
  12. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #12
    I went ahead and jailbroke and unlocked my iPhone 4 yesterday and my Visual Voicemail stopped working too. I was about to restore the phone when I decided to try resetting the network settings. It took three tries to get it to work, but after the third try (and rebooting the phone), all 5 of the test voicemails that I sent to myself appeared. But it stopped working sometime after that, so I just uninstalled Ultrasn0w, and voicemail is working fine again. The unlock is a wonderful thing to have, but if I can't get voicemail, it's no good to me. I'll wait until right before I go on vacation to unlock again and just have my voicemail forwarded to Google Voice.
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #13
    Visual voicemail will never work on unsupported carriers with unlocked iphones anyway.
    The visual voicemail feature is offered by official providers only with appropriate iphone data plans.
    So like you said use it now on official carrier and when you need the unlock thats when you install ultrasnow to use other simcards.
    I dont see why you guys install the unlock even though you're using it on AT&T.
     
  14. anonymous6237 macrumors 6502

    anonymous6237

    Joined:
    Nov 3, 2007
    Location:
    Plano, TX
    #14
    I didn't even realize mine wasn't working until this thread caused me to check it. Thanks for this information, it fixed the problem for me.
     
  15. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #15
    Welcome.
     
  16. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #16
    Just trying it out, really. I'd never done it before.

    How do other carriers handle voicemail with the iPhone? Do you just call your own number to check it? And how are you notified that you even have voicemail on the iPhone on other carriers? Same popup, but without the visual option when going to check it?
     
  17. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #17
    Guys, it's ultrasn0w. I was having the same issue and once I removed ultrasn0w the problem immediately went away. I'm with AT&T anyway so I don't need the unlock right now. That has to be the problem because nothing else fixed it but removing ultrasn0w.
     
  18. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #18
    The same old school way. You get a little badge with the number of voicemessages you have.
    When you click the voicemail part it just calls your cellphone number and you enter you pin number and listen to your messages.
     
  19. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #19
    Yes, the problem is definitely ultrasn0w.
     
  20. futbalguy macrumors 6502

    Joined:
    May 16, 2007
    #20
    I did not install ultrasnow and it was giving me a problem. I had to type in the vmail pw again. Im glad I found this thread though because I hadnt noticed I had the problem.
     
  21. iLisa777 macrumors member

    Joined:
    Jun 21, 2010
    Location:
    Ohio
    #21
    Same here. I saw this thread and checked mine.

    Thanks for the thread and the fix.
     
  22. iLisa777 macrumors member

    Joined:
    Jun 21, 2010
    Location:
    Ohio
    #22
    I never installed ultrasn0w so it couldn't have been the problem for me.
     
  23. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #23
    Ok. There are obviously other cause for it then but ultrasn0w is definitely a cause as well. I'm just glad that we were able to figure it out.
     
  24. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #24
    Had same problem. But solved itself.

    Just leave your visual voice mail open and it'll ask you for password after awhile.
     
  25. iLisa777 macrumors member

    Joined:
    Jun 21, 2010
    Location:
    Ohio
    #25
    Absolutely!! I love visual voice mail. :)
     

Share This Page